package/intel-mediadriver: bump version to 22.5.1

Rebased patch 0001.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Bernd Kuhls 2022-07-29 19:59:44 +02:00 committed by Thomas Petazzoni
parent 0ebe86467d
commit 433322ff61
3 changed files with 11 additions and 11 deletions

View File

@ -1,6 +1,6 @@
From 2007edc683499d2e82772f84241b453bdf319372 Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Fri, 10 Jun 2022 18:42:34 +0200
Date: Fri, 29 Jul 2022 19:51:39 +0200
Subject: [PATCH] Fix uClibc build
uClibc does not provide execinfo.h
@ -14,7 +14,7 @@ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
2 files changed, 10 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8305acfdb..6bec00f7d 100755
index 053904748..4a3f0869e 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,12 @@ option (BUILD_CMRTLIB "Build and Install cmrtlib together with media driver" ON)
@ -31,20 +31,20 @@ index 8305acfdb..6bec00f7d 100755
if (BUILD_CMRTLIB AND NOT CMAKE_WDDM_LINUX)
diff --git a/media_softlet/linux/common/os/osservice/mos_utilities_specific.cpp b/media_softlet/linux/common/os/osservice/mos_utilities_specific.cpp
index ff0b68655..8ea621f0e 100644
index bde216b83..120b02d55 100644
--- a/media_softlet/linux/common/os/osservice/mos_utilities_specific.cpp
+++ b/media_softlet/linux/common/os/osservice/mos_utilities_specific.cpp
@@ -51,7 +51,9 @@
@@ -34,7 +34,9 @@
#include <signal.h>
#include <unistd.h> // fork
#include <algorithm>
+#ifdef HAVE_EXECINFO
#include <execinfo.h> // backtrace
+#endif
const char *MosUtilitiesSpecificNext::m_szUserFeatureFile = USER_FEATURE_FILE;
MOS_PUF_KEYLIST MosUtilitiesSpecificNext::m_ufKeyList = nullptr;
@@ -2492,6 +2494,7 @@ void MosUtilities::MosTraceEvent(
#include <sys/types.h>
#include <sys/stat.h> // fstat
#include <sys/ipc.h> // System V IPC
@@ -2473,6 +2475,7 @@ void MosUtilities::MosTraceEvent(
MOS_FreeMemory(pTraceBuf);
}
}
@ -52,7 +52,7 @@ index ff0b68655..8ea621f0e 100644
if (m_mosTraceFilter & (1ULL << TR_KEY_CALL_STACK))
{
// reserve space for header and stack size field.
@@ -2511,6 +2514,7 @@ void MosUtilities::MosTraceEvent(
@@ -2492,6 +2495,7 @@ void MosUtilities::MosTraceEvent(
size_t ret = write(MosUtilitiesSpecificNext::m_mosTraceFd, traceBuf, nLen);
}
}

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 7cfa02442711f4ffa7fc1bd6effda49446a005422a3db4083bbc1a621815f672 intel-media-22.5.0.tar.gz
sha256 17905258374dafe2051073fee5722527c6b756c111b2962af051b37d1fc0df56 intel-media-22.5.1.tar.gz
sha256 74979d5aaee78b8da82e3aafd415a216b6131dfff6d95d6930927c8a4e3bded3 LICENSE.md

View File

@ -6,7 +6,7 @@
# based on https://software.intel.com/en-us/articles/build-and-debug-open-source-media-stack
INTEL_MEDIADRIVER_VERSION = 22.5.0
INTEL_MEDIADRIVER_VERSION = 22.5.1
INTEL_MEDIADRIVER_SITE = https://github.com/intel/media-driver/archive
INTEL_MEDIADRIVER_SOURCE= intel-media-$(INTEL_MEDIADRIVER_VERSION).tar.gz
INTEL_MEDIADRIVER_LICENSE = MIT, BSD-3-Clause