package/libminiupnpc: bump to version 2.2.3

Update hash of license file (update in year)

http://miniupnp.free.fr/files/changelog.php?file=miniupnpc-2.2.3.tar.gz

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2022-06-19 18:50:09 +02:00 committed by Peter Korsgaard
parent c099842544
commit 428e9d74c4
3 changed files with 46 additions and 7 deletions

View File

@ -0,0 +1,43 @@
From f82b0563a72e33800f5918ead68c41bcda1fd4c1 Mon Sep 17 00:00:00 2001
From: heitbaum <rudi@heitbaum.com>
Date: Fri, 1 Oct 2021 00:00:27 +1000
Subject: [PATCH] miniupnpc/CMakeLists.txt: fix install for headers
[Retrieved from:
https://github.com/miniupnp/miniupnp/commit/f82b0563a72e33800f5918ead68c41bcda1fd4c1]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
miniupnpc/CMakeLists.txt | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0553eeb3..6b0904c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,16 +221,16 @@ endif ()
if (NOT UPNPC_NO_INSTALL)
install (FILES
- miniupnpc.h
- miniwget.h
- upnpcommands.h
- igd_desc_parse.h
- upnpreplyparse.h
- upnperrors.h
- upnpdev.h
- miniupnpctypes.h
- portlistingparse.h
- miniupnpc_declspec.h
+ include/miniupnpc.h
+ include/miniwget.h
+ include/upnpcommands.h
+ include/igd_desc_parse.h
+ include/upnpreplyparse.h
+ include/upnperrors.h
+ include/upnpdev.h
+ include/miniupnpctypes.h
+ include/portlistingparse.h
+ include/miniupnpc_declspec.h
DESTINATION include/miniupnpc
)

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 69f72fe355f911b807915f78dcfc0af772c0f22bc7ab1157e70f334e37db7d39 miniupnpc-2.1.20201016.tar.gz
sha256 0b476c395af6dd21eeb54c40a21d22e1c11a751fbd2dd17a41ce26e370be88d5 LICENSE
sha256 dce41b4a4f08521c53a0ab163ad2007d18b5e1aa173ea5803bd47a1be3159c24 miniupnpc-2.2.3.tar.gz
sha256 90bb92bf524970569296022fea562c85a4ec4d99a16f3aef2144d13d7087b631 LICENSE

View File

@ -4,9 +4,7 @@
#
################################################################################
LIBMINIUPNPC_VERSION_MAJOR = 2.1
LIBMINIUPNPC_VERSION_MINOR = 20201016
LIBMINIUPNPC_VERSION = $(LIBMINIUPNPC_VERSION_MAJOR).$(LIBMINIUPNPC_VERSION_MINOR)
LIBMINIUPNPC_VERSION = 2.2.3
LIBMINIUPNPC_SOURCE = miniupnpc-$(LIBMINIUPNPC_VERSION).tar.gz
LIBMINIUPNPC_SITE = http://miniupnp.free.fr/files
LIBMINIUPNPC_INSTALL_STAGING = YES
@ -14,8 +12,6 @@ LIBMINIUPNPC_LICENSE = BSD-3-Clause
LIBMINIUPNPC_LICENSE_FILES = LICENSE
LIBMINIUPNPC_CPE_ID_VENDOR = miniupnp_project
LIBMINIUPNPC_CPE_ID_PRODUCT = miniupnpc
LIBMINIUPNPC_CPE_ID_VERSION = $(LIBMINIUPNPC_VERSION_MAJOR)
LIBMINIUPNPC_CPE_ID_UPDATE = $(LIBMINIUPNPC_VERSION_MINOR)
LIBMINIUPNPC_CONF_OPTS = -DUPNPC_BUILD_SAMPLE=OFF -DUPNPC_BUILD_TESTS=OFF
ifeq ($(BR2_STATIC_LIBS),y)