flex: only prevent the flex binary to be built for target, not for host
We do want to build the flex binary when building host-flex since it's needed as a build dependency for other packages. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
3525b970c0
commit
41ee484baf
@ -1,4 +1,4 @@
|
|||||||
flex: prevent flex binary to be built
|
flex: disable documentation
|
||||||
|
|
||||||
Since we prevent the flex binary to be built, we also need to prevent
|
Since we prevent the flex binary to be built, we also need to prevent
|
||||||
the documentation to be built, otherwise it will fail like this:
|
the documentation to be built, otherwise it will fail like this:
|
||||||
@ -21,15 +21,3 @@ diff -rup a/Makefile.in b/Makefile.in
|
|||||||
examples \
|
examples \
|
||||||
po \
|
po \
|
||||||
tests \
|
tests \
|
||||||
diff -rup a/src/Makefile.in b/src/Makefile.in
|
|
||||||
--- a/src/Makefile.in 2017-05-06 15:49:09.000000000 +0100
|
|
||||||
+++ b/src/Makefile.in 2017-05-10 14:35:01.918464036 +0100
|
|
||||||
@@ -90,7 +90,7 @@ PRE_UNINSTALL = :
|
|
||||||
POST_UNINSTALL = :
|
|
||||||
build_triplet = @build@
|
|
||||||
host_triplet = @host@
|
|
||||||
-bin_PROGRAMS = flex$(EXEEXT)
|
|
||||||
+bin_PROGRAMS =
|
|
||||||
@ENABLE_BOOTSTRAP_TRUE@noinst_PROGRAMS = stage1flex$(EXEEXT)
|
|
||||||
@CROSS_TRUE@am__append_1 = \
|
|
||||||
@CROSS_TRUE@ ../lib/malloc.c \
|
|
@ -15,6 +15,11 @@ FLEX_CONF_ENV = ac_cv_path_M4=/usr/bin/m4
|
|||||||
# we don't have a host-gettext/libintl
|
# we don't have a host-gettext/libintl
|
||||||
HOST_FLEX_DEPENDENCIES = host-m4
|
HOST_FLEX_DEPENDENCIES = host-m4
|
||||||
|
|
||||||
|
define FLEX_DISABLE_PROGRAM
|
||||||
|
$(SED) 's/^bin_PROGRAMS.*//' $(@D)/src/Makefile.in
|
||||||
|
endef
|
||||||
|
FLEX_POST_PATCH_HOOKS += FLEX_DISABLE_PROGRAM
|
||||||
|
|
||||||
# flex++ symlink is broken when flex binary is not installed
|
# flex++ symlink is broken when flex binary is not installed
|
||||||
define FLEX_REMOVE_BROKEN_SYMLINK
|
define FLEX_REMOVE_BROKEN_SYMLINK
|
||||||
rm -f $(TARGET_DIR)/usr/bin/flex++
|
rm -f $(TARGET_DIR)/usr/bin/flex++
|
||||||
|
Loading…
Reference in New Issue
Block a user