squid: bump to version 4.3
Drop get_certificate test avoidance patch; upstream made the test cross compile friendly in commit 958ae827cabf (Fix cross-compile issues with SSL_get_certificate()) Drop the patch adding <time.h>; the code does not call time() anymore. Restore netfilter support under musl libc. Squid build fine with current musl version. Cc: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
d0758184c0
commit
419c47a213
@ -1,21 +0,0 @@
|
||||
The openssl get_certificate working test isn't cross compile friendly.
|
||||
Just assume it works ok since we're using a modern OpenSSL version.
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
[Bernd: Rebased for 4.2]
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
|
||||
diff -Nura squid-3.5.1.orig/configure.ac squid-3.5.1/configure.ac
|
||||
--- squid-3.5.1.orig/configure.ac 2015-01-27 11:09:15.035711981 -0300
|
||||
+++ squid-3.5.1/configure.ac 2015-01-27 11:09:25.829084482 -0300
|
||||
@@ -1377,10 +1377,6 @@
|
||||
])
|
||||
SQUID_STATE_ROLLBACK(check_SSL_CTX_get0_certificate)
|
||||
|
||||
- # check for other specific broken implementations
|
||||
- if test "x$missing_SSL_CTX_get0_certificate" = "xyes"; then
|
||||
- SQUID_CHECK_OPENSSL_GETCERTIFICATE_WORKS
|
||||
- fi
|
||||
SQUID_CHECK_OPENSSL_CONST_SSL_METHOD
|
||||
SQUID_CHECK_OPENSSL_CONST_CRYPTO_EX_DATA
|
||||
SQUID_CHECK_OPENSSL_CONST_SSL_SESSION_CB_ARG
|
@ -1,28 +0,0 @@
|
||||
ipc/Kid.cc: add missing include of time.h
|
||||
|
||||
Function time() comes from <time.h>, so add the necessary include.
|
||||
This fixes compilation on some configurations, for example
|
||||
http://autobuild.buildroot.net/results/b33/b33e1f41e50b6e7ac3e30806b9a617d451bc27b4/
|
||||
|
||||
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
|
||||
Upstream-status: submitted (http://bugs.squid-cache.org/show_bug.cgi?id=3967)
|
||||
|
||||
---
|
||||
src/ipc/Kid.cc | 4 ++++
|
||||
1 files changed, 4 insertions(+), 0 deletions(-)
|
||||
|
||||
|
||||
diff --git a/src/ipc/Kid.cc b/src/ipc/Kid.cc
|
||||
--- a/src/ipc/Kid.cc
|
||||
+++ b/src/ipc/Kid.cc
|
||||
@@ -11,6 +11,10 @@
|
||||
#include <sys/wait.h>
|
||||
#endif
|
||||
|
||||
+#if HAVE_TIME_H
|
||||
+#include <time.h>
|
||||
+#endif
|
||||
+
|
||||
int TheProcessKind = pkOther;
|
||||
|
||||
Kid::Kid():
|
@ -1,6 +1,6 @@
|
||||
# From http://www.squid-cache.org/Versions/v4/squid-4.2.tar.xz.asc
|
||||
md5 2cf3f5f183d04322d798f98ea5ead43f squid-4.2.tar.xz
|
||||
sha1 77fd6f06e6028780faf85ba7e7e9aef0922e9dc0 squid-4.2.tar.xz
|
||||
# From http://www.squid-cache.org/Versions/v4/squid-4.3.tar.xz.asc
|
||||
md5 ebb67abaec4db9d298c0edd8e1ffaca4 squid-4.3.tar.xz
|
||||
sha1 690540e7d0904e3959557f8beca45dbac1c94578 squid-4.3.tar.xz
|
||||
# Locally calculated
|
||||
sha256 994807762c59991b32449caf29418fd0ec9d2329746b18eb19bd930b6806d208 squid-4.2.tar.xz
|
||||
sha256 322612ef0544828f6c673a25124b32364fb41ef5e2847e21c89480b5546a4c7c squid-4.3.tar.xz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
|
@ -4,13 +4,11 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
SQUID_VERSION = 4.2
|
||||
SQUID_VERSION = 4.3
|
||||
SQUID_SOURCE = squid-$(SQUID_VERSION).tar.xz
|
||||
SQUID_SITE = http://www.squid-cache.org/Versions/v4
|
||||
SQUID_LICENSE = GPL-2.0+
|
||||
SQUID_LICENSE_FILES = COPYING
|
||||
# For 0001-assume-get-certificate-ok.patch
|
||||
SQUID_AUTORECONF = YES
|
||||
SQUID_DEPENDENCIES = libcap host-libcap libxml2 host-pkgconf \
|
||||
$(if $(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),libnetfilter_conntrack)
|
||||
SQUID_CONF_ENV = \
|
||||
@ -25,7 +23,7 @@ SQUID_CONF_ENV = \
|
||||
BUILDCXXFLAGS="$(HOST_CXXFLAGS)"
|
||||
SQUID_CONF_OPTS = \
|
||||
--enable-async-io=8 \
|
||||
$(if $(BR2_TOOLCHAIN_USES_MUSL),--disable-linux-netfilter,--enable-linux-netfilter) \
|
||||
--enable-linux-netfilter \
|
||||
--enable-removal-policies="lru,heap" \
|
||||
--with-filedescriptors=1024 \
|
||||
--disable-ident-lookups \
|
||||
|
Loading…
Reference in New Issue
Block a user