package/grpc: bump version to 1.39.0
* drop CMakeLists.txt patch applied upstream. * Update patch for wrap_memcpy.cc to match changed target file. * update patch numbering. Signed-off-by: Michael Nosthoff <buildroot@heine.tech> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
d292d139cd
commit
4185f6dae9
@ -1,43 +0,0 @@
|
||||
From 268815d74ea34856c686dce9e9c23106b51f2782 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
|
||||
Date: Tue, 2 Feb 2021 21:46:29 +0100
|
||||
Subject: [PATCH] CMakeLists.txt: fix cross-compilation with
|
||||
gRPC_BUILD_GRPC_CPP_PLUGIN=OFF
|
||||
|
||||
When cross-compiling gRPC, a native version of 'grpc_cpp_plugin' is searched
|
||||
in the environment. For most use cases, a cross version of this file is not
|
||||
needed.
|
||||
|
||||
However, when cross-building with -DgRPC_BUILD_GRPC_CPP_PLUGIN=OFF, there
|
||||
are some build errors, for example:
|
||||
|
||||
make[3]: *** No rule to make target 'grpc_cpp_plugin', needed by 'gens/src/proto/grpc/reflection/v1alpha/reflection.grpc.pb.cc'. Stop.
|
||||
|
||||
This is because there is still a hard dependency on 'grpc_cpp_plugin' for
|
||||
these targets, not taking into account the cross-compilation case.
|
||||
|
||||
Fix by depending on the variable gRPC_CPP_PLUGIN, which is set correctly for
|
||||
either cross or native case.
|
||||
|
||||
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
|
||||
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6bdae22083..08aea609f7 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -317,7 +317,7 @@ function(protobuf_generate_grpc_cpp)
|
||||
--plugin=protoc-gen-grpc=${_gRPC_CPP_PLUGIN}
|
||||
${_protobuf_include_path}
|
||||
${REL_FIL}
|
||||
- DEPENDS ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} grpc_cpp_plugin
|
||||
+ DEPENDS ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} ${_gRPC_CPP_PLUGIN}
|
||||
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
||||
COMMENT "Running gRPC C++ protocol buffer compiler on ${FIL}"
|
||||
VERBATIM)
|
||||
--
|
||||
2.26.2
|
||||
|
@ -20,12 +20,12 @@ diff --git a/src/core/lib/gpr/wrap_memcpy.cc b/src/core/lib/gpr/wrap_memcpy.cc
|
||||
index 9b8608e056..38b76acf95 100644
|
||||
--- a/src/core/lib/gpr/wrap_memcpy.cc
|
||||
+++ b/src/core/lib/gpr/wrap_memcpy.cc
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
@@ -29,7 +29,7 @@
|
||||
extern "C" {
|
||||
#ifdef __linux__
|
||||
-#if defined(__x86_64__) && !defined(GPR_MUSL_LIBC_COMPAT)
|
||||
+#if defined(__x86_64__) && !defined(GPR_MUSL_LIBC_COMPAT) && !defined(GPR_DISABLE_WRAPPED_MEMCPY)
|
||||
#if defined(__x86_64__) && !defined(GPR_MUSL_LIBC_COMPAT) && \
|
||||
- !defined(__ANDROID__)
|
||||
+ !defined(__ANDROID__) && !defined(GPR_DISABLE_WRAPPED_MEMCPY)
|
||||
__asm__(".symver memcpy,memcpy@GLIBC_2.2.5");
|
||||
void* __wrap_memcpy(void* destination, const void* source, size_t num) {
|
||||
return memcpy(destination, source, num);
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 f60e5b112913bf776a22c16a3053cc02cf55e60bf27a959fd54d7aaf8e2da6e8 grpc-1.38.1.tar.gz
|
||||
sha256 b16992aa1c949c10d5d5ce2a62f9d99fa7de77da2943e643fb66dcaf075826d6 grpc-1.39.0.tar.gz
|
||||
sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
GRPC_VERSION = 1.38.1
|
||||
GRPC_VERSION = 1.39.0
|
||||
GRPC_SITE = $(call github,grpc,grpc,v$(GRPC_VERSION))
|
||||
GRPC_LICENSE = Apache-2.0
|
||||
GRPC_LICENSE_FILES = LICENSE
|
||||
|
Loading…
Reference in New Issue
Block a user