python3: fix invalid ncursesw header path
This commit adds a patch to python3 that makes sure it does not use an invalid header path (pointing to host headers) when including ncursesw support. Fixes: http://autobuild.buildroot.org/results/9bd/9bdaa392e8dd00c6ebee156b758e3c0cac480237/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Tested-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
0b173fd795
commit
414d7e97a7
21
package/python3/018-ncursesw-remove-wrong-includedir.patch
Normal file
21
package/python3/018-ncursesw-remove-wrong-includedir.patch
Normal file
@ -0,0 +1,21 @@
|
||||
Do not harcode invalid path to ncursesw headers
|
||||
|
||||
Adding /usr/include/ncursesw is obviously invalid when
|
||||
cross-compiling. Since the ncursesw headers are no longer installed in
|
||||
usr/include/ncursesw/, but directly in usr/include, there is anyway no
|
||||
need for a special header path.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: b/setup.py
|
||||
===================================================================
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -1287,7 +1287,6 @@
|
||||
panel_library = 'panel'
|
||||
if curses_library == 'ncursesw':
|
||||
curses_defines.append(('HAVE_NCURSESW', '1'))
|
||||
- curses_includes.append('/usr/include/ncursesw')
|
||||
# Bug 1464056: If _curses.so links with ncursesw,
|
||||
# _curses_panel.so must link with panelw.
|
||||
panel_library = 'panelw'
|
Loading…
Reference in New Issue
Block a user