libxmlrpc: fix build without C++ compiler

Conditionally disable compilation of optional C++ module.

Fixes:

  http://autobuild.buildroot.net/results/cbff6c816606a515467d467677763533a41fc276/

Signed-off-by: Alvaro Gamez Machado <alvaro.gamez@hazent.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Alvaro Gamez Machado 2016-12-04 16:55:40 +01:00 committed by Thomas Petazzoni
parent de90d77dc1
commit 413605e036

View File

@ -1,9 +1,10 @@
Handle builds without C++
libxmlrpc nicely handles the fact of being built without C++ support,
except for one location, fixed by this patch.
except for two locations, fixed by this patch.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Alvaro Gamez Machado <alvaro.gamez@hazent.com>
Index: b/lib/util/Makefile
===================================================================
@ -25,3 +26,19 @@ Index: b/lib/util/Makefile
.PHONY: all
all: $(LIBOBJS)
Index: b/lib/Makefile
===================================================================
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -9,7 +9,10 @@
# Build up SUBDIRS:
SUBDIRS =
-SUBDIRS += util libutil libutil++
+SUBDIRS += util libutil
+ifeq ($(ENABLE_CPLUSPLUS),yes)
+ SUBDIRS += libutil++
+endif
ifeq ($(ENABLE_ABYSS_SERVER),yes)
SUBDIRS += abyss
ifeq ($(ENABLE_CPLUSPLUS),yes)