package/rtl8189fs: bump to version 2024-01-22

With this version we can build with Linux 6.8.
Let's also drop local patch that has been upstreamed.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Giulio Benetti 2024-01-22 16:03:06 +01:00 committed by Peter Korsgaard
parent ca76f99d95
commit 40f7130a67
3 changed files with 2 additions and 43 deletions

View File

@ -1,41 +0,0 @@
From f48d99fab8b79e573850067a3ff2d8c16aa95ce1 Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Wed, 28 Sep 2022 21:17:17 +0200
Subject: [PATCH] Makefile: move 'EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)' at the
end of EXTRA_FLAGS assignment
At the moment USER_EXTRA_CFLAGS can't override local Makfile EXTRA_CFLAGS
since it's assigned at the beginning of the Makefile. For example it's not
possible to undefine the hardcoded CONFIG_LITTLE_ENDIAN and this doesn't
allow to build these modules for big endian architectures. So let's move
the assignment of USER_EXTRA_CFLAGS to EXTRA_CFLAGS after the last
EXTRA_CFLAGS assignment.
Upstream: https://github.com/jwrdegoede/rtl8189ES_linux/pull/101
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index dfca305..6f91d0a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
EXTRA_CFLAGS += -O1
#EXTRA_CFLAGS += -O3
#EXTRA_CFLAGS += -Wall
@@ -2208,6 +2207,8 @@ ifneq ($(USER_MODULE_NAME),)
MODULE_NAME := $(USER_MODULE_NAME)
endif
+EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
+
ifneq ($(KERNELRELEASE),)
########### this part for *.mk ############################
--
2.34.1

View File

@ -1,2 +1,2 @@
# Locally calculated
sha256 9ff7aa9ee8cd7a8f386531d3b009e7bcbce1ff71bb676c187c40e538755eb8b5 rtl8189fs-75a566a830037c7d1309c5a9fe411562772a1cf2.tar.gz
sha256 c92e1d800258665835922c1e927708f7a0477a1cbb281dc98ba5d33d5e3271ee rtl8189fs-5d523593f41c0b8d723c6aa86b217ee1d0965786.tar.gz

View File

@ -4,7 +4,7 @@
#
################################################################################
RTL8189FS_VERSION = 75a566a830037c7d1309c5a9fe411562772a1cf2
RTL8189FS_VERSION = 5d523593f41c0b8d723c6aa86b217ee1d0965786
RTL8189FS_SITE = $(call github,jwrdegoede,rtl8189ES_linux,$(RTL8189FS_VERSION))
RTL8189FS_LICENSE = GPL-2.0