dtc: bump version to 1.4.4
Adds overlay support. Drop the non-upstreamed 0002-extra-cflags.patch and instead simply pass the needed CFLAGS as make arguments. Passing the full upstream warning flags are not important in the Buildroot context, so this is simpler than maintaining a patch. Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
920c7f4706
commit
40a5d25378
@ -1,32 +0,0 @@
|
||||
Makefile: append the CFLAGS to existing ones
|
||||
|
||||
Allow the user to pass custom CFLAGS (eg. optimisation flags).
|
||||
|
||||
Do not use EXTRA_CFLAGS, append to existing CFLAGS with += (Arnout)
|
||||
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
Cc: Arnout Vandecappelle <arnout@mind.be>
|
||||
|
||||
---
|
||||
Patch not sent upstream.
|
||||
|
||||
Although not specific to buildroot, I am not sure this is the best
|
||||
way to handle user-supplied CFLAGS.
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 962f94eba661..bf6b317158cf 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -16,9 +16,10 @@ LOCAL_VERSION =
|
||||
CONFIG_LOCALVERSION =
|
||||
|
||||
CPPFLAGS = -I libfdt -I .
|
||||
-WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
||||
+WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
||||
-Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -Wshadow
|
||||
-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
|
||||
+CFLAGS ?= -g -Os
|
||||
+CFLAGS += -fPIC $(WARNINGS)
|
||||
|
||||
BISON = bison
|
||||
LEX = flex
|
@ -1,2 +1,2 @@
|
||||
# from https://www.kernel.org/pub/software/utils/dtc/sha256sums.asc
|
||||
sha256 77992ad8eac7b68f553d0ba58e5b51604ac803d126196c99e3ae38aaae28bb94 dtc-1.4.1.tar.xz
|
||||
sha256 470731d5c015b160d26a96645dbb1c7337d6e7b8c98244612002b66bedf6cffb dtc-1.4.4.tar.xz
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
DTC_VERSION = 1.4.1
|
||||
DTC_VERSION = 1.4.4
|
||||
DTC_SOURCE = dtc-$(DTC_VERSION).tar.xz
|
||||
DTC_SITE = https://www.kernel.org/pub/software/utils/dtc
|
||||
DTC_LICENSE = GPL-2.0+ or BSD-2-Clause (library)
|
||||
@ -32,7 +32,7 @@ DTC_INSTALL_GOAL = install-lib
|
||||
endif # $(BR2_PACKAGE_DTC_PROGRAMS) != y
|
||||
|
||||
define DTC_BUILD_CMDS
|
||||
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=/usr
|
||||
$(TARGET_CONFIGURE_OPTS) $(MAKE) CFLAGS="$(TARGET_CFLAGS) -fPIC" -C $(@D) PREFIX=/usr
|
||||
endef
|
||||
|
||||
# For staging, only the library is needed
|
||||
@ -47,7 +47,7 @@ endef
|
||||
|
||||
# host build
|
||||
define HOST_DTC_BUILD_CMDS
|
||||
$(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr
|
||||
$(HOST_CONFIGURE_OPTS) $(MAKE) CFLAGS="$(HOST_CFLAGS) -fPIC" -C $(@D) PREFIX=$(HOST_DIR)/usr
|
||||
endef
|
||||
|
||||
define HOST_DTC_INSTALL_CMDS
|
||||
|
Loading…
Reference in New Issue
Block a user