diff --git a/package/gvfs/gvfs.mk b/package/gvfs/gvfs.mk
index 92a01ef2f6..c5104e8dbf 100644
--- a/package/gvfs/gvfs.mk
+++ b/package/gvfs/gvfs.mk
@@ -25,7 +25,6 @@ GVFS_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
 # Most of these are missing library support
 GVFS_CONF_OPTS = \
 	-Dafc=false \
-	-Dfuse=false \
 	-Dgoa=false \
 	-Dgoogle=false \
 	-Dmtp=false \
@@ -85,6 +84,13 @@ else
 GVFS_CONF_OPTS += -Dcdda=false
 endif
 
+ifeq ($(BR2_PACKAGE_LIBFUSE3),y)
+GVFS_DEPENDENCIES += libfuse3
+GVFS_CONF_OPTS += -Dfuse=true
+else
+GVFS_CONF_OPTS += -Dfuse=false
+endif
+
 # AFP support is anon-only without libgcrypt which isn't very useful
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 GVFS_CONF_OPTS += \