wpan-tools: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
9b96527237
commit
404597a5db
@ -1505,6 +1505,7 @@ endif
|
||||
source "package/wireless_tools/Config.in"
|
||||
source "package/wireshark/Config.in"
|
||||
source "package/wpa_supplicant/Config.in"
|
||||
source "package/wpan-tools/Config.in"
|
||||
source "package/wvdial/Config.in"
|
||||
source "package/xinetd/Config.in"
|
||||
source "package/xl2tp/Config.in"
|
||||
|
40
package/wpan-tools/0001-fix-build-with-newer-libnl.patch
Normal file
40
package/wpan-tools/0001-fix-build-with-newer-libnl.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 51ab69d76aa708c79aed971ee4083abb8cc07201 Mon Sep 17 00:00:00 2001
|
||||
From: Stefan Schmidt <stefan@osg.samsung.com>
|
||||
Date: Mon, 9 Nov 2015 19:06:25 +0100
|
||||
Subject: [PATCH] build: avoid redefinition errors with libnl >= 3.2.27
|
||||
|
||||
From 3.2.17 onwards we have nla for s8, s16, etc defined directly in libnl.
|
||||
If we keep including this file anyway we run into redefinition errors. Better
|
||||
include use our own only for earlier versions.
|
||||
|
||||
Happened to me on Fedora 22 after my last update.
|
||||
|
||||
Signed-off-by: Stefan Schmidt <stefan@osg.samsung.com>
|
||||
Acked-by: Alexander Aring <alex.aring@gmail.com>
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
---
|
||||
Patch status: upstream
|
||||
|
||||
src/nl_extras.h | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/nl_extras.h b/src/nl_extras.h
|
||||
index 9d841aa..c4d1d14 100644
|
||||
--- a/src/nl_extras.h
|
||||
+++ b/src/nl_extras.h
|
||||
@@ -1,6 +1,8 @@
|
||||
#ifndef __NL_EXTRAS_H
|
||||
#define __NL_EXTRAS_H
|
||||
|
||||
+#if LIBNL_VER_MIC <= 26
|
||||
+
|
||||
#ifndef NLA_S8
|
||||
|
||||
#define NLA_S8 13
|
||||
@@ -43,4 +45,6 @@ static inline int32_t nla_get_s32(struct nlattr *nla)
|
||||
|
||||
#endif /* NLA_S64 */
|
||||
|
||||
+#endif /* LIBNL_VER_MIC */
|
||||
+
|
||||
#endif /* __NL_EXTRAS_H */
|
11
package/wpan-tools/Config.in
Normal file
11
package/wpan-tools/Config.in
Normal file
@ -0,0 +1,11 @@
|
||||
config BR2_PACKAGE_WPAN_TOOLS
|
||||
bool "wpan-tools"
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS
|
||||
select BR2_PACKAGE_LIBNL
|
||||
help
|
||||
Userspace tools for Linux IEEE 802.15.4 stack.
|
||||
|
||||
http://wpan.cakelab.org/
|
||||
|
||||
comment "wpan-tools needs a toolchain w/ threads"
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS
|
4
package/wpan-tools/wpan-tools.hash
Normal file
4
package/wpan-tools/wpan-tools.hash
Normal file
@ -0,0 +1,4 @@
|
||||
# From http://wpan.cakelab.org/releases/md5sum
|
||||
md5 c6356f7be4de2e9f2084283b9ed7e1ab wpan-tools-0.5.tar.gz
|
||||
# Calculated based on the hash above
|
||||
sha256 f381f24eb1962aa9e21751004560371bb9ad8bd0b735bc493930f50e8c1f3d99 wpan-tools-0.5.tar.gz
|
13
package/wpan-tools/wpan-tools.mk
Normal file
13
package/wpan-tools/wpan-tools.mk
Normal file
@ -0,0 +1,13 @@
|
||||
################################################################################
|
||||
#
|
||||
# wpan-tools
|
||||
#
|
||||
################################################################################
|
||||
|
||||
WPAN_TOOLS_VERSION = 0.5
|
||||
WPAN_TOOLS_SITE = http://wpan.cakelab.org/releases
|
||||
WPAN_TOOLS_DEPENDENCIES = host-pkgconf libnl
|
||||
WPAN_TOOLS_LICENSE = iw license
|
||||
WPAN_TOOLS_LICENSE_FILES = COPYING
|
||||
|
||||
$(eval $(autotools-package))
|
Loading…
Reference in New Issue
Block a user