package/gerbera: bump version to 1.12.1

Removed patch which is included in this release.

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Bernd Kuhls 2023-07-30 19:12:28 +02:00 committed by Thomas Petazzoni
parent 18173cba92
commit 3fd79fcb61
4 changed files with 2 additions and 39 deletions

View File

@ -531,7 +531,6 @@ package/gengetopt/0001-configure.ac-add-disable-doc-option.patch Upstream
package/genpart/0001-fix-return-code.patch Upstream
package/genromfs/0001-build-system.patch Sob Upstream
package/gensio/0001-Fix-missing-EVP_PKEY_ED25519-build-error-on-libressl.patch Upstream
package/gerbera/0001-Fix-build-with-fmt-9-0.patch Upstream
package/gerbera/S99gerbera Indent
package/gettext-gnu/0001-error_print_progname.patch Upstream
package/gettext-gnu/0002-restore-the-ability-to-buld-gettext-tools-seperately-part1.patch Upstream

View File

@ -1,36 +0,0 @@
From d7b8fafbc94405c20753fed569abd8878cccde89 Mon Sep 17 00:00:00 2001
From: Felix Yan <felixonmars@archlinux.org>
Date: Fri, 19 Aug 2022 15:22:10 +0300
Subject: [PATCH] Fix build with fmt 9.0
Fixes #2681
[Retrieved from:
https://github.com/gerbera/gerbera/commit/d7b8fafbc94405c20753fed569abd8878cccde89]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
src/database/sql_format.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/database/sql_format.h b/src/database/sql_format.h
index 32dc00efa..e4e1909a8 100644
--- a/src/database/sql_format.h
+++ b/src/database/sql_format.h
@@ -42,7 +42,7 @@ struct SQLIdentifier {
template <>
struct fmt::formatter<SQLIdentifier> : formatter<std::string_view> {
template <typename FormatContext>
- auto format(const SQLIdentifier& tn, FormatContext& ctx) -> decltype(ctx.out())
+ auto format(const SQLIdentifier& tn, FormatContext& ctx) const -> decltype(ctx.out())
{
return format_to(ctx.out(), "{}{}{}", tn.quote_begin, tn.name, tn.quote_end);
}
@@ -61,7 +61,7 @@ struct ColumnUpdate {
template <>
struct fmt::formatter<ColumnUpdate> : formatter<std::string_view> {
template <typename FormatContext>
- auto format(const ColumnUpdate& a, FormatContext& ctx) -> decltype(ctx.out())
+ auto format(const ColumnUpdate& a, FormatContext& ctx) const -> decltype(ctx.out())
{
return format_to(ctx.out(), "{} = {}", a.column, a.value);
}

View File

@ -1,3 +1,3 @@
# Locally computed:
sha256 bd6c7b2c6380e2e265a998bbc0df9eec14b9c6a65bc91e7f2c0ae0b67fd0c9cf gerbera-1.10.0.tar.gz
sha256 2144a7c4a13e8b43aa0c911fbeae65f05e2c42254ddd03be5c41f5fcf103a93c gerbera-1.12.1.tar.gz
sha256 cae4138373be41fd2be75faf41ce7efbcf49fb17d0e05ad1c51cc01ac335b9b6 LICENSE.md

View File

@ -4,7 +4,7 @@
#
################################################################################
GERBERA_VERSION = 1.10.0
GERBERA_VERSION = 1.12.1
GERBERA_SITE = $(call github,gerbera,gerbera,v$(GERBERA_VERSION))
GERBERA_LICENSE = GPL-2.0
GERBERA_LICENSE_FILES = LICENSE.md