package/libcamera-apps: bump to version 1.1.0
Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
2890f308b5
commit
3fac163b93
@ -1,37 +0,0 @@
|
||||
From 6bd733b52f0b4039407c676cd3126a9e2f79456b Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Fri, 5 Feb 2021 18:24:08 +0100
|
||||
Subject: [PATCH] cmake: remove -Werror and -Wfatal-errors compiler command
|
||||
line option
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fixes (with bootlin-riscv64-musl toolchain):
|
||||
|
||||
.../build/libcamera-apps-2d1009e3badcc8047361ff81149ad6cba3b911b5/core/libcamera_app.cpp:30:22: error: overflow in conversion from ‘long unsigned int’ to ‘int’ changes value from ‘2154321408’ to ‘-2140645888’ [-Werror=overflow]
|
||||
30 | int ret = ioctl(fd, VIDIOC_QUERYCAP, &caps);
|
||||
| ^~~~~~~~~~~~~~~
|
||||
cc1plus: all warnings being treated as errors
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 748c6dd..1ca1e39 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -11,7 +11,7 @@ endif()
|
||||
|
||||
set (CMAKE_EXPORT_COMPILE_COMMANDS ON)
|
||||
set (CMAKE_CXX_STANDARD 17)
|
||||
-add_compile_options(-Wall -Wextra -pedantic -Wno-unused-parameter -faligned-new -Werror -Wfatal-errors)
|
||||
+add_compile_options(-Wall -Wextra -pedantic -Wno-unused-parameter -faligned-new)
|
||||
add_definitions(-D_FILE_OFFSET_BITS=64)
|
||||
|
||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
--
|
||||
2.34.1
|
||||
|
@ -1,39 +0,0 @@
|
||||
From 60715769cd5368a63b2bdc2e6d6bb6df0030a54d Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Thu, 31 Mar 2022 21:44:22 +0200
|
||||
Subject: [PATCH] preview: fix egl_preview compile (conversion from Window to
|
||||
EGLNativeWindowType)
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fixes:
|
||||
|
||||
.../build/libcamera-apps-2d1009e3badcc8047361ff81149ad6cba3b911b5/preview/egl_preview.cpp:329:69: error: invalid conversion from ‘Window’ {aka ‘long unsigned int’} to ‘EGLNativeWindowType’ {aka ‘fbdev_window*’} [-fpermissive]
|
||||
329 | egl_surface_ = eglCreateWindowSurface(egl_display_, config, window_, NULL);
|
||||
| ^~~~~~~
|
||||
| |
|
||||
| Window {aka long unsigned int}
|
||||
|
||||
[Upstream: https://github.com/raspberrypi/libcamera-apps/pull/283]
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
preview/egl_preview.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/preview/egl_preview.cpp b/preview/egl_preview.cpp
|
||||
index b936e57..593583d 100644
|
||||
--- a/preview/egl_preview.cpp
|
||||
+++ b/preview/egl_preview.cpp
|
||||
@@ -326,7 +326,7 @@ void EglPreview::makeWindow(char const *name)
|
||||
wm_delete_window_ = XInternAtom(display_, "WM_DELETE_WINDOW", False);
|
||||
XSetWMProtocols(display_, window_, &wm_delete_window_, 1);
|
||||
|
||||
- egl_surface_ = eglCreateWindowSurface(egl_display_, config, window_, NULL);
|
||||
+ egl_surface_ = eglCreateWindowSurface(egl_display_, config, reinterpret_cast<EGLNativeWindowType>(window_), NULL);
|
||||
if (!egl_surface_)
|
||||
throw std::runtime_error("eglCreateWindowSurface failed");
|
||||
|
||||
--
|
||||
2.35.1
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 611aec06dd24de6586580164d9b7c55da0698ac4cf129944b2fc41fe67210597 libcamera-apps-2d1009e3badcc8047361ff81149ad6cba3b911b5.tar.gz
|
||||
sha256 2d895ad5d11a6004b1e84eb8d486d5dca64dda1b41e0f4f3f87904666f249e3e libcamera-apps-1.1.0.tar.gz
|
||||
sha256 36dfed86bdef661a0a14ec1a1cc84c771d5a06b6f9b92e9ebb610ba711bd528a license.txt
|
||||
|
@ -4,8 +4,8 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBCAMERA_APPS_VERSION = 2d1009e3badcc8047361ff81149ad6cba3b911b5
|
||||
LIBCAMERA_APPS_SITE = $(call github,raspberrypi,libcamera-apps,$(LIBCAMERA_APPS_VERSION))
|
||||
LIBCAMERA_APPS_VERSION = 1.1.0
|
||||
LIBCAMERA_APPS_SITE = $(call github,raspberrypi,libcamera-apps,v$(LIBCAMERA_APPS_VERSION))
|
||||
LIBCAMERA_APPS_LICENSE = BSD-2-Clause
|
||||
LIBCAMERA_APPS_LICENSE_FILES = license.txt
|
||||
LIBCAMERA_APPS_DEPENDENCIES = \
|
||||
|
Loading…
Reference in New Issue
Block a user