xvkbd: turn into a generic-package
xvkbd was integrated has an autotools package, but it does not have a ./configure script. And to avoid executing the ./configure, the xvkbd-2.8-makefile.patch was creating a dummy .stamp_configured stamp file... Ugly. So, make xvkbd a normal generic package, with BUILD_CMDS and INSTALL_TARGET_CMDS, and get rid of the crappy part of the patch. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
ab0e905aaf
commit
3ed3b69efe
@ -1,8 +1,3 @@
|
||||
--- a/.stamp_configured 2008-03-04 06:14:55.425005441 -0500
|
||||
+++ b/.stamp_configured 2008-03-05 08:42:53.000000000 -0500
|
||||
@@ -0,0 +1 @@
|
||||
+dummy
|
||||
\ No newline at end of file
|
||||
--- a/Makefile 2008-03-04 06:14:55.425005441 -0500
|
||||
+++ b/Makefile 2008-03-05 08:40:50.000000000 -0500
|
||||
@@ -0,0 +1,2397 @@
|
||||
|
@ -7,8 +7,16 @@ XVKBD_VERSION = 3.2
|
||||
XVKBD_SOURCE = xvkbd-$(XVKBD_VERSION).tar.gz
|
||||
XVKBD_SITE = http://homepage3.nifty.com/tsato/xvkbd
|
||||
|
||||
XVKBD_MAKE_OPT = CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" LD="$(TARGET_CC)" \
|
||||
CFLAGS="-O2 -I$(STAGING_DIR)/usr/include" USRLIBDIR="$(STAGING_DIR)/usr/lib"
|
||||
# Passing USRLIBDIR ensures that the stupid Makefile doesn't add
|
||||
# /usr/lib to the library search path.
|
||||
define XVKBD_BUILD_CMDS
|
||||
$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
|
||||
USRLIBDIR="$(STAGING_DIR)/usr/lib"
|
||||
endef
|
||||
|
||||
define XVKBD_INSTALL_TARGET_CMDS
|
||||
$(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
|
||||
endef
|
||||
|
||||
XVKBD_DEPENDENCIES = \
|
||||
xlib_libICE \
|
||||
@ -21,5 +29,5 @@ XVKBD_DEPENDENCIES = \
|
||||
xlib_libXt \
|
||||
xlib_libXtst
|
||||
|
||||
$(eval $(autotools-package))
|
||||
$(eval $(generic-package))
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user