package/numactl: remove unneeded patches
Both patches are already included (a bit earlier in the file) in version
2.0.12, so drop the patches.
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
(cherry picked from commit 0fda716432
)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
a1d6549359
commit
3d1cdb23f3
@ -1,35 +0,0 @@
|
|||||||
From 3770bdc4fa7b9059db5cd2aa8bb09b50fa15e456 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
||||||
Date: Fri, 12 Feb 2016 19:25:02 +0100
|
|
||||||
Subject: [PATCH] Fix usage of __GLIBC_PREREQ for non-glibc toolchains
|
|
||||||
|
|
||||||
The way __GLIBC_PREREQ() is currently used means that it's evaluated
|
|
||||||
even if __GLIBC__ is not defined. But obviously, __GLIBC_PREREQ will
|
|
||||||
not exist if __GLIBC__ is not defined, causing build failures on C
|
|
||||||
libraries not defining __GLIBC__ such as the musl C library.
|
|
||||||
|
|
||||||
Patch originally taken from:
|
|
||||||
https://github.com/voidlinux/void-packages/blob/master/srcpkgs/numactl/patches/musl.patch
|
|
||||||
|
|
||||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
||||||
[Bernd: Reworked to fix uClibc]
|
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
||||||
[Thomas: improve patch description.]
|
|
||||||
[Upstream commit: https://github.com/numactl/numactl/commit/3770bdc4fa7b9059db5cd2aa8bb09b50fa15e456.]
|
|
||||||
---
|
|
||||||
syscall.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/syscall.c b/syscall.c
|
|
||||||
index 4589b85..37782d9 100644
|
|
||||||
--- a/syscall.c
|
|
||||||
+++ b/syscall.c
|
|
||||||
@@ -115,7 +115,7 @@
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 11)
|
|
||||||
+#if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 11)
|
|
||||||
|
|
||||||
/* glibc 2.11 seems to have working 6 argument sycall. Use the
|
|
||||||
glibc supplied syscall in this case.
|
|
@ -1,39 +0,0 @@
|
|||||||
From 31dc2951c758698bff060aeae8ffd8854616183b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
||||||
Date: Fri, 12 Feb 2016 19:25:02 +0100
|
|
||||||
Subject: [PATCH] Fix usage of __GLIBC_PREREQ for non-glibc toolchains
|
|
||||||
|
|
||||||
The way __GLIBC_PREREQ() is currently used means that it's evaluated
|
|
||||||
even if __GLIBC__ is not defined. But obviously, __GLIBC_PREREQ will
|
|
||||||
not exist if __GLIBC__ is not defined, causing build failures on C
|
|
||||||
libraries not defining __GLIBC__ such as the musl C library.
|
|
||||||
|
|
||||||
Patch originally taken from:
|
|
||||||
https://github.com/voidlinux/void-packages/blob/master/srcpkgs/numactl/patches/musl.patch
|
|
||||||
|
|
||||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
||||||
[Bernd: Reworked to fix uClibc]
|
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
||||||
[Thomas: improve patch description.]
|
|
||||||
[Upstream commit: https://github.com/numactl/numactl/commit/31dc2951c758698bff060aeae8ffd8854616183b]
|
|
||||||
---
|
|
||||||
syscall.c | 6 +++++-
|
|
||||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/syscall.c b/syscall.c
|
|
||||||
index 37782d9..255853d 100644
|
|
||||||
--- a/syscall.c
|
|
||||||
+++ b/syscall.c
|
|
||||||
@@ -115,7 +115,11 @@
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 11)
|
|
||||||
+#ifndef __GLIBC_PREREQ
|
|
||||||
+# define __GLIBC_PREREQ(x,y) 0
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 11)
|
|
||||||
|
|
||||||
/* glibc 2.11 seems to have working 6 argument sycall. Use the
|
|
||||||
glibc supplied syscall in this case.
|
|
Loading…
Reference in New Issue
Block a user