package/tinyalsa: bump to version 2.0.0
- Switch to meson-package to drop first patch and disable examples and
utils
- Drop second patch (already in version)
- Update hash of NOTICE (empty new lines added with
902b8c8f9f
)
https://github.com/tinyalsa/tinyalsa/releases/tag/v2.0.0
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
5dbdb2535c
commit
3b9c8f8cb5
@ -1,35 +0,0 @@
|
||||
Disable doxygen usage
|
||||
|
||||
In order to avoid a dependency on doxygen on the build machine, this
|
||||
patch adjusts the main Makefile to not build and install the
|
||||
documentation.
|
||||
|
||||
[Vincent: tweak patch for 1.1.1 version]
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||
|
||||
diff -rup a/Makefile b/Makefile
|
||||
--- a/Makefile 2017-05-24 05:23:57.000000000 +0100
|
||||
+++ b/Makefile 2017-05-25 10:35:20.781747053 +0100
|
||||
@@ -11,14 +11,12 @@ export MANDIR ?= $(PREFIX)/share/man
|
||||
all:
|
||||
$(MAKE) -C src
|
||||
$(MAKE) -C utils
|
||||
- $(MAKE) -C doxygen
|
||||
$(MAKE) -C examples
|
||||
|
||||
.PHONY: clean
|
||||
clean:
|
||||
$(MAKE) -C src clean
|
||||
$(MAKE) -C utils clean
|
||||
- $(MAKE) -C doxygen clean
|
||||
$(MAKE) -C examples clean
|
||||
|
||||
.PHONY: install
|
||||
@@ -30,5 +28,4 @@ install:
|
||||
install include/tinyalsa/version.h $(DESTDIR)$(INCDIR)/
|
||||
$(MAKE) -C src install
|
||||
$(MAKE) -C utils install
|
||||
- $(MAKE) -C doxygen install
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 685e530d8a0063134642371eaacd01fee2f62d85 Mon Sep 17 00:00:00 2001
|
||||
From: Baruch Siach <baruch@tkos.co.il>
|
||||
Date: Fri, 2 Jun 2017 12:19:03 +0300
|
||||
Subject: [PATCH] interval.h: add missing header
|
||||
|
||||
The ssize_t type requires the unistd.h header. This fixes build with musl
|
||||
libc:
|
||||
|
||||
In file included from ../include/tinyalsa/limits.h:32:0,
|
||||
from limits.c:1:
|
||||
../include/tinyalsa/interval.h:38:2: error: unknown type name 'ssize_t'
|
||||
ssize_t max;
|
||||
^
|
||||
|
||||
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
||||
---
|
||||
Upstream status: https://github.com/tinyalsa/tinyalsa/pull/98
|
||||
|
||||
include/tinyalsa/interval.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/include/tinyalsa/interval.h b/include/tinyalsa/interval.h
|
||||
index 3f6f3dce5d90..068571df5a63 100644
|
||||
--- a/include/tinyalsa/interval.h
|
||||
+++ b/include/tinyalsa/interval.h
|
||||
@@ -30,6 +30,7 @@
|
||||
#define TINYALSA_INTERVAL_H
|
||||
|
||||
#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
/** A closed range signed interval. */
|
||||
|
||||
--
|
||||
2.11.0
|
||||
|
@ -1,3 +1,3 @@
|
||||
# locally computed
|
||||
sha256 d92b438cea348ae316c4b2cbf367b4f01ed821a947e6a34d813624e9e3c936c1 tinyalsa-1.1.1.tar.gz
|
||||
sha256 ca2b89a68c33fba3c8bcaec96f32907e2ede0eb33688ae61d29ec49732158f6d NOTICE
|
||||
sha256 573ae0b2d3480851c1d2a12503ead2beea27f92d44ed47b74b553ba947994ef1 tinyalsa-2.0.0.tar.gz
|
||||
sha256 ea22a4711f5250f88a4d7011fbc65367d1b02ac954dcc49f5b6d7c135e6537c4 NOTICE
|
||||
|
@ -4,30 +4,11 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
TINYALSA_VERSION = 1.1.1
|
||||
TINYALSA_SITE = $(call github,tinyalsa,tinyalsa,$(TINYALSA_VERSION))
|
||||
TINYALSA_VERSION = 2.0.0
|
||||
TINYALSA_SITE = $(call github,tinyalsa,tinyalsa,v$(TINYALSA_VERSION))
|
||||
TINYALSA_LICENSE = BSD-3-Clause
|
||||
TINYALSA_LICENSE_FILES = NOTICE
|
||||
TINYALSA_INSTALL_STAGING = YES
|
||||
TINYALSA_CONF_OPTS = -Ddocs=disabled -Dexamples=disabled -Dutils=disabled
|
||||
|
||||
define TINYALSA_BUILD_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D)
|
||||
endef
|
||||
|
||||
define TINYALSA_INSTALL_STAGING_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) \
|
||||
-C $(@D) \
|
||||
PREFIX="/usr" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
DESTDIR="$(STAGING_DIR)" install
|
||||
endef
|
||||
|
||||
define TINYALSA_INSTALL_TARGET_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) \
|
||||
-C $(@D) \
|
||||
PREFIX="/usr" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
DESTDIR="$(TARGET_DIR)" install
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
||||
$(eval $(meson-package))
|
||||
|
Loading…
Reference in New Issue
Block a user