tstools: new package
[Thomas: properly indent help text, add largefile dependency, remove unneeded libpcap dependency, remove unneeded CLEAN_CMDS, reorder build and install commands, remove uneeded <pkg>_INSTALL_STAGING, <pkg>_INSTALL_TARGET and <pkg>_INSTALL_IMAGES variables, move from package/multimedia/ to package/, add license details, rename patch to remove version number in the patch filename.] Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
03882d45b2
commit
396e92ed2e
@ -37,6 +37,7 @@ source "package/multimedia/on2-8170-libs/Config.in"
|
||||
source "package/opus-tools/Config.in"
|
||||
source "package/multimedia/pulseaudio/Config.in"
|
||||
source "package/multimedia/tidsp-binaries/Config.in"
|
||||
source "package/tstools/Config.in"
|
||||
source "package/multimedia/vorbis-tools/Config.in"
|
||||
source "package/multimedia/wavpack/Config.in"
|
||||
source "package/yavta/Config.in"
|
||||
|
17
package/tstools/Config.in
Normal file
17
package/tstools/Config.in
Normal file
@ -0,0 +1,17 @@
|
||||
config BR2_PACKAGE_TSTOOLS
|
||||
bool "tstools"
|
||||
depends on BR2_LARGEFILE
|
||||
help
|
||||
This is a set of cross-platform command line tools for
|
||||
working with MPEG data
|
||||
|
||||
The emphasis is on relatively simple tools which concentrate
|
||||
on MPEG (H.264 and H.262) data packaged according to H.222
|
||||
(i.e., TS or PS), with a particular interest in checking for
|
||||
conformance.
|
||||
|
||||
Transport Stream (TS) is typically used for distribution of
|
||||
cable and satellite data. Program Stream (PS) is typically
|
||||
used to store data on DVDs.
|
||||
|
||||
http://tstools.berlios.de/
|
40
package/tstools/tstools-build-get-along-with-buildroot.patch
Normal file
40
package/tstools/tstools-build-get-along-with-buildroot.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 44f80bce0914d4d9c5e7486c7cdb521ba637b324 Mon Sep 17 00:00:00 2001
|
||||
From: Tzu-Jung Lee <tjlee@ambarella.com>
|
||||
Date: Fri, 19 Jul 2013 22:45:18 +0800
|
||||
Subject: [PATCH] build: get along with buildroot
|
||||
|
||||
Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
|
||||
---
|
||||
Makefile | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 2c3568e..98bb994 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -34,12 +34,6 @@ SHELL = /bin/sh
|
||||
.SUFFIXES:
|
||||
.SUFFIXES: .c .o
|
||||
|
||||
-ifdef CROSS_COMPILE
|
||||
-CC = $(CROSS_COMPILE)gcc
|
||||
-else
|
||||
-CC = gcc
|
||||
-endif
|
||||
-
|
||||
# Use WARN=1 periodically to get too many warnings...
|
||||
ifdef WARN
|
||||
WARNING_FLAGS = -Wall -W -Wfloat-equal -Wundef -Wshadow -Wpointer-arith -Wcast-qual -Wconversion -Wmissing-prototypes -Wmissing-declarations -Wunreachable-code -Winline
|
||||
@@ -452,3 +446,9 @@ test_lists: $(BINDIR)/test_nal_unit_list $(BINDIR)/test_es_unit_list
|
||||
@echo +++ Testing ES unit lists
|
||||
$(BINDIR)/test_es_unit_list
|
||||
@echo +++ Test succeeded
|
||||
+
|
||||
+.PHONY: install
|
||||
+install:
|
||||
+ @for i in $(PROGS); do \
|
||||
+ cp -f $$i $(DESTDIR)/usr/bin/; \
|
||||
+ done
|
||||
--
|
||||
1.8.3.2
|
||||
|
21
package/tstools/tstools.mk
Normal file
21
package/tstools/tstools.mk
Normal file
@ -0,0 +1,21 @@
|
||||
################################################################################
|
||||
#
|
||||
# tstools
|
||||
#
|
||||
################################################################################
|
||||
|
||||
TSTOOLS_VERSION = 1_11
|
||||
TSTOOLS_SITE = https://tstools.googlecode.com/files/
|
||||
TSTOOLS_SOURCE = tstools-$(TSTOOLS_VERSION).tgz
|
||||
TSTOOLS_LICENSE = MPL v1.1
|
||||
|
||||
define TSTOOLS_BUILD_CMDS
|
||||
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
|
||||
endef
|
||||
|
||||
define TSTOOLS_INSTALL_TARGET_CMDS
|
||||
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
|
||||
DESTDIR=$(TARGET_DIR) install
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user