kbd: make sure to link against libintl when needed
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
75c0a45488
commit
383074a633
@ -1,5 +1,7 @@
|
||||
config BR2_PACKAGE_KBD
|
||||
bool "kbd"
|
||||
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
|
||||
select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT_IF_LOCALE
|
||||
help
|
||||
Keytable files and keyboard utilities.
|
||||
|
||||
|
34
package/kbd/kbd-link-against-libintl.patch
Normal file
34
package/kbd/kbd-link-against-libintl.patch
Normal file
@ -0,0 +1,34 @@
|
||||
Make sure we link against libintl if needed
|
||||
|
||||
We modify directly the Makefile.in so that we don't have to
|
||||
autoreconfigure the package, which doesn't work because packages using
|
||||
gettext need the autopoint tool for their autoregeneration step and
|
||||
this thing doesn't work (yet) in Buildroot.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: kbd-1.15.2/src/Makefile.am
|
||||
===================================================================
|
||||
--- kbd-1.15.2.orig/src/Makefile.am 2011-05-22 16:08:51.144530776 +0200
|
||||
+++ kbd-1.15.2/src/Makefile.am 2011-05-22 16:09:09.892530778 +0200
|
||||
@@ -5,6 +5,8 @@
|
||||
AM_CPPFLAGS = -DDATADIR=\"$(datadir)\" -DLOCALEDIR=\"$(localedir)\" $(WARNINGS) \
|
||||
-funit-at-a-time
|
||||
|
||||
+LDADD = @INTLLIBS@
|
||||
+
|
||||
OLDPROGS = mapscrn loadunimap
|
||||
PROGS = \
|
||||
dumpkeys loadkeys showkey setfont showconsolefont \
|
||||
Index: kbd-1.15.2/src/Makefile.in
|
||||
===================================================================
|
||||
--- kbd-1.15.2.orig/src/Makefile.in 2011-05-22 16:10:27.540530777 +0200
|
||||
+++ kbd-1.15.2/src/Makefile.in 2011-05-22 16:10:51.172530778 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
install_sh_PROGRAM = $(install_sh) -c
|
||||
install_sh_SCRIPT = $(install_sh) -c
|
||||
INSTALL_HEADER = $(INSTALL_DATA)
|
||||
+LDADD = @INTLLIBS@
|
||||
transform = $(program_transform_name)
|
||||
NORMAL_INSTALL = :
|
||||
PRE_INSTALL = :
|
@ -2,4 +2,6 @@ KBD_VERSION = 1.15.2
|
||||
KBD_SOURCE = kbd-$(KBD_VERSION).tar.gz
|
||||
KBD_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/kbd
|
||||
|
||||
KBD_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,kbd))
|
||||
|
Loading…
Reference in New Issue
Block a user