package/rtl8723ds: fix build failure due to endianness and Linux version 6.0

Add local patch pending upstream[0] to override CFLAGS to set endianness
according to BR2_ENDIAN. Let's also bump version to latest to support up to
Linux 6.1.

[0]: https://github.com/lwfinger/rtl8723ds/pull/29

Fixes:
http://autobuild.buildroot.net/results/2646ec0512f867e20c25c1d0a6417826218942d6/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Giulio Benetti 2022-11-16 16:22:36 +01:00 committed by Thomas Petazzoni
parent 6ebfe647b6
commit 354f9387f3
3 changed files with 48 additions and 3 deletions

View File

@ -0,0 +1,39 @@
From 769a1943cb409f89f3c91208294a89b09bf47b86 Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Wed, 16 Nov 2022 16:08:21 +0100
Subject: [PATCH] Makefile: move 'EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)' at the
end of EXTRA_FLAGS assignment
At the moment USER_EXTRA_CFLAGS can't override local Makfile EXTRA_CFLAGS
since it's assigned at the beginning of the Makefile. For example it's not
possible to undefine the hardcoded CONFIG_LITTLE_ENDIAN and this doesn't
allow to build these modules for big endian architectures. So let's move
the assignment of USER_EXTRA_CFLAGS to EXTRA_CFLAGS after the last
EXTRA_CFLAGS assignment.
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index aa57f85..3d91574 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
EXTRA_CFLAGS += -O1
#EXTRA_CFLAGS += -O3
#EXTRA_CFLAGS += -Wall
@@ -1738,6 +1737,8 @@ ifneq ($(USER_MODULE_NAME),)
MODULE_NAME := $(USER_MODULE_NAME)
endif
+EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
+
ifneq ($(KERNELRELEASE),)
rtk_core := core/rtw_cmd.o \
--
2.34.1

View File

@ -1,2 +1,2 @@
# Locally computed
sha256 cc5dcf9d17cefabfeba3e68671367c7d69091936e40f71dc5e1165c61195a9fb rtl8723ds-76146e85847beb2427b1d4958fa275822f2b04ab.tar.gz
sha256 691040a85d838f8d8d7da0f2ed460f1ea5f6734c40dc73770ba7e260b6cda9cc rtl8723ds-5ab2d3f3858dc4c833013c47a79faa05b10198f6.tar.gz

View File

@ -4,14 +4,20 @@
#
################################################################################
RTL8723DS_VERSION = 76146e85847beb2427b1d4958fa275822f2b04ab
RTL8723DS_VERSION = 5ab2d3f3858dc4c833013c47a79faa05b10198f6
RTL8723DS_SITE = $(call github,lwfinger,rtl8723ds,$(RTL8723DS_VERSION))
RTL8723DS_LICENSE = GPL-2.0
# Undefine the hardcoded CONFIG_LITTLE_ENDIAN
RTL8723DS_USER_EXTRA_CLAGS = -UCONFIG_LITTLE_ENDIAN
# Set endianness
RTL8723DS_USER_EXTRA_CLAGS += -DCONFIG_$(call qstrip,$(BR2_ENDIAN))_ENDIAN
RTL8723DS_MODULE_MAKE_OPTS = \
CONFIG_RTL8723DS=m \
KVER=$(LINUX_VERSION_PROBED) \
KSRC=$(LINUX_DIR)
KSRC=$(LINUX_DIR) \
USER_EXTRA_CFLAGS="$(RTL8723DS_USER_EXTRA_CLAGS)"
define RTL8723DS_LINUX_CONFIG_FIXUPS
$(call KCONFIG_ENABLE_OPT,CONFIG_NET)