package/transmission: add optional support for libminiupnpc/libnatpmp
Transmission bundles copies of both libraries and uses them if they are not provided by the system. This patch allows transmission to use the system libraries of libminiupnpc/libnatpmp. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
06015c7deb
commit
349b1688a5
31
package/transmission/0003-miniupnpc-cross.patch
Normal file
31
package/transmission/0003-miniupnpc-cross.patch
Normal file
@ -0,0 +1,31 @@
|
||||
Fix libminiupnpc version detection
|
||||
|
||||
Problem is known upstream: https://trac.transmissionbt.com/ticket/6140
|
||||
|
||||
For buildroot we know the libminiupnpc version so we hard-code 2.0.
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
|
||||
diff -uNr transmission-2.92.org/configure.ac transmission-2.92/configure.ac
|
||||
--- transmission-2.92.org/configure.ac 2016-03-06 21:23:45.336198393 +0100
|
||||
+++ transmission-2.92/configure.ac 2016-07-02 21:48:13.452385686 +0200
|
||||
@@ -386,18 +386,7 @@
|
||||
dnl MINIUPNPC_API_VERSION and we won't have to figure
|
||||
dnl it out on our own
|
||||
if test "x$upnp_version" = "xunknown" ; then
|
||||
- AC_RUN_IFELSE(
|
||||
- [AC_LANG_PROGRAM(
|
||||
- [#include <stdlib.h>
|
||||
- #include <miniupnpc/miniupnpc.h>],
|
||||
- [#ifdef MINIUPNPC_API_VERSION
|
||||
- return EXIT_SUCCESS;
|
||||
- #else
|
||||
- return EXIT_FAILURE;
|
||||
- #endif]
|
||||
- )],
|
||||
- [upnp_version=">= 1.7"]
|
||||
- )
|
||||
+ upnp_version="2.0"
|
||||
fi
|
||||
|
||||
dnl Or maybe it's miniupnp 1.6
|
@ -21,6 +21,17 @@ TRANSMISSION_CONF_OPTS = \
|
||||
TRANSMISSION_LICENSE = GPLv2 or GPLv3 with OpenSSL exception
|
||||
TRANSMISSION_LICENSE_FILES = COPYING
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBMINIUPNPC),y)
|
||||
TRANSMISSION_DEPENDENCIES += libminiupnpc
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBNATPMP),y)
|
||||
TRANSMISSION_DEPENDENCIES += libnatpmp
|
||||
TRANSMISSION_CONF_OPTS += --enable-external-natpmp
|
||||
else
|
||||
TRANSMISSION_CONF_OPTS += --disable-external-natpmp
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_TRANSMISSION_UTP),y)
|
||||
TRANSMISSION_CONF_OPTS += --enable-utp
|
||||
else
|
||||
|
Loading…
Reference in New Issue
Block a user