xenomai: use install-user to remove patch

As noted by "George" in bug #6416, the xenomai-do-not-install-devices
patch is not needed, since Xenomai provides a "install-user" target to
only install the libraries/headers and not the device files. This
patch changes xenomai.mk to use 'install-user' and removes the useless
patch.

Fixes bug #6416.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Petazzoni 2013-10-30 23:41:45 +01:00
parent 77de13ba55
commit 344fc7aa0d
2 changed files with 2 additions and 11 deletions

View File

@ -1,11 +0,0 @@
--- a/Makefile.in 2011-06-24 16:11:23.591449817 +0200
+++ b/Makefile.in 2011-06-24 16:20:29.638129633 +0200
@@ -719,7 +719,7 @@
$$sudo mknod -m 666 $(DESTDIR)/dev/rtheap c 10 254 ; \
fi
-install-exec-local: devices
+install-exec-local:
install-user:
$(MAKE) SUDO=false install

View File

@ -16,6 +16,8 @@ XENOMAI_LICENSE = headers: GPLv2+ with exception, libraries: LGPLv2.1+, kernel:
XENOMAI_LICENSE_FILES = debian/copyright include/COPYING src/skins/native/COPYING ksrc/nucleus/COPYING
XENOMAI_INSTALL_STAGING = YES
XENOMAI_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-user
XENOMAI_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install-user
XENOMAI_CONF_OPT += --includedir=/usr/include/xenomai/