package: add libhid
Based on patch by Johan Sagaert, but with some additional tweaks. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
7e7a8dc85e
commit
343eb8b583
@ -292,6 +292,7 @@ menu "Hardware handling"
|
||||
source "package/libaio/Config.in"
|
||||
source "package/libraw1394/Config.in"
|
||||
source "package/tslib/Config.in"
|
||||
source "package/libhid/Config.in"
|
||||
source "package/libusb/Config.in"
|
||||
source "package/libusb-compat/Config.in"
|
||||
source "package/python-serial/Config.in"
|
||||
|
8
package/libhid/Config.in
Normal file
8
package/libhid/Config.in
Normal file
@ -0,0 +1,8 @@
|
||||
config BR2_PACKAGE_LIBHID
|
||||
bool "libhid"
|
||||
select BR2_PACKAGE_LIBUSB
|
||||
select BR2_PACKAGE_LIBUSB_COMPAT
|
||||
help
|
||||
Userspace library for accessing USB HID devices
|
||||
|
||||
http://libhid.alioth.debian.org
|
24
package/libhid/libhid-0.2.16-fix-configure-typo.patch
Normal file
24
package/libhid/libhid-0.2.16-fix-configure-typo.patch
Normal file
@ -0,0 +1,24 @@
|
||||
[PATCH] fix typo in configure
|
||||
|
||||
Somehow a newline character has gotten inserted in the middle of the
|
||||
LDFLAGS assignment, breaking the build.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
---
|
||||
configure | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
Index: libhid-0.2.16/configure
|
||||
===================================================================
|
||||
--- libhid-0.2.16.orig/configure
|
||||
+++ libhid-0.2.16/configure
|
||||
@@ -23050,8 +23050,7 @@ echo "$as_me: doxygen disabled by config
|
||||
CPPFLAGS=$(echo $CPPFLAGS)
|
||||
CFLAGS=$(echo $OS_CFLAGS $LIBUSB_CFLAGS $CFLAGS)
|
||||
CXXFLAGS=$(echo $CXXFLAGS)
|
||||
- LDFLAGS=$(echo $OS_LDFLAGS $LIBUSB_LIBS
|
||||
- $LDFLAGS)
|
||||
+ LDFLAGS=$(echo $OS_LDFLAGS $LIBUSB_LIBS $LDFLAGS)
|
||||
|
||||
|
||||
|
17
package/libhid/libhid.mk
Normal file
17
package/libhid/libhid.mk
Normal file
@ -0,0 +1,17 @@
|
||||
#############################################################
|
||||
#
|
||||
# libhid
|
||||
#
|
||||
#############################################################
|
||||
|
||||
LIBHID_VERSION = 0.2.16
|
||||
LIBHID_SOURCE = libhid-$(LIBHID_VERSION).tar.gz
|
||||
LIBHID_SITE = http://alioth.debian.org/frs/download.php/1958
|
||||
LIBHID_DEPENDENCIES = libusb-compat libusb
|
||||
LIBHID_INSTALL_STAGING = YES
|
||||
# configure runs libusb-config for cflags/ldflags. Ensure it picks up
|
||||
# the target version
|
||||
LIBHID_CONF_ENV = PATH=$(STAGING_DIR)/usr/bin:$(TARGET_PATH)
|
||||
LIBHID_CONF_OPT = --disable-swig --without-doxygen --disable-package-config
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,libhid))
|
Loading…
Reference in New Issue
Block a user