version bump 2.16.94
This commit is contained in:
parent
88ce2b4702
commit
338e502682
139
toolchain/binutils/2.16.94/100-uclibc-conf.patch
Normal file
139
toolchain/binutils/2.16.94/100-uclibc-conf.patch
Normal file
@ -0,0 +1,139 @@
|
|||||||
|
--- binutils-2.16.91.0.7/bfd/configure
|
||||||
|
+++ binutils-2.16.91.0.7/bfd/configure
|
||||||
|
@@ -3576,7 +3576,7 @@
|
||||||
|
;;
|
||||||
|
|
||||||
|
# This must be Linux ELF.
|
||||||
|
-linux-gnu*)
|
||||||
|
+linux-gnu*|linux-uclibc*)
|
||||||
|
lt_cv_deplibs_check_method=pass_all
|
||||||
|
;;
|
||||||
|
|
||||||
|
--- binutils-2.16.91.0.7/binutils/configure
|
||||||
|
+++ binutils-2.16.91.0.7/binutils/configure
|
||||||
|
@@ -3411,7 +3411,7 @@
|
||||||
|
;;
|
||||||
|
|
||||||
|
# This must be Linux ELF.
|
||||||
|
-linux-gnu*)
|
||||||
|
+linux-gnu*|linux-uclibc*)
|
||||||
|
lt_cv_deplibs_check_method=pass_all
|
||||||
|
;;
|
||||||
|
|
||||||
|
--- binutils-2.16.91.0.7/configure
|
||||||
|
+++ binutils-2.16.91.0.7/configure
|
||||||
|
@@ -1270,7 +1270,7 @@
|
||||||
|
am33_2.0-*-linux*)
|
||||||
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
||||||
|
;;
|
||||||
|
- sh-*-linux*)
|
||||||
|
+ sh*-*-linux*)
|
||||||
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
||||||
|
;;
|
||||||
|
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
||||||
|
@@ -1578,7 +1578,7 @@
|
||||||
|
romp-*-*)
|
||||||
|
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
||||||
|
;;
|
||||||
|
- sh-*-* | sh64-*-*)
|
||||||
|
+ sh*-*-* | sh64-*-*)
|
||||||
|
case "${host}" in
|
||||||
|
i[3456789]86-*-vsta) ;; # don't add gprof back in
|
||||||
|
i[3456789]86-*-go32*) ;; # don't add gprof back in
|
||||||
|
--- binutils-2.16.91.0.7/configure.in
|
||||||
|
+++ binutils-2.16.91.0.7/configure.in
|
||||||
|
@@ -468,7 +468,7 @@
|
||||||
|
am33_2.0-*-linux*)
|
||||||
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
||||||
|
;;
|
||||||
|
- sh-*-linux*)
|
||||||
|
+ sh*-*-linux*)
|
||||||
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
||||||
|
;;
|
||||||
|
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
||||||
|
@@ -776,7 +776,7 @@
|
||||||
|
romp-*-*)
|
||||||
|
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
||||||
|
;;
|
||||||
|
- sh-*-* | sh64-*-*)
|
||||||
|
+ sh*-*-* | sh64-*-*)
|
||||||
|
case "${host}" in
|
||||||
|
i[[3456789]]86-*-vsta) ;; # don't add gprof back in
|
||||||
|
i[[3456789]]86-*-go32*) ;; # don't add gprof back in
|
||||||
|
--- binutils-2.16.91.0.7/gas/configure
|
||||||
|
+++ binutils-2.16.91.0.7/gas/configure
|
||||||
|
@@ -3411,7 +3411,7 @@
|
||||||
|
;;
|
||||||
|
|
||||||
|
# This must be Linux ELF.
|
||||||
|
-linux-gnu*)
|
||||||
|
+linux-gnu*|linux-uclibc*)
|
||||||
|
lt_cv_deplibs_check_method=pass_all
|
||||||
|
;;
|
||||||
|
|
||||||
|
--- binutils-2.16.91.0.7/gprof/configure
|
||||||
|
+++ binutils-2.16.91.0.7/gprof/configure
|
||||||
|
@@ -3419,6 +3419,11 @@
|
||||||
|
lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
|
||||||
|
;;
|
||||||
|
|
||||||
|
+linux-uclibc*)
|
||||||
|
+ lt_cv_deplibs_check_method=pass_all
|
||||||
|
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||||
|
+ ;;
|
||||||
|
+
|
||||||
|
netbsd* | knetbsd*-gnu)
|
||||||
|
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||||
|
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||||
|
--- binutils-2.16.91.0.7/ld/configure
|
||||||
|
+++ binutils-2.16.91.0.7/ld/configure
|
||||||
|
@@ -3413,7 +3413,7 @@
|
||||||
|
;;
|
||||||
|
|
||||||
|
# This must be Linux ELF.
|
||||||
|
-linux-gnu*)
|
||||||
|
+linux-gnu*|linux-uclibc*)
|
||||||
|
lt_cv_deplibs_check_method=pass_all
|
||||||
|
;;
|
||||||
|
|
||||||
|
--- binutils-2.16.91.0.7/libtool.m4
|
||||||
|
+++ binutils-2.16.91.0.7/libtool.m4
|
||||||
|
@@ -739,7 +739,7 @@
|
||||||
|
;;
|
||||||
|
|
||||||
|
# This must be Linux ELF.
|
||||||
|
-linux-gnu*)
|
||||||
|
+linux-gnu*|linux-uclibc*)
|
||||||
|
lt_cv_deplibs_check_method=pass_all
|
||||||
|
;;
|
||||||
|
|
||||||
|
--- binutils-2.16.91.0.7/ltconfig
|
||||||
|
+++ binutils-2.16.91.0.7/ltconfig
|
||||||
|
@@ -602,6 +602,7 @@
|
||||||
|
|
||||||
|
# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
|
||||||
|
case $host_os in
|
||||||
|
+linux-uclibc*) ;;
|
||||||
|
linux-gnu*) ;;
|
||||||
|
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
|
||||||
|
esac
|
||||||
|
@@ -1247,7 +1248,7 @@
|
||||||
|
;;
|
||||||
|
|
||||||
|
# This must be Linux ELF.
|
||||||
|
-linux-gnu*)
|
||||||
|
+linux-gnu*|linux-uclibc*)
|
||||||
|
version_type=linux
|
||||||
|
need_lib_prefix=no
|
||||||
|
need_version=no
|
||||||
|
--- binutils-2.16.91.0.7/opcodes/configure
|
||||||
|
+++ binutils-2.16.91.0.7/opcodes/configure
|
||||||
|
@@ -3579,7 +3579,7 @@
|
||||||
|
;;
|
||||||
|
|
||||||
|
# This must be Linux ELF.
|
||||||
|
-linux-gnu*)
|
||||||
|
+linux-gnu*|linux-uclibc*)
|
||||||
|
lt_cv_deplibs_check_method=pass_all
|
||||||
|
;;
|
||||||
|
|
24
toolchain/binutils/2.16.94/110-arm-eabi-conf.patch
Normal file
24
toolchain/binutils/2.16.94/110-arm-eabi-conf.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -urN binutils-2.16.91.0.7.orig/configure binutils-2.16.91.0.7/configure
|
||||||
|
--- binutils-2.16.91.0.7.orig/configure 2006-05-31 14:54:24.000000000 +0300
|
||||||
|
+++ binutils-2.16.91.0.7/configure 2006-05-31 14:55:53.000000000 +0300
|
||||||
|
@@ -1299,7 +1299,7 @@
|
||||||
|
arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
|
||||||
|
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||||
|
;;
|
||||||
|
- arm*-*-linux-gnueabi)
|
||||||
|
+ arm*-*-linux-gnueabi | arm*-*-linux-uclibcgnueabi)
|
||||||
|
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||||
|
noconfigdirs="$noconfigdirs target-libjava target-libobjc"
|
||||||
|
;;
|
||||||
|
diff -urN binutils-2.16.91.0.7.orig/configure.in binutils-2.16.91.0.7/configure.in
|
||||||
|
--- binutils-2.16.91.0.7.orig/configure.in 2006-05-31 14:54:24.000000000 +0300
|
||||||
|
+++ binutils-2.16.91.0.7/configure.in 2006-05-31 14:55:53.000000000 +0300
|
||||||
|
@@ -497,7 +497,7 @@
|
||||||
|
arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
|
||||||
|
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||||
|
;;
|
||||||
|
- arm*-*-linux-gnueabi)
|
||||||
|
+ arm*-*-linux-gnueabi | arm*-*-linux-uclibcgnueabi)
|
||||||
|
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||||
|
noconfigdirs="$noconfigdirs target-libjava target-libobjc"
|
||||||
|
;;
|
50
toolchain/binutils/2.16.94/300-001_ld_makefile_patch.patch
Normal file
50
toolchain/binutils/2.16.94/300-001_ld_makefile_patch.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
#!/bin/sh -e
|
||||||
|
## 001_ld_makefile_patch.dpatch
|
||||||
|
##
|
||||||
|
## All lines beginning with `## DP:' are a description of the patch.
|
||||||
|
## DP: Description: correct where ld scripts are installed
|
||||||
|
## DP: Author: Chris Chimelis <chris@debian.org>
|
||||||
|
## DP: Upstream status: N/A
|
||||||
|
## DP: Date: ??
|
||||||
|
|
||||||
|
if [ $# -ne 1 ]; then
|
||||||
|
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
|
||||||
|
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
|
||||||
|
|
||||||
|
case "$1" in
|
||||||
|
-patch) patch $patch_opts -p1 < $0;;
|
||||||
|
-unpatch) patch $patch_opts -p1 -R < $0;;
|
||||||
|
*)
|
||||||
|
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||||
|
exit 1;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
--- binutils-2.16.91.0.1/ld/Makefile.am
|
||||||
|
+++ binutils-2.16.91.0.1/ld/Makefile.am
|
||||||
|
@@ -20,7 +20,7 @@
|
||||||
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||||
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||||
|
# directives need to be different for native and cross linkers.
|
||||||
|
-scriptdir = $(tooldir)/lib
|
||||||
|
+scriptdir = $(libdir)
|
||||||
|
|
||||||
|
EMUL = @EMUL@
|
||||||
|
EMULATION_OFILES = @EMULATION_OFILES@
|
||||||
|
--- binutils-2.16.91.0.1/ld/Makefile.in
|
||||||
|
+++ binutils-2.16.91.0.1/ld/Makefile.in
|
||||||
|
@@ -268,7 +268,7 @@
|
||||||
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||||
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||||
|
# directives need to be different for native and cross linkers.
|
||||||
|
-scriptdir = $(tooldir)/lib
|
||||||
|
+scriptdir = $(libdir)
|
||||||
|
BASEDIR = $(srcdir)/..
|
||||||
|
BFDDIR = $(BASEDIR)/bfd
|
||||||
|
INCDIR = $(BASEDIR)/include
|
43
toolchain/binutils/2.16.94/300-006_better_file_error.patch
Normal file
43
toolchain/binutils/2.16.94/300-006_better_file_error.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
#!/bin/sh -e
|
||||||
|
## 006_better_file_error.dpatch by David Kimdon <dwhedon@gordian.com>
|
||||||
|
##
|
||||||
|
## All lines beginning with `## DP:' are a description of the patch.
|
||||||
|
## DP: Specify which filename is causing an error if the filename is a
|
||||||
|
## DP: directory. (#45832)
|
||||||
|
|
||||||
|
if [ $# -ne 1 ]; then
|
||||||
|
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
|
||||||
|
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
|
||||||
|
|
||||||
|
case "$1" in
|
||||||
|
-patch) patch $patch_opts -p1 < $0;;
|
||||||
|
-unpatch) patch $patch_opts -p1 -R < $0;;
|
||||||
|
*)
|
||||||
|
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||||
|
exit 1;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
diff -urNad /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c binutils-2.14.90.0.6/bfd/opncls.c
|
||||||
|
--- /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c 2003-07-23 16:08:09.000000000 +0100
|
||||||
|
+++ binutils-2.14.90.0.6/bfd/opncls.c 2003-09-10 22:35:00.000000000 +0100
|
||||||
|
@@ -150,6 +150,13 @@
|
||||||
|
{
|
||||||
|
bfd *nbfd;
|
||||||
|
const bfd_target *target_vec;
|
||||||
|
+ struct stat s;
|
||||||
|
+
|
||||||
|
+ if (stat (filename, &s) == 0)
|
||||||
|
+ if (S_ISDIR(s.st_mode)) {
|
||||||
|
+ bfd_set_error (bfd_error_file_not_recognized);
|
||||||
|
+ return NULL;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
nbfd = _bfd_new_bfd ();
|
||||||
|
if (nbfd == NULL)
|
@ -0,0 +1,47 @@
|
|||||||
|
#!/bin/sh -e
|
||||||
|
## 012_check_ldrunpath_length.dpatch by Chris Chimelis <chris@debian.org>
|
||||||
|
##
|
||||||
|
## All lines beginning with `## DP:' are a description of the patch.
|
||||||
|
## DP: Only generate an RPATH entry if LD_RUN_PATH is not empty, for
|
||||||
|
## DP: cases where -rpath isn't specified. (#151024)
|
||||||
|
|
||||||
|
if [ $# -ne 1 ]; then
|
||||||
|
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
|
||||||
|
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
|
||||||
|
|
||||||
|
case "$1" in
|
||||||
|
-patch) patch $patch_opts -p1 < $0;;
|
||||||
|
-unpatch) patch $patch_opts -p1 -R < $0;;
|
||||||
|
*)
|
||||||
|
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||||
|
exit 1;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
diff -urNad /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em binutils-2.15/ld/emultempl/elf32.em
|
||||||
|
--- /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em 2004-05-21 23:12:58.000000000 +0100
|
||||||
|
+++ binutils-2.15/ld/emultempl/elf32.em 2004-05-21 23:12:59.000000000 +0100
|
||||||
|
@@ -692,6 +692,8 @@
|
||||||
|
&& command_line.rpath == NULL)
|
||||||
|
{
|
||||||
|
lib_path = (const char *) getenv ("LD_RUN_PATH");
|
||||||
|
+ if ((lib_path) && (strlen (lib_path) == 0))
|
||||||
|
+ lib_path = NULL;
|
||||||
|
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
|
||||||
|
force))
|
||||||
|
break;
|
||||||
|
@@ -871,6 +873,8 @@
|
||||||
|
rpath = command_line.rpath;
|
||||||
|
if (rpath == NULL)
|
||||||
|
rpath = (const char *) getenv ("LD_RUN_PATH");
|
||||||
|
+ if ((rpath) && (strlen (rpath) == 0))
|
||||||
|
+ rpath = NULL;
|
||||||
|
if (! (bfd_elf_size_dynamic_sections
|
||||||
|
(output_bfd, command_line.soname, rpath,
|
||||||
|
command_line.filter_shlib,
|
26
toolchain/binutils/2.16.94/400-mips-ELF_MAXPAGESIZE-4K.patch
Normal file
26
toolchain/binutils/2.16.94/400-mips-ELF_MAXPAGESIZE-4K.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- binutils/bfd/elf32-mips.c~
|
||||||
|
+++ binutils/bfd/elf32-mips.c
|
||||||
|
@@ -1613,7 +1613,9 @@
|
||||||
|
|
||||||
|
/* The SVR4 MIPS ABI says that this should be 0x10000, and Linux uses
|
||||||
|
page sizes of up to that limit, so we need to respect it. */
|
||||||
|
-#define ELF_MAXPAGESIZE 0x10000
|
||||||
|
+/*#define ELF_MAXPAGESIZE 0x10000*/
|
||||||
|
+/* Use 4K to shrink the elf header. NOT for general use! */
|
||||||
|
+#define ELF_MAXPAGESIZE 0x1000
|
||||||
|
#define elf32_bed elf32_tradbed
|
||||||
|
|
||||||
|
/* Include the target file again for this target. */
|
||||||
|
--- binutils/bfd/elfn32-mips.c~
|
||||||
|
+++ binutils/bfd/elfn32-mips.c
|
||||||
|
@@ -2399,7 +2399,9 @@
|
||||||
|
|
||||||
|
/* The SVR4 MIPS ABI says that this should be 0x10000, and Linux uses
|
||||||
|
page sizes of up to that limit, so we need to respect it. */
|
||||||
|
-#define ELF_MAXPAGESIZE 0x10000
|
||||||
|
+/*#define ELF_MAXPAGESIZE 0x10000*/
|
||||||
|
+/* Use 4K to shrink the elf header. NOT for general use! */
|
||||||
|
+#define ELF_MAXPAGESIZE 0x1000
|
||||||
|
#define elf32_bed elf32_tradbed
|
||||||
|
|
||||||
|
/* Include the target file again for this target. */
|
93
toolchain/binutils/2.16.94/702-binutils-skip-comments.patch
Normal file
93
toolchain/binutils/2.16.94/702-binutils-skip-comments.patch
Normal file
@ -0,0 +1,93 @@
|
|||||||
|
Retrieved from http://sources.redhat.com/ml/binutils/2004-04/msg00646.html
|
||||||
|
Fixes
|
||||||
|
localealias.s:544: Error: junk at end of line, first unrecognized character is `,'
|
||||||
|
when building glibc-2.3.2 with gcc-3.4.0 and binutils-2.15.90.0.3
|
||||||
|
|
||||||
|
Paths adjusted to match crosstool's patcher.
|
||||||
|
|
||||||
|
Message-Id: m3n052qw2g.fsf@whitebox.m5r.de
|
||||||
|
From: Andreas Schwab <schwab at suse dot de>
|
||||||
|
To: Nathan Sidwell <nathan at codesourcery dot com>
|
||||||
|
Cc: Ian Lance Taylor <ian at wasabisystems dot com>, binutils at sources dot redhat dot com
|
||||||
|
Date: Fri, 23 Apr 2004 22:27:19 +0200
|
||||||
|
Subject: Re: demand_empty_rest_of_line and ignore_rest_of_line
|
||||||
|
|
||||||
|
Nathan Sidwell <nathan@codesourcery.com> writes:
|
||||||
|
|
||||||
|
> Index: read.c
|
||||||
|
> ===================================================================
|
||||||
|
> RCS file: /cvs/src/src/gas/read.c,v
|
||||||
|
> retrieving revision 1.76
|
||||||
|
> diff -c -3 -p -r1.76 read.c
|
||||||
|
> *** read.c 12 Mar 2004 17:48:12 -0000 1.76
|
||||||
|
> --- read.c 18 Mar 2004 09:56:05 -0000
|
||||||
|
> *************** read_a_source_file (char *name)
|
||||||
|
> *** 1053,1059 ****
|
||||||
|
> #endif
|
||||||
|
> input_line_pointer--;
|
||||||
|
> /* Report unknown char as ignored. */
|
||||||
|
> ! ignore_rest_of_line ();
|
||||||
|
> }
|
||||||
|
>
|
||||||
|
> #ifdef md_after_pass_hook
|
||||||
|
> --- 1053,1059 ----
|
||||||
|
> #endif
|
||||||
|
> input_line_pointer--;
|
||||||
|
> /* Report unknown char as ignored. */
|
||||||
|
> ! demand_empty_rest_of_line ();
|
||||||
|
> }
|
||||||
|
>
|
||||||
|
> #ifdef md_after_pass_hook
|
||||||
|
|
||||||
|
This means that the unknown character is no longer ignored, despite the
|
||||||
|
comment. As a side effect a line starting with a line comment character
|
||||||
|
not followed by APP in NO_APP mode now triggers an error instead of just a
|
||||||
|
warning, breaking builds of glibc on m68k-linux. Earlier in
|
||||||
|
read_a_source_file where #APP is handled there is another comment that
|
||||||
|
claims that unknown comments are ignored, when in fact they aren't (only
|
||||||
|
the initial line comment character is skipped).
|
||||||
|
|
||||||
|
Note that the presence of #APP will mess up the line counters, but
|
||||||
|
that appears to be difficult to fix.
|
||||||
|
|
||||||
|
Andreas.
|
||||||
|
|
||||||
|
2004-04-23 Andreas Schwab <schwab@suse.de>
|
||||||
|
|
||||||
|
* read.c (read_a_source_file): Ignore unknown text after line
|
||||||
|
comment character. Fix misleading comment.
|
||||||
|
|
||||||
|
--- binutils/gas/read.c.~1.78.~ 2004-04-23 08:58:23.000000000 +0200
|
||||||
|
+++ binutils/gas/read.c 2004-04-23 21:49:01.000000000 +0200
|
||||||
|
@@ -950,10 +950,14 @@ read_a_source_file (char *name)
|
||||||
|
unsigned int new_length;
|
||||||
|
char *tmp_buf = 0;
|
||||||
|
|
||||||
|
- bump_line_counters ();
|
||||||
|
s = input_line_pointer;
|
||||||
|
if (strncmp (s, "APP\n", 4))
|
||||||
|
- continue; /* We ignore it */
|
||||||
|
+ {
|
||||||
|
+ /* We ignore it */
|
||||||
|
+ ignore_rest_of_line ();
|
||||||
|
+ continue;
|
||||||
|
+ }
|
||||||
|
+ bump_line_counters ();
|
||||||
|
s += 4;
|
||||||
|
|
||||||
|
sb_new (&sbuf);
|
||||||
|
@@ -1052,7 +1056,7 @@ read_a_source_file (char *name)
|
||||||
|
continue;
|
||||||
|
#endif
|
||||||
|
input_line_pointer--;
|
||||||
|
- /* Report unknown char as ignored. */
|
||||||
|
+ /* Report unknown char as error. */
|
||||||
|
demand_empty_rest_of_line ();
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
--
|
||||||
|
Andreas Schwab, SuSE Labs, schwab@suse.de
|
||||||
|
SuSE Linux AG, MaxfeldstraÃe 5, 90409 NÃrnberg, Germany
|
||||||
|
Key fingerprint = 58CA 54C7 6D53 942B 1756 01D3 44D5 214B 8276 4ED5
|
||||||
|
"And now for something completely different."
|
@ -47,6 +47,10 @@ choice
|
|||||||
depends !BR2_nios2
|
depends !BR2_nios2
|
||||||
bool "binutils 2.16.93"
|
bool "binutils 2.16.93"
|
||||||
|
|
||||||
|
config BR2_BINUTILS_VERSION_2_16_94
|
||||||
|
depends !BR2_nios2
|
||||||
|
bool "binutils 2.16.94"
|
||||||
|
|
||||||
config BR2_BINUTILS_VERSION_2_17_50_0_2
|
config BR2_BINUTILS_VERSION_2_17_50_0_2
|
||||||
depends !BR2_nios2
|
depends !BR2_nios2
|
||||||
bool "binutils 2.17.50.0.2"
|
bool "binutils 2.17.50.0.2"
|
||||||
@ -65,6 +69,7 @@ config BR2_BINUTILS_VERSION
|
|||||||
default "2.16.91.0.6" if BR2_BINUTILS_VERSION_2_16_91_0_6
|
default "2.16.91.0.6" if BR2_BINUTILS_VERSION_2_16_91_0_6
|
||||||
default "2.16.91.0.7" if BR2_BINUTILS_VERSION_2_16_91_0_7
|
default "2.16.91.0.7" if BR2_BINUTILS_VERSION_2_16_91_0_7
|
||||||
default "2.16.93" if BR2_BINUTILS_VERSION_2_16_93
|
default "2.16.93" if BR2_BINUTILS_VERSION_2_16_93
|
||||||
|
default "2.16.94" if BR2_BINUTILS_VERSION_2_16_94
|
||||||
default "2.17.50.0.2" if BR2_BINUTILS_VERSION_2_17_50_0_2
|
default "2.17.50.0.2" if BR2_BINUTILS_VERSION_2_17_50_0_2
|
||||||
|
|
||||||
config BR2_EXTRA_BINUTILS_CONFIG_OPTIONS
|
config BR2_EXTRA_BINUTILS_CONFIG_OPTIONS
|
||||||
|
Loading…
Reference in New Issue
Block a user