diff --git a/package/iproute2/0001-Revert-ss-prevent-Process-column-from-being-printed-.patch b/package/iproute2/0001-Revert-ss-prevent-Process-column-from-being-printed-.patch
deleted file mode 100644
index 10fa472d64..0000000000
--- a/package/iproute2/0001-Revert-ss-prevent-Process-column-from-being-printed-.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From f22c49730c3691c25a1147081363eb35aa9d1048 Mon Sep 17 00:00:00 2001
-From: Stephen Hemminger <stephen@networkplumber.org>
-Date: Sat, 13 Jan 2024 08:51:55 -0800
-Subject: [PATCH] Revert "ss: prevent "Process" column from being printed
- unless requested"
-
-This reverts commit 1607bf531fd2f984438d227ea97312df80e7cf56.
-
-This commit is being reverted because it breaks output of tcp info.
-The order of the columns enum is order sensistive.
-
-Bug: https://bugzilla.kernel.org/show_bug.cgi?id=218372
-Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
-Upstream: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=f22c49730c3691c25a1147081363eb35aa9d1048
----
- misc/ss.c | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/misc/ss.c b/misc/ss.c
-index 09dc1f37..9438382b 100644
---- a/misc/ss.c
-+++ b/misc/ss.c
-@@ -100,8 +100,8 @@ enum col_id {
- 	COL_SERV,
- 	COL_RADDR,
- 	COL_RSERV,
--	COL_PROC,
- 	COL_EXT,
-+	COL_PROC,
- 	COL_MAX
- };
-
-@@ -5795,9 +5795,6 @@ int main(int argc, char *argv[])
- 	if (ssfilter_parse(&current_filter.f, argc, argv, filter_fp))
- 		usage();
-
--	if (!show_processes)
--		columns[COL_PROC].disabled = 1;
--
- 	if (!(current_filter.dbs & (current_filter.dbs - 1)))
- 		columns[COL_NETID].disabled = 1;
-
---
-2.43.0
-
diff --git a/package/iproute2/iproute2.hash b/package/iproute2/iproute2.hash
index 0be058e64b..d57a93de7d 100644
--- a/package/iproute2/iproute2.hash
+++ b/package/iproute2/iproute2.hash
@@ -1,3 +1,3 @@
 # From https://kernel.org/pub/linux/utils/net/iproute2/sha256sums.asc
-sha256  ff942dd9828d7d1f867f61fe72ce433078c31e5d8e4a78e20f02cb5892e8841d  iproute2-6.7.0.tar.xz
+sha256  03a6cca3d71a908d1f15f7b495be2b8fe851f941458dc4664900d7f45fcf68ce  iproute2-6.8.0.tar.xz
 sha256  e6d6a009505e345fe949e1310334fcb0747f28dae2856759de102ab66b722cb4  COPYING
diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index 4adb4e3356..3db2ab925d 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IPROUTE2_VERSION = 6.7.0
+IPROUTE2_VERSION = 6.8.0
 IPROUTE2_SOURCE = iproute2-$(IPROUTE2_VERSION).tar.xz
 IPROUTE2_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/net/iproute2
 IPROUTE2_DEPENDENCIES = host-bison host-flex host-pkgconf \