package/libnfnetlink: bump to version 1.0.2
- Drop first and second patches (already in version) and so also drop autoreconf - Drop third patch (not needed since https://git.netfilter.org/libnfnetlink/commit/?id=efa1d8e417ae5b685c206853aaa0e7f762574585) - Update indentation in hash file (two spaces) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
bcdcacf0c9
commit
32ecf0e80c
@ -1,26 +0,0 @@
|
||||
From 8e5a9d8f32c9646d01d8c84e979892dfd28a7f7c Mon Sep 17 00:00:00 2001
|
||||
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
Date: Tue, 10 Sep 2013 15:35:22 -0300
|
||||
Subject: [PATCH] configure: uclinux is also linux
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 0926a1c..b979772 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -18,7 +18,7 @@ AC_DISABLE_STATIC
|
||||
AM_PROG_LIBTOOL
|
||||
|
||||
case "$host" in
|
||||
-*-*-linux*) ;;
|
||||
+*-*-linux* | *-*-uclinux*) ;;
|
||||
*) AC_MSG_ERROR([Linux only, dude!]);;
|
||||
esac
|
||||
|
||||
--
|
||||
1.8.1.5
|
||||
|
@ -1,114 +0,0 @@
|
||||
From 7a1a07c0028a1c88cd7716a058697c552a563b24 Mon Sep 17 00:00:00 2001
|
||||
From: Felix Janda <felix.janda@posteo.de>
|
||||
Date: Sat, 16 May 2015 14:49:07 +0200
|
||||
Subject: include: Sync with kernel headers
|
||||
|
||||
Signed-off-by: Felix Janda <felix.janda@posteo.de>
|
||||
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
||||
|
||||
[Retrieved from:
|
||||
https://git.netfilter.org/libnfnetlink/commit/?id=7a1a07c0028a1c88cd7716a058697c552a563b24]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
include/libnfnetlink/linux_nfnetlink.h | 44 ++++-----------------------
|
||||
include/libnfnetlink/linux_nfnetlink_compat.h | 12 ++++----
|
||||
2 files changed, 12 insertions(+), 44 deletions(-)
|
||||
|
||||
diff --git a/include/libnfnetlink/linux_nfnetlink.h b/include/libnfnetlink/linux_nfnetlink.h
|
||||
index 76a8550..44a38d6 100644
|
||||
--- a/include/libnfnetlink/linux_nfnetlink.h
|
||||
+++ b/include/libnfnetlink/linux_nfnetlink.h
|
||||
@@ -25,9 +25,9 @@ enum nfnetlink_groups {
|
||||
/* General form of address family dependent message.
|
||||
*/
|
||||
struct nfgenmsg {
|
||||
- u_int8_t nfgen_family; /* AF_xxx */
|
||||
- u_int8_t version; /* nfnetlink version */
|
||||
- u_int16_t res_id; /* resource id */
|
||||
+ __u8 nfgen_family; /* AF_xxx */
|
||||
+ __u8 version; /* nfnetlink version */
|
||||
+ __be16 res_id; /* resource id */
|
||||
};
|
||||
|
||||
#define NFNETLINK_V0 0
|
||||
@@ -46,40 +46,8 @@ struct nfgenmsg {
|
||||
#define NFNL_SUBSYS_CTNETLINK_EXP 2
|
||||
#define NFNL_SUBSYS_QUEUE 3
|
||||
#define NFNL_SUBSYS_ULOG 4
|
||||
-#define NFNL_SUBSYS_COUNT 5
|
||||
+#define NFNL_SUBSYS_OSF 5
|
||||
+#define NFNL_SUBSYS_IPSET 6
|
||||
+#define NFNL_SUBSYS_COUNT 7
|
||||
|
||||
-#ifdef __KERNEL__
|
||||
-
|
||||
-#include <linux/netlink.h>
|
||||
-#include <linux/capability.h>
|
||||
-#include <net/netlink.h>
|
||||
-
|
||||
-struct nfnl_callback
|
||||
-{
|
||||
- int (*call)(struct sock *nl, struct sk_buff *skb,
|
||||
- struct nlmsghdr *nlh, struct nlattr *cda[]);
|
||||
- const struct nla_policy *policy; /* netlink attribute policy */
|
||||
- const u_int16_t attr_count; /* number of nlattr's */
|
||||
-};
|
||||
-
|
||||
-struct nfnetlink_subsystem
|
||||
-{
|
||||
- const char *name;
|
||||
- __u8 subsys_id; /* nfnetlink subsystem ID */
|
||||
- __u8 cb_count; /* number of callbacks */
|
||||
- const struct nfnl_callback *cb; /* callback for individual types */
|
||||
-};
|
||||
-
|
||||
-extern int nfnetlink_subsys_register(const struct nfnetlink_subsystem *n);
|
||||
-extern int nfnetlink_subsys_unregister(const struct nfnetlink_subsystem *n);
|
||||
-
|
||||
-extern int nfnetlink_has_listeners(unsigned int group);
|
||||
-extern int nfnetlink_send(struct sk_buff *skb, u32 pid, unsigned group,
|
||||
- int echo);
|
||||
-extern int nfnetlink_unicast(struct sk_buff *skb, u_int32_t pid, int flags);
|
||||
-
|
||||
-#define MODULE_ALIAS_NFNL_SUBSYS(subsys) \
|
||||
- MODULE_ALIAS("nfnetlink-subsys-" __stringify(subsys))
|
||||
-
|
||||
-#endif /* __KERNEL__ */
|
||||
#endif /* _NFNETLINK_H */
|
||||
diff --git a/include/libnfnetlink/linux_nfnetlink_compat.h b/include/libnfnetlink/linux_nfnetlink_compat.h
|
||||
index e145176..74b9e55 100644
|
||||
--- a/include/libnfnetlink/linux_nfnetlink_compat.h
|
||||
+++ b/include/libnfnetlink/linux_nfnetlink_compat.h
|
||||
@@ -1,6 +1,8 @@
|
||||
#ifndef _NFNETLINK_COMPAT_H
|
||||
#define _NFNETLINK_COMPAT_H
|
||||
-#ifndef __KERNEL__
|
||||
+
|
||||
+#include <linux/types.h>
|
||||
+
|
||||
/* Old nfnetlink macros for userspace */
|
||||
|
||||
/* nfnetlink groups: Up to 32 maximum */
|
||||
@@ -18,10 +20,9 @@
|
||||
* ! nfnetlink use the same attributes methods. - J. Schulist.
|
||||
*/
|
||||
|
||||
-struct nfattr
|
||||
-{
|
||||
- u_int16_t nfa_len;
|
||||
- u_int16_t nfa_type; /* we use 15 bits for the type, and the highest
|
||||
+struct nfattr {
|
||||
+ __u16 nfa_len;
|
||||
+ __u16 nfa_type; /* we use 15 bits for the type, and the highest
|
||||
* bit to indicate whether the payload is nested */
|
||||
};
|
||||
|
||||
@@ -57,5 +58,4 @@ struct nfattr
|
||||
+ NLMSG_ALIGN(sizeof(struct nfgenmsg))))
|
||||
#define NFM_PAYLOAD(n) NLMSG_PAYLOAD(n, sizeof(struct nfgenmsg))
|
||||
|
||||
-#endif /* ! __KERNEL__ */
|
||||
#endif /* _NFNETLINK_COMPAT_H */
|
||||
--
|
||||
cgit v1.2.3
|
||||
|
@ -1,32 +0,0 @@
|
||||
Include <sys/types.h> to get the u_int* definitions
|
||||
|
||||
This is needed to fix the build with the musl C library, and this
|
||||
patch comes from
|
||||
http://git.alpinelinux.org/cgit/aports/plain/main/libnfnetlink/musl-fix-includes.patch.
|
||||
|
||||
It will no longer be needed with upcoming upstream releases of
|
||||
libnfnetlink, since they have switched to use the <stdint.h> types
|
||||
instead. However this change was too invasive to backport.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
--- libnfnetlink-1.0.1.orig/include/libnfnetlink/linux_nfnetlink.h
|
||||
+++ libnfnetlink-1.0.1/include/libnfnetlink/linux_nfnetlink.h
|
||||
@@ -1,6 +1,6 @@
|
||||
#ifndef _NFNETLINK_H
|
||||
#define _NFNETLINK_H
|
||||
-#include <linux/types.h>
|
||||
+#include <sys/types.h>
|
||||
#include <libnfnetlink/linux_nfnetlink_compat.h>
|
||||
|
||||
enum nfnetlink_groups {
|
||||
--- libnfnetlink-1.0.1.orig/include/libnfnetlink/libnfnetlink.h
|
||||
+++ libnfnetlink-1.0.1/include/libnfnetlink/libnfnetlink.h
|
||||
@@ -15,6 +15,7 @@
|
||||
#define aligned_u64 unsigned long long __attribute__((aligned(8)))
|
||||
#endif
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h> /* for sa_family_t */
|
||||
#include <linux/netlink.h>
|
||||
#include <libnfnetlink/linux_nfnetlink.h>
|
@ -1,6 +1,5 @@
|
||||
# From ftp://ftp.netfilter.org/pub/libnfnetlink/libnfnetlink-1.0.1.tar.bz2.{md5sum,sha1sum}
|
||||
md5 98927583d2016a9fb1936fed992e2c5e libnfnetlink-1.0.1.tar.bz2
|
||||
sha1 27ae2dfbd976e28cb7a417f9e946c901f512dd9a libnfnetlink-1.0.1.tar.bz2
|
||||
# From http://ftp.netfilter.org/pub/libnfnetlink/libnfnetlink-1.0.2.tar.bz2.sha256sum
|
||||
sha256 b064c7c3d426efb4786e60a8e6859b82ee2f2c5e49ffeea640cfe4fe33cbc376 libnfnetlink-1.0.2.tar.bz2
|
||||
|
||||
# Hash for license file:
|
||||
sha256 91df39d1816bfb17a4dda2d3d2c83b1f6f2d38d53e53e41e8f97ad5ac46a0cad COPYING
|
||||
sha256 91df39d1816bfb17a4dda2d3d2c83b1f6f2d38d53e53e41e8f97ad5ac46a0cad COPYING
|
||||
|
@ -4,10 +4,9 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBNFNETLINK_VERSION = 1.0.1
|
||||
LIBNFNETLINK_VERSION = 1.0.2
|
||||
LIBNFNETLINK_SOURCE = libnfnetlink-$(LIBNFNETLINK_VERSION).tar.bz2
|
||||
LIBNFNETLINK_SITE = http://www.netfilter.org/projects/libnfnetlink/files
|
||||
LIBNFNETLINK_AUTORECONF = YES
|
||||
LIBNFNETLINK_INSTALL_STAGING = YES
|
||||
LIBNFNETLINK_LICENSE = GPL-2.0
|
||||
LIBNFNETLINK_LICENSE_FILES = COPYING
|
||||
|
Loading…
Reference in New Issue
Block a user