package/google-breakpad: bump version to f49c2f1a2023da0cb055874fba050563dfea57db

- Drop no longer needed
  0001-mainline-version-gcc-13-cannot-use-uintptr_t-via-inc.patch as
  it was a backport from upstream

- Updated license hash due to numerous additions of licenses, and
  updated copyright years. The LICENSE variable was updated
  accordingly, and clarified

- zlib is now a mandatory dependency, it is not checked at configure
  time, but <zlib.h> is uncondtionnally included, and libzlib is
  linked in unconditionnally. See
  de086a9859

- explicitly disable zstd support, which was added in upstream commit
  9ea5b228f5. This
  requires adding AUTORECONF = YES because the pre-generated
  configure/Makefile.in available in the Git repository is out of
  date, and links unconditionnally with -lzstd, even when
  --disable-zstd is passed.

Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
[Thomas: handle zlib dependency, handle zstd option, fix LICENSE variable]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Adam Duskett 2023-12-02 21:18:39 -07:00 committed by Thomas Petazzoni
parent 875b898b98
commit 32c1fbad55
4 changed files with 20 additions and 36 deletions

View File

@ -1,30 +0,0 @@
From 7ea7ded187b4d739239f3ab7082fcd5a2ccc1eaa Mon Sep 17 00:00:00 2001
From: mingtaoxt xt <mingtaoxt@gmail.com>
Date: Wed, 19 Oct 2022 19:36:13 +0800
Subject: [PATCH] mainline version gcc-13 cannot use "uintptr_t" via "#include
<string>"
Change-Id: I0049bb92658b4226e32783ad4d8271787deef5f3
Reviewed-on: https://chromium-review.googlesource.com/c/breakpad/breakpad/+/3964166
Reviewed-by: Mike Frysinger <vapier@chromium.org>
Upstream: https://chromium.googlesource.com/breakpad/breakpad/+/7ea7ded187b4d739239f3ab7082fcd5a2ccc1eaa
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
src/client/linux/handler/minidump_descriptor.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/client/linux/handler/minidump_descriptor.h b/src/client/linux/handler/minidump_descriptor.h
index 4349b88f..d822c9d9 100644
--- a/src/client/linux/handler/minidump_descriptor.h
+++ b/src/client/linux/handler/minidump_descriptor.h
@@ -32,6 +32,7 @@
#include <assert.h>
#include <sys/types.h>
+#include <cstdint>
#include <string>
#include "client/linux/handler/microdump_extra_info.h"
--
2.43.0

View File

@ -13,6 +13,7 @@ config BR2_PACKAGE_GOOGLE_BREAKPAD
depends on BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS
depends on BR2_PACKAGE_HOST_GOOGLE_BREAKPAD_ARCH_SUPPORTS
select BR2_PACKAGE_LINUX_SYSCALL_SUPPORT
select BR2_PACKAGE_ZLIB
help
Google-Breakpad is a library and tool suite that allows you
to distribute an application to users with compiler-provided

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 52716d140ba528d36b40591ae2c7485b18023f6610414bba0057f0cc13caf256 google-breakpad-c85eb4a59b618f3beaad5445ceb1f865ffa8efdf-br1.tar.gz
sha256 8d5d1311342ed55b486d778a6763f54a26002698ac0cbab64026b98033300dfd LICENSE
sha256 29e147011bf6577df95ee3a50bf5ffd1941645dd414d569bd409a9035bcbb7f7 google-breakpad-f49c2f1a2023da0cb055874fba050563dfea57db-br1.tar.gz
sha256 69b3d80c19a460e09716910d54d1ada5d800716e2b73751bebac44352590f646 LICENSE

View File

@ -4,15 +4,28 @@
#
################################################################################
GOOGLE_BREAKPAD_VERSION = c85eb4a59b618f3beaad5445ceb1f865ffa8efdf
GOOGLE_BREAKPAD_VERSION = f49c2f1a2023da0cb055874fba050563dfea57db
GOOGLE_BREAKPAD_SITE = https://chromium.googlesource.com/breakpad/breakpad
GOOGLE_BREAKPAD_SITE_METHOD = git
GOOGLE_BREAKPAD_INSTALL_STAGING = YES
GOOGLE_BREAKPAD_LICENSE = BSD-3-Clause, MIT
# APSL-2.0, BSD-4-Clause, Apache-2.0, BSD-2-Clause not listed, only
# used for Mac code, GPL-2.0 not listed, only used for autotools code
GOOGLE_BREAKPAD_LICENSE = \
BSD-3-Clause, \
Unicode-DFS-2015 (UTF code), \
MIT (src/common/linux/breakpad_getcontext.S), \
curl (src/third_party/curl/), \
ClArtistic (src/third_party/libdisasm)
GOOGLE_BREAKPAD_LICENSE_FILES = LICENSE
GOOGLE_BREAKPAD_DEPENDENCIES = host-google-breakpad linux-syscall-support
# Needed because the configure/Makefile.in provided in the Git
# repository is out of date, and links with -lzstd even if
# --disable-zstd is passed
GOOGLE_BREAKPAD_AUTORECONF = YES
GOOGLE_BREAKPAD_DEPENDENCIES = host-google-breakpad linux-syscall-support zlib
GOOGLE_BREAKPAD_CONF_OPTS = --disable-zstd
HOST_GOOGLE_BREAKPAD_DEPENDENCIES = host-linux-syscall-support
HOST_GOOGLE_BREAKPAD_DEPENDENCIES = host-linux-syscall-support host-zlib
HOST_GOOGLE_BREAKPAD_CONF_OPTS = --disable-zstd
ifeq ($(BR2_PACKAGE_GOOGLE_BREAKPAD_TOOLS),)
GOOGLE_BREAKPAD_INSTALL_TARGET = NO