perl-gd: bump to version 2.56
perl-gd now supplies a Build.PL, but this one is not cross-compilation friendly. So, we still use Makefile.PL like in previous version by using the new <pkg>_PREFER_INSTALLER variable. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
7f102d8284
commit
31c3ad17ed
@ -7,7 +7,7 @@ Index: b/Makefile.PL
|
||||
===================================================================
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -34,9 +34,9 @@
|
||||
@@ -42,9 +42,9 @@
|
||||
END
|
||||
}
|
||||
|
||||
@ -18,7 +18,7 @@ Index: b/Makefile.PL
|
||||
|
||||
# support for AMD64 libraries
|
||||
if (-d '/usr/lib64') {
|
||||
@@ -291,7 +291,6 @@
|
||||
@@ -294,7 +294,6 @@
|
||||
@$LIBPATH = map {s/^-L// && "-L$_"} split /\s+/,$ldflags;
|
||||
@$LIBS = split /\s+/,$libs;
|
||||
|
||||
|
@ -7,7 +7,7 @@ Index: b/Makefile.PL
|
||||
===================================================================
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -35,13 +35,15 @@
|
||||
@@ -43,13 +43,15 @@
|
||||
}
|
||||
|
||||
push @LIBS, "-lgd";
|
||||
|
@ -53,7 +53,7 @@ index dfe8ad7..0fa6ef3 100644
|
||||
#############################################################################################
|
||||
|
||||
if ($^O eq 'VMS'){
|
||||
@@ -275,7 +286,7 @@ exit 0;
|
||||
@@ -278,7 +289,7 @@ exit 0;
|
||||
|
||||
sub try_to_autoconfigure {
|
||||
my ($options,$lib_gd_path,$INC,$LIBPATH,$LIBS) = @_;
|
||||
|
@ -6,7 +6,7 @@ config BR2_PACKAGE_PERL_GD
|
||||
select BR2_PACKAGE_FREETYPE
|
||||
select BR2_PACKAGE_GD
|
||||
help
|
||||
Interface to Gd Graphics Library
|
||||
Perl interface to the gd2 graphics library
|
||||
|
||||
https://metacpan.org/release/GD
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
# retrieved by scancpan from http://cpan.metacpan.org/
|
||||
md5 d2c9b18123bcaff8672eb50f2eb37ed3 GD-2.53.tar.gz
|
||||
sha256 d05d01fe95e581adb3468cf05ab5d405db7497c0fb3ec7ecf23d023705fab7aa GD-2.53.tar.gz
|
||||
md5 c4b3afd98b2c4ce3c2e1027d101a8f1e GD-2.56.tar.gz
|
||||
sha256 1f103d1c98de8621504642ed7fb79f1b40f5f6a63c2abe9390a8ab78617248f9 GD-2.56.tar.gz
|
||||
|
@ -4,12 +4,13 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PERL_GD_VERSION = 2.53
|
||||
PERL_GD_VERSION = 2.56
|
||||
PERL_GD_SOURCE = GD-$(PERL_GD_VERSION).tar.gz
|
||||
PERL_GD_SITE = $(BR2_CPAN_MIRROR)/authors/id/L/LD/LDS
|
||||
PERL_GD_DEPENDENCIES = zlib libpng freetype gd
|
||||
PERL_GD_LICENSE = Artistic-2.0 or GPLv1+
|
||||
PERL_GD_LICENSE = Artistic or GPLv1+
|
||||
PERL_GD_LICENSE_FILES = LICENSE
|
||||
PERL_GD_PREFER_INSTALLER = EUMM
|
||||
|
||||
PERL_GD_CONF_OPTS = \
|
||||
-options=FT,PNG \
|
||||
|
Loading…
Reference in New Issue
Block a user