package/zlib-ng: fix version in zlib.pc when building statically

Fix the following static build failure with transmission:

checking for ZLIB... configure: error: Package requirements (zlib >= 1.2.3) were not met:

Package dependency requirement 'zlib >= 1.2.3' could not be satisfied.
Package 'zlib' has version '', required version is '>= 1.2.3'

Fixes:
 - http://autobuild.buildroot.org/results/b3b882482f517726e5c780ba4c37818bd379df82

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2022-05-31 21:10:36 +02:00 committed by Thomas Petazzoni
parent eb5e2d2d43
commit 31a7427662

View File

@ -0,0 +1,53 @@
From 9fcc446306f27eb253545540ce28403874b899fa Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Fri, 27 May 2022 23:25:21 +0200
Subject: [PATCH] CMakeLists.txt: fix version in zlib.pc when building
statically
When building statically (i.e. with BUILD_SHARED_LIBS=OFF),
ZLIB_FULL_VERSION is not set resulting in an empty version in zlib.pc
and the following build failure with transmission:
checking for ZLIB... configure: error: Package requirements (zlib >= 1.2.3) were not met:
Package dependency requirement 'zlib >= 1.2.3' could not be satisfied.
Package 'zlib' has version '', required version is '>= 1.2.3'
Fixes:
- http://autobuild.buildroot.org/results/b3b882482f517726e5c780ba4c37818bd379df82
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/zlib-ng/zlib-ng/pull/1278]
---
CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a62a95e..6a26d59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,8 +150,10 @@ if(ZLIB_COMPAT)
add_definitions(-DZLIB_COMPAT)
set(WITH_GZFILEOP ON)
set(SUFFIX "")
+ set(ZLIB_FULL_VERSION ${ZLIB_HEADER_VERSION}.zlib-ng)
else()
set(SUFFIX "-ng")
+ set(ZLIB_FULL_VERSION ${ZLIBNG_HEADER_VERSION})
endif()
if(WITH_GZFILEOP)
@@ -1068,10 +1070,8 @@ if(NOT DEFINED BUILD_SHARED_LIBS OR BUILD_SHARED_LIBS)
set_target_properties(zlib PROPERTIES DEFINE_SYMBOL ZLIB_DLL)
if(ZLIB_COMPAT)
- set(ZLIB_FULL_VERSION ${ZLIB_HEADER_VERSION}.zlib-ng)
set_target_properties(zlib PROPERTIES SOVERSION 1)
else()
- set(ZLIB_FULL_VERSION ${ZLIBNG_HEADER_VERSION})
set_target_properties(zlib PROPERTIES SOVERSION 2)
endif()
--
2.35.1