package/open62541: disable -Werror
Disable -Werror to avoid the following build failures raised since bump
to version 1.2.2 in commit b436b82411
:
/tmp/instance-0/output-1/build/open62541-v1.2.2/arch/network_tcp.c: In function 'connection_recv':
/tmp/instance-0/output-1/build/open62541-v1.2.2/arch/network_tcp.c:96:5: error: conversion to 'unsigned int' from 'int' may change the sign of the result [-Werror=sign-conversion]
96 | UA_fd_set(connection->sockfd, &fdset);
| ^~~~~~~~~
/tmp/instance-6/output-1/build/open62541-v1.2.2/plugins/ua_pubsub_udp.c: In function 'UA_PubSubChannelUDPMC_receive':
/tmp/instance-6/output-1/build/open62541-v1.2.2/plugins/ua_pubsub_udp.c:477:21: error: conversion to '__suseconds_t' {aka 'int'} from 'UA_UInt32' {aka 'unsigned int'} may change the sign of the result [-Werror=sign-conversion]
477 | tmptv.tv_usec = (long int)(timeout % 1000000);
| ^
Fixes:
- http://autobuild.buildroot.org/results/911811de81d8abb2a31feb8f27af1592641c6fbc
- http://autobuild.buildroot.org/results/f0187b3f2d62e955fddeef4e90f84ba4fd642bd2
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
c5b016c618
commit
315ce32648
@ -0,0 +1,54 @@
|
||||
From a439daafdc98391eed13e23f93ecfca81d71c731 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Mon, 2 Aug 2021 09:49:48 +0200
|
||||
Subject: [PATCH] CMakeLists.txt: add UA_FORCE_WERROR
|
||||
|
||||
Allow the user to disable -Werror to avoid the following build failures:
|
||||
|
||||
/tmp/instance-0/output-1/build/open62541-v1.2.2/arch/network_tcp.c: In function 'connection_recv':
|
||||
/tmp/instance-0/output-1/build/open62541-v1.2.2/arch/network_tcp.c:96:5: error: conversion to 'unsigned int' from 'int' may change the sign of the result [-Werror=sign-conversion]
|
||||
96 | UA_fd_set(connection->sockfd, &fdset);
|
||||
| ^~~~~~~~~
|
||||
|
||||
/tmp/instance-6/output-1/build/open62541-v1.2.2/plugins/ua_pubsub_udp.c: In function 'UA_PubSubChannelUDPMC_receive':
|
||||
/tmp/instance-6/output-1/build/open62541-v1.2.2/plugins/ua_pubsub_udp.c:477:21: error: conversion to '__suseconds_t' {aka 'int'} from 'UA_UInt32' {aka 'unsigned int'} may change the sign of the result [-Werror=sign-conversion]
|
||||
477 | tmptv.tv_usec = (long int)(timeout % 1000000);
|
||||
| ^
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/911811de81d8abb2a31feb8f27af1592641c6fbc
|
||||
- http://autobuild.buildroot.org/results/f0187b3f2d62e955fddeef4e90f84ba4fd642bd2
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: https://github.com/open62541/open62541/pull/4572]
|
||||
---
|
||||
CMakeLists.txt | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index bc839f27..963460d0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -292,6 +292,8 @@ if(UA_FORCE_CPP)
|
||||
add_definitions(-D__STDC_CONSTANT_MACROS) # We need the UINT32_C define
|
||||
endif()
|
||||
|
||||
+option(UA_FORCE_WERROR "Force compilation with -Werror" ON)
|
||||
+
|
||||
#General PubSub setup
|
||||
option(UA_ENABLE_PUBSUB "Enable the PubSub protocol" OFF)
|
||||
|
||||
@@ -589,7 +591,9 @@ if(NOT UA_FORCE_CPP AND (CMAKE_COMPILER_IS_GNUCC OR "x${CMAKE_C_COMPILER_ID}" ST
|
||||
check_add_cc_flag("-Wall") # Warnings
|
||||
check_add_cc_flag("-Wextra") # More warnings
|
||||
check_add_cc_flag("-Wpedantic") # Standard compliance
|
||||
- check_add_cc_flag("-Werror") # All warnings are errors
|
||||
+ if(UA_FORCE_WERROR)
|
||||
+ check_add_cc_flag("-Werror") # All warnings are errors
|
||||
+ endif()
|
||||
|
||||
check_add_cc_flag("-Wno-static-in-inline") # Clang doesn't like the use of static inline methods inside static inline methods
|
||||
check_add_cc_flag("-Wno-overlength-strings") # May happen in the nodeset compiler when complex values are directly encoded
|
||||
--
|
||||
2.30.2
|
||||
|
@ -19,7 +19,8 @@ OPEN62541_CONF_OPTS = \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DGIT_EXECUTABLE=NO \
|
||||
-DOPEN62541_VERSION=$(OPEN62541_VERSION) \
|
||||
-DUA_ENABLE_HARDENING=OFF
|
||||
-DUA_ENABLE_HARDENING=OFF \
|
||||
-DUA_FORCE_WERROR=OFF
|
||||
|
||||
ifeq ($(BR2_PACKAGE_OPEN62541_UA_NAMESPACE_ZERO_MINIMAL),y)
|
||||
OPEN62541_CONF_OPTS += -DUA_NAMESPACE_ZERO=MINIMAL
|
||||
|
Loading…
Reference in New Issue
Block a user