python-paho-mqtt: bump to version 1.3.0

Change setup type to setuptools.

Add a patch removing the pytest-runner dependency. The patch was sent
upstream.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Yegor Yefremov 2017-09-08 10:38:16 +02:00 committed by Peter Korsgaard
parent 95389fe98c
commit 30f667b704
3 changed files with 35 additions and 5 deletions

View File

@ -0,0 +1,30 @@
From 38373d36094b5a708c595f8c560d14e8ab61aac6 Mon Sep 17 00:00:00 2001
From: Yegor Yefremov <yegorslists@googlemail.com>
Date: Fri, 8 Sep 2017 08:58:31 +0200
Subject: [PATCH] Make pytest-runner a conditional requirement
Check for pytest-runner only if setup.py was invoked with 'test'
argument.
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
setup.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 85d9c5f..10fb6df 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,8 @@ with open('README.rst', 'rb') as readme_file:
requirements = []
test_requirements = ['pytest', 'pylama']
-setup_requirements = ['pytest-runner']
+needs_pytest = set(['pytest', 'test', 'ptr']).intersection(sys.argv)
+setup_requirements = ['pytest-runner'] if needs_pytest else []
if sys.version_info < (3, 0):
test_requirements += ['mock']
--
2.11.0

View File

@ -1,3 +1,3 @@
# md5 from https://pypi.python.org/pypi/paho-mqtt/json, sha256 locally computed
md5 241150b3fcb920ddca4d33181f3238b1 paho-mqtt-1.2.tar.gz
sha256 9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f paho-mqtt-1.2.tar.gz
md5 b9338236e2836e8579ef140956189cc4 paho-mqtt-1.3.0.tar.gz
sha256 2c9ef5494cfc1e41a9fff6544c5a2cd59ea5d401d9119a06ecf7fad6a2ffeb93 paho-mqtt-1.3.0.tar.gz

View File

@ -4,11 +4,11 @@
#
################################################################################
PYTHON_PAHO_MQTT_VERSION = 1.2
PYTHON_PAHO_MQTT_VERSION = 1.3.0
PYTHON_PAHO_MQTT_SOURCE = paho-mqtt-$(PYTHON_PAHO_MQTT_VERSION).tar.gz
PYTHON_PAHO_MQTT_SITE = https://pypi.python.org/packages/82/d9/7064d3a0a1d62756a1a809c85b99f864c641b66de84c15458f72193b7708
PYTHON_PAHO_MQTT_SITE = https://pypi.python.org/packages/33/7f/3ce1ffebaa0343d509aac003800b305d821e89dac3c11666f92e12feca14
PYTHON_PAHO_MQTT_LICENSE = EPL-1.0 or EDLv1.0
PYTHON_PAHO_MQTT_LICENSE_FILES = LICENSE.txt edl-v10 epl-v10
PYTHON_PAHO_MQTT_SETUP_TYPE = distutils
PYTHON_PAHO_MQTT_SETUP_TYPE = setuptools
$(eval $(python-package))