Merge branch 'misc-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
This commit is contained in:
commit
2f81dd315f
@ -604,10 +604,10 @@ CONFIG_DEVMEM=y
|
||||
CONFIG_EJECT=y
|
||||
# CONFIG_FEATURE_EJECT_SCSI is not set
|
||||
# CONFIG_FBSPLASH is not set
|
||||
CONFIG_FLASHCP=y
|
||||
CONFIG_FLASH_LOCK=y
|
||||
CONFIG_FLASH_UNLOCK=y
|
||||
CONFIG_FLASH_ERASEALL=y
|
||||
# CONFIG_FLASHCP is not set
|
||||
# CONFIG_FLASH_LOCK is not set
|
||||
# CONFIG_FLASH_UNLOCK is not set
|
||||
# CONFIG_FLASH_ERASEALL is not set
|
||||
# CONFIG_IONICE is not set
|
||||
# CONFIG_INOTIFYD is not set
|
||||
CONFIG_LAST=y
|
||||
|
@ -13,7 +13,8 @@ LIBXCB_AUTORECONF = NO
|
||||
LIBXCB_LIBTOOL_PATCH = NO
|
||||
LIBXCB_DEPENDENCIES = host-libxslt pthread-stubs xcb-proto xlib_libXdmcp xlib_libXau
|
||||
LIBXCB_CONF_ENV = STAGING_DIR="$(STAGING_DIR)"
|
||||
LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb XCBPROTO_XCBPYTHONDIR=$(STAGING_DIR)/usr/lib/python2.6/site-packages
|
||||
HOST_PYTHON_VERSION=$(shell python --version 2>&1 | sed 's/Python \(2\.[0-9]\)\..*/\1/')
|
||||
LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb XCBPROTO_XCBPYTHONDIR=$(STAGING_DIR)/usr/lib/python$(HOST_PYTHON_VERSION)/site-packages
|
||||
|
||||
$(eval $(call AUTOTARGETS,package/x11r7,libxcb))
|
||||
|
||||
|
35
package/x11r7/xlib_libX11/xlib_libX11-1.3.2-keysymdef.patch
Normal file
35
package/x11r7/xlib_libX11/xlib_libX11-1.3.2-keysymdef.patch
Normal file
@ -0,0 +1,35 @@
|
||||
[patch]: configure: add --with-keysymdef argument for cross compilation
|
||||
|
||||
Based on a similar patch from Openembedded.
|
||||
|
||||
The libX11 configure script hardcodes the location to keysymdef.h as
|
||||
<prefix>/include/X11/keysymdef.h, which is fine for native compilation,
|
||||
but breaks with cross compilation as that directory is a location on
|
||||
the target, not the build host.
|
||||
|
||||
Fix it by providing an explicit --with-keysymdef=<full-path-to-file>.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>Index: libX11-1.1.5/configure.ac
|
||||
===================================================================
|
||||
Index: xlib_libX11-1.3.2/configure.ac
|
||||
===================================================================
|
||||
--- xlib_libX11-1.3.2.orig/configure.ac 2009-10-23 22:55:03.000000000 +0200
|
||||
+++ xlib_libX11-1.3.2/configure.ac 2010-05-04 16:26:39.000000000 +0200
|
||||
@@ -280,8 +280,15 @@
|
||||
# Find keysymdef.h
|
||||
#
|
||||
AC_MSG_CHECKING([keysymdef.h])
|
||||
-dir=`pkg-config --variable=includedir xproto`
|
||||
-KEYSYMDEF="$dir/X11/keysymdef.h"
|
||||
+AC_ARG_WITH(keysymdef,
|
||||
+ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
|
||||
+ KEYSYMDEF=$withval, KEYSYMDEF="")
|
||||
+
|
||||
+if test x$KEYSYMDEF = x; then
|
||||
+ dir=`pkg-config --variable=includedir xproto`
|
||||
+ KEYSYMDEF="$dir/X11/keysymdef.h"
|
||||
+fi
|
||||
+
|
||||
if test -f "$KEYSYMDEF"; then
|
||||
AC_MSG_RESULT([$KEYSYMDEF])
|
||||
else
|
@ -122,7 +122,7 @@ if ! $SHELL --version 2>&1 | grep -q '^GNU bash'; then
|
||||
fi;
|
||||
|
||||
# Check that a few mandatory programs are installed
|
||||
for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio ; do
|
||||
for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio python ; do
|
||||
if ! which $prog > /dev/null ; then
|
||||
/bin/echo -e "\nYou must install '$prog' on your build machine";
|
||||
if test $prog = "makeinfo" ; then
|
||||
|
Loading…
Reference in New Issue
Block a user