package/gst1-plugins-base: bump version to 1.18.5

- delete 0002-gstgl-Fix-build-when-Meson-0.58.0rc1.patch
  (from upstream [1])

[1] 90903917a8

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Peter Seiderer 2021-09-13 23:04:01 +02:00 committed by Yann E. MORIN
parent 97fddaa3df
commit 2f707103c3
3 changed files with 3 additions and 54 deletions

View File

@ -1,51 +0,0 @@
From 90903917a8185e0f9add7af8153ae2fc9875fdcb Mon Sep 17 00:00:00 2001
From: Xavier Claessens <xavier.claessens@collabora.com>
Date: Mon, 26 Apr 2021 14:25:03 -0400
Subject: [PATCH] gstgl: Fix build when Meson >= 0.58.0rc1
"implicit_include_directories: false" now also means that current build
directory is not added to include paths by default any more. We have to
add it manually because we have some custom_target() that generate
headers in current build directory.
See https://github.com/mesonbuild/meson/issues/8700.
Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/1127>
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[james.hilliard1@gmail.com: backport from upstream commit
90903917a8185e0f9add7af8153ae2fc9875fdcb]
---
gst-libs/gst/gl/meson.build | 15 ++++++++++++---
1 file changed, 12 insertions(+), 3 deletions(-)
diff --git a/gst-libs/gst/gl/meson.build b/gst-libs/gst/gl/meson.build
index db11c5e89..731ee9f5e 100644
--- a/gst-libs/gst/gl/meson.build
+++ b/gst-libs/gst/gl/meson.build
@@ -989,11 +989,20 @@ if build_gstgl
command : [mkenums, glib_mkenums, '@OUTPUT@', '@INPUT@'])
gen_sources = [gl_enumtypes_h]
+ common_args = gst_plugins_base_args + gl_cpp_args + ['-DBUILDING_GST_GL']
+
+ # We have custom_target() that generate headers in the current build dir,
+ # but with implicit_include_directories: false, meson >= 0.58.0 won't include
+ # it by default. We cannot use include_directories('.') here because it would
+ # also include current source dir which is what we want to avoid because
+ # case-insensitive FS would include gst-libs/gl/egl/egl.h as EGL/egl.h.
+ common_args += '-I@0@'.format(meson.current_build_dir())
+
gstgl = library('gstgl-' + api_version,
gl_sources, gl_egl_sources, gl_x11_sources, gl_wayland_sources, gl_priv_sources, gl_enumtypes_c, gl_enumtypes_h,
- c_args : gst_plugins_base_args + gl_cpp_args + ['-DBUILDING_GST_GL'],
- cpp_args : gst_plugins_base_args + gl_cpp_args + ['-DBUILDING_GST_GL'],
- objc_args : gst_plugins_base_args + gl_cpp_args + gl_objc_args + ['-DBUILDING_GST_GL'],
+ c_args : common_args,
+ cpp_args : common_args,
+ objc_args : common_args + gl_objc_args,
include_directories : [configinc, libsinc, gl_includes],
version : libversion,
soversion : soversion,
--
2.25.1

View File

@ -1,3 +1,3 @@
# From https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-1.18.4.tar.xz.sha256sum
sha256 29e53229a84d01d722f6f6db13087231cdf6113dd85c25746b9b58c3d68e8323 gst-plugins-base-1.18.4.tar.xz
# From https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-1.18.5.tar.xz.sha256sum
sha256 960b7af4585700db0fdd5b843554e11e2564fed9e061f591fae88a7be6446fa3 gst-plugins-base-1.18.5.tar.xz
sha256 f445dc78b88496f7e20c7a2a461b95baba5865c8919b8289ac24ac0a80c6ce7a COPYING

View File

@ -4,7 +4,7 @@
#
################################################################################
GST1_PLUGINS_BASE_VERSION = 1.18.4
GST1_PLUGINS_BASE_VERSION = 1.18.5
GST1_PLUGINS_BASE_SOURCE = gst-plugins-base-$(GST1_PLUGINS_BASE_VERSION).tar.xz
GST1_PLUGINS_BASE_SITE = https://gstreamer.freedesktop.org/src/gst-plugins-base
GST1_PLUGINS_BASE_INSTALL_STAGING = YES