package/gli: disable tests
Disable tests to avoid the following build failure with gcc 11: /srv/storage/autobuild/run/instance-2/output-1/build/gli-559cbe1ec38878e182507d331e0780fbae5baf15/test/core/core_convert.cpp: In function 'bool convert_rgb32f_rgb9e5(const char*, const char*)': /srv/storage/autobuild/run/instance-2/output-1/build/gli-559cbe1ec38878e182507d331e0780fbae5baf15/test/core/core_convert.cpp:36:45: error: ordered comparison of pointer with integer zero ('const char*' and 'int') 36 | if(std::strstr(FilenameDst, ".dds") > 0 || std::strstr(FilenameDst, ".ktx") > 0) | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~ Fixes: - http://autobuild.buildroot.org/results/4f1dbb7cf2b071f3b92d00d13984068ef5f5b329 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
f0baab0d51
commit
2f57920841
45
package/gli/0001-Optional-building-tests.patch
Normal file
45
package/gli/0001-Optional-building-tests.patch
Normal file
@ -0,0 +1,45 @@
|
||||
From 629fc81ce73114a5925484937df796467adbe8c7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jo=C3=A3o=20Pereira?= <pereira.john94@gmail.com>
|
||||
Date: Fri, 22 Mar 2019 22:58:17 +0000
|
||||
Subject: [PATCH] Optional building tests
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/g-truc/gli/commit/629fc81ce73114a5925484937df796467adbe8c7]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 1 +
|
||||
test/CMakeLists.txt | 8 +++++---
|
||||
2 files changed, 6 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6eb1a68b..bcff7ef0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -13,6 +13,7 @@ include(GNUInstallDirs)
|
||||
include(CMakePackageConfigHelpers)
|
||||
|
||||
enable_testing()
|
||||
+option(GLI_TEST_ENABLE "Build unit tests" ON)
|
||||
|
||||
add_definitions(-D_CRT_SECURE_NO_WARNINGS)
|
||||
add_definitions(-DSOURCE_DIR="${CMAKE_CURRENT_SOURCE_DIR}")
|
||||
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
|
||||
index 6b1d4826..e51a3181 100644
|
||||
--- a/test/CMakeLists.txt
|
||||
+++ b/test/CMakeLists.txt
|
||||
@@ -19,10 +19,12 @@ function(glmCreateTestGTC NAME)
|
||||
set(SAMPLE_NAME test-${NAME})
|
||||
add_executable(${SAMPLE_NAME} ${NAME}.cpp)
|
||||
target_link_libraries(${SAMPLE_NAME} gli)
|
||||
- add_test(
|
||||
+ add_test(
|
||||
NAME ${SAMPLE_NAME}
|
||||
COMMAND $<TARGET_FILE:${SAMPLE_NAME}> )
|
||||
endfunction()
|
||||
|
||||
-add_subdirectory(bug)
|
||||
-add_subdirectory(core)
|
||||
+if(GLI_TEST_ENABLE)
|
||||
+ add_subdirectory(bug)
|
||||
+ add_subdirectory(core)
|
||||
+endif()
|
@ -14,4 +14,6 @@ GLI_LICENSE_FILES = manual.md
|
||||
GLI_INSTALL_STAGING = YES
|
||||
GLI_INSTALL_TARGET = NO
|
||||
|
||||
GLI_CONF_OPTS = -DGLI_TEST_ENABLE=OFF
|
||||
|
||||
$(eval $(cmake-package))
|
||||
|
Loading…
Reference in New Issue
Block a user