package/at-spi2-atk: remove package
at-spi2-atk has been merged into at-spi2-core with version 2.45.1. https://gitlab.gnome.org/GNOME/at-spi2-core/-/blob/AT_SPI2_CORE_2_45_1/NEWS https://gitlab.gnome.org/GNOME/at-spi2-core/-/merge_requests/78 Signed-off-by: Daniel Lang <d.lang@abatec.at> Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com> Tested-by: Adrian Perez de Castro <aperez@igalia.com> Reviewed-by: Adrian Perez de Castro <aperez@igalia.com> [yann.morin.1998@free.fr: regenerate .checkpackageignore] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
d1757fdfb0
commit
2f43af1b99
@ -181,7 +181,6 @@ package/asterisk/0003-build-ensure-target-directory-for-modules-exists.patch Ups
|
||||
package/asterisk/0004-install-samples-need-the-data-files.patch Upstream
|
||||
package/asterisk/0005-configure-fix-detection-of-re-entrant-resolver-funct.patch Upstream
|
||||
package/asterisk/0006-main-iostream.c-fix-build-with-libressl.patch Upstream
|
||||
package/at-spi2-atk/0001-meson-add-tests-option.patch Upstream
|
||||
package/at/0001-Makefile.in-fix-make-install-for-non-root-don-t-stri.patch Upstream
|
||||
package/at/S99at Indent Variables
|
||||
package/atest/0001-seq.h-fix-build-with-gcc-10.patch Upstream
|
||||
|
@ -146,6 +146,12 @@ endif
|
||||
|
||||
comment "Legacy options removed in 2023.05"
|
||||
|
||||
config BR2_PACKAGE_AT_SPI2_ATK
|
||||
bool "at-spi2-atk removed"
|
||||
select BR2_LEGACY
|
||||
help
|
||||
at-spi2-atk is now part of at-spi2-core.
|
||||
|
||||
config BR2_PACKAGE_OPTEE_BENCHMARK
|
||||
bool "optee-benchmark has been removed"
|
||||
select BR2_LEGACY
|
||||
|
@ -1632,7 +1632,6 @@ F: support/testing/tests/package/test_avocado.py
|
||||
F: support/testing/tests/package/test_python_aexpect.py
|
||||
|
||||
N: Joseph Kogut <joseph.kogut@gmail.com>
|
||||
F: package/at-spi2-atk/
|
||||
F: package/at-spi2-core/
|
||||
F: package/clang/
|
||||
F: package/earlyoom/
|
||||
|
@ -1554,7 +1554,6 @@ endmenu
|
||||
|
||||
menu "Graphics"
|
||||
source "package/assimp/Config.in"
|
||||
source "package/at-spi2-atk/Config.in"
|
||||
source "package/at-spi2-core/Config.in"
|
||||
source "package/atk/Config.in"
|
||||
source "package/atkmm/Config.in"
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 466d04a57b32417dbf2d5e818af1b7593af5f802 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sun, 3 May 2020 10:29:36 +0200
|
||||
Subject: [PATCH] meson: add tests option
|
||||
|
||||
Add tests option to allow the user to build at-spi2-atk without tests,
|
||||
it is especially useful as one of the test requires libxml-2.0
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status:
|
||||
https://gitlab.gnome.org/GNOME/at-spi2-atk/-/merge_requests/22]
|
||||
---
|
||||
meson.build | 4 +++-
|
||||
meson_options.txt | 4 ++++
|
||||
2 files changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 9fce5d6..61bc93d 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -61,4 +61,6 @@ install_data('at-spi2-atk.desktop',
|
||||
|
||||
subdir('droute')
|
||||
subdir('atk-adaptor')
|
||||
-subdir('tests')
|
||||
+if get_option('tests')
|
||||
+ subdir('tests')
|
||||
+endif
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index 24c9228..a4abdc2 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -2,3 +2,7 @@ option('disable_p2p',
|
||||
description: 'Disable peer-to-peer DBus connections',
|
||||
type: 'boolean',
|
||||
value: false)
|
||||
+option('tests',
|
||||
+ description: 'Whether to build tests',
|
||||
+ type: 'boolean',
|
||||
+ value: true)
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,22 +0,0 @@
|
||||
config BR2_PACKAGE_AT_SPI2_ATK
|
||||
bool "at-spi2-atk"
|
||||
depends on BR2_PACKAGE_XORG7 # at-spi2-core
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
|
||||
depends on BR2_USE_MMU # glib2
|
||||
depends on BR2_USE_WCHAR # glib2
|
||||
select BR2_PACKAGE_ATK
|
||||
select BR2_PACKAGE_AT_SPI2_CORE
|
||||
select BR2_PACKAGE_LIBGLIB2
|
||||
help
|
||||
The At-Spi2 Atk package contains a library that bridges
|
||||
ATK to At-Spi2 D-Bus service.
|
||||
|
||||
https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/
|
||||
|
||||
comment "at-spi2-atk needs a toolchain w/ wchar, threads"
|
||||
depends on BR2_USE_MMU
|
||||
depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
|
||||
|
||||
comment "at-spi2-atk depends on X.org"
|
||||
depends on BR2_USE_MMU
|
||||
depends on !BR2_PACKAGE_XORG7
|
@ -1,5 +0,0 @@
|
||||
# From http://ftp.acc.umu.se/pub/gnome/sources/at-spi2-atk/2.34/at-spi2-atk-2.34.2.sha256sum
|
||||
sha256 901323cee0eef05c01ec4dee06c701aeeca81a314a7d60216fa363005e27f4f0 at-spi2-atk-2.34.2.tar.xz
|
||||
|
||||
# locally calculated
|
||||
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING
|
@ -1,19 +0,0 @@
|
||||
################################################################################
|
||||
#
|
||||
# at-spi2-atk
|
||||
#
|
||||
################################################################################
|
||||
|
||||
AT_SPI2_ATK_VERSION_MAJOR = 2.34
|
||||
AT_SPI2_ATK_VERSION = $(AT_SPI2_ATK_VERSION_MAJOR).2
|
||||
AT_SPI2_ATK_SOURCE = at-spi2-atk-$(AT_SPI2_ATK_VERSION).tar.xz
|
||||
AT_SPI2_ATK_SITE = \
|
||||
http://ftp.gnome.org/pub/gnome/sources/at-spi2-atk/$(AT_SPI2_ATK_VERSION_MAJOR)
|
||||
AT_SPI2_ATK_LICENSE = LGPL-2.1+
|
||||
AT_SPI2_ATK_LICENSE_FILES = COPYING
|
||||
AT_SPI2_ATK_CPE_ID_VENDOR = gnome
|
||||
AT_SPI2_ATK_INSTALL_STAGING = YES
|
||||
AT_SPI2_ATK_DEPENDENCIES = atk at-spi2-core libglib2 host-pkgconf
|
||||
AT_SPI2_ATK_CONF_OPTS = -Dtests=false
|
||||
|
||||
$(eval $(meson-package))
|
Loading…
Reference in New Issue
Block a user