package/raspberrypi-usbboot: bump version to 20221215-105525
The "msd" (mass storage device) firmware files in 2021.07.01 don't work with some newer CM4 based devices, the one I had issues with is a RevPi Connect 4. Updating fixes the issue. Mass storage device mode is required to flash the eMMC of CM4 devices. Signed-off-by: Fiona Klute <fiona.klute+wiwa@gmx.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> (cherry picked from commit fbd9a3f3114ef52d6ff9a14ec2648926909fd46e) Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
9cddd68f8e
commit
2e34d5638d
@ -1,4 +1,4 @@
|
|||||||
From 38b730c00f45abf324caf687b5b00662ff4252c2 Mon Sep 17 00:00:00 2001
|
From acd175aa53af1f1b8422bf1f1fe57eafc710cdca Mon Sep 17 00:00:00 2001
|
||||||
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
Date: Fri, 2 Dec 2016 23:09:44 +0100
|
Date: Fri, 2 Dec 2016 23:09:44 +0100
|
||||||
Subject: [PATCH] Makefile: allow passing CFLAGS/LDFLAGS
|
Subject: [PATCH] Makefile: allow passing CFLAGS/LDFLAGS
|
||||||
@ -10,21 +10,25 @@ Submitted-upstream: https://github.com/raspberrypi/usbboot/pull/2
|
|||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
[Rebased on 9324fd7]
|
[Rebased on 9324fd7]
|
||||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||||
|
[Rebased on 20221215-105525-0-g1afa26c5]
|
||||||
|
Signed-off-by: Fiona Klute <fiona.klute+wiwa@gmx.de>
|
||||||
---
|
---
|
||||||
Makefile | 2 +-
|
Makefile | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 822e714..875e717 100755
|
index dc78cfe..c9d4910 100755
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1,5 +1,5 @@
|
@@ -1,7 +1,7 @@
|
||||||
|
PKG_VER=$(shell grep rpiboot debian/changelog | head -n1 | sed 's/.*(\(.*\)).*/\1/g')
|
||||||
|
GIT_VER=$(shell git rev-parse HEAD 2>/dev/null | cut -c1-8 || echo "")
|
||||||
rpiboot: main.c msd/bootcode.h msd/start.h msd/bootcode4.h msd/start4.h
|
rpiboot: main.c msd/bootcode.h msd/start.h msd/bootcode4.h msd/start4.h
|
||||||
- $(CC) -Wall -Wextra -g -o $@ $< -lusb-1.0
|
- $(CC) -Wall -Wextra -g -o $@ $< `pkg-config --cflags --libs libusb-1.0` -DGIT_VER="\"$(GIT_VER)\"" -DPKG_VER="\"$(PKG_VER)\""
|
||||||
+ $(CC) -Wall -Wextra -g $(CFLAGS) -o $@ $< -lusb-1.0 $(LDFLAGS)
|
+ $(CC) -Wall -Wextra -g $(CFLAGS) -o $@ $< `pkg-config --cflags --libs libusb-1.0` -DGIT_VER="\"$(GIT_VER)\"" -DPKG_VER="\"$(PKG_VER)\"" $(LDFLAGS)
|
||||||
|
|
||||||
%.h: %.bin ./bin2c
|
%.h: %.bin ./bin2c
|
||||||
./bin2c $< $@
|
./bin2c $< $@
|
||||||
--
|
--
|
||||||
2.31.1
|
2.45.2
|
||||||
|
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
# Locally calculated
|
# Locally calculated
|
||||||
sha256 4565314b38e7c7505b7d32a3b51b49f79c7dd5767d45b86d38e5255ae7489a43 raspberrypi-usbboot-2021.07.01.tar.gz
|
sha256 2f02dbe9a88e9dfad5f05e513e1f30afd47b1575820f7c3b09665dfefc45bbaa raspberrypi-usbboot-20221215-105525.tar.gz
|
||||||
|
|
||||||
# License files
|
# License files
|
||||||
sha256 b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1 LICENSE
|
sha256 b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1 LICENSE
|
||||||
|
@ -4,9 +4,9 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
RASPBERRYPI_USBBOOT_VERSION = 2021.07.01
|
RASPBERRYPI_USBBOOT_VERSION = 20221215-105525
|
||||||
RASPBERRYPI_USBBOOT_SITE = \
|
RASPBERRYPI_USBBOOT_SITE = \
|
||||||
$(call github,raspberrypi,usbboot,v$(RASPBERRYPI_USBBOOT_VERSION))
|
$(call github,raspberrypi,usbboot,$(RASPBERRYPI_USBBOOT_VERSION))
|
||||||
RASPBERRYPI_USBBOOT_LICENSE = Apache-2.0
|
RASPBERRYPI_USBBOOT_LICENSE = Apache-2.0
|
||||||
RASPBERRYPI_USBBOOT_LICENSE_FILES = LICENSE
|
RASPBERRYPI_USBBOOT_LICENSE_FILES = LICENSE
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user