package/azmq: bump to version 1.0.3
- Drop patch and use AZMQ_NO_TESTS which is available since3548638b9b
- boost log (and so NPTL) is not a dependency since3548638b9b
- boost regex is not a dependency since209ccdc318
- Update indentation in hash file (two spaces) https://github.com/zeromq/azmq/releases/tag/v1.0.3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
fe0e1020a3
commit
2db0ec0692
@ -1,43 +0,0 @@
|
||||
From d960f93fb52e373f76cfedbee5f4fb0c5276856a Mon Sep 17 00:00:00 2001
|
||||
From: RJ Ascani <rj.ascani@gmail.com>
|
||||
Date: Thu, 20 Jul 2017 15:53:40 -0700
|
||||
Subject: [PATCH] Conditionally disable test and doc builds
|
||||
|
||||
Signed-off-by: RJ Ascani <rj.ascani@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 12 +++++++++---
|
||||
1 file changed, 9 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 5b5b9cc..97006a4 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -49,7 +49,9 @@ include_directories(${Boost_INCLUDE_DIRS}
|
||||
${ZeroMQ_INCLUDE_DIRS}
|
||||
${PROJECT_SOURCE_DIR})
|
||||
|
||||
-enable_testing()
|
||||
+if (BUILD_TESTING)
|
||||
+ enable_testing()
|
||||
+endif()
|
||||
|
||||
macro(add_catch_test name)
|
||||
if (TEST_REPORT_FORMAT)
|
||||
@@ -59,8 +61,12 @@ macro(add_catch_test name)
|
||||
endif()
|
||||
endmacro()
|
||||
|
||||
-add_subdirectory(test)
|
||||
-add_subdirectory(doc)
|
||||
+if (BUILD_TESTING)
|
||||
+ add_subdirectory(test)
|
||||
+endif()
|
||||
+if (BUILD_DOC)
|
||||
+ add_subdirectory(doc)
|
||||
+endif()
|
||||
|
||||
install(DIRECTORY ${PROJECT_SOURCE_DIR}/azmq
|
||||
DESTINATION include)
|
||||
--
|
||||
2.13.3
|
||||
|
@ -2,7 +2,7 @@ config BR2_PACKAGE_AZMQ
|
||||
bool "azmq"
|
||||
depends on BR2_INSTALL_LIBSTDCPP
|
||||
depends on BR2_TOOLCHAIN_HAS_ATOMIC
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # boost-log
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS # boost, zeromq
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
|
||||
depends on BR2_USE_WCHAR # boost
|
||||
depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS # boost-thread
|
||||
@ -11,9 +11,7 @@ config BR2_PACKAGE_AZMQ
|
||||
select BR2_PACKAGE_BOOST
|
||||
select BR2_PACKAGE_BOOST_CHRONO
|
||||
select BR2_PACKAGE_BOOST_DATE_TIME
|
||||
select BR2_PACKAGE_BOOST_LOG
|
||||
select BR2_PACKAGE_BOOST_RANDOM
|
||||
select BR2_PACKAGE_BOOST_REGEX
|
||||
select BR2_PACKAGE_BOOST_SYSTEM
|
||||
select BR2_PACKAGE_BOOST_THREAD
|
||||
help
|
||||
@ -21,10 +19,10 @@ config BR2_PACKAGE_AZMQ
|
||||
|
||||
https://github.com/zeromq/azmq
|
||||
|
||||
comment "azmq needs a toolchain w/ C++11, wchar and NPTL"
|
||||
comment "azmq needs a toolchain w/ C++11, wchar and threads"
|
||||
depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS
|
||||
depends on !(BR2_INSTALL_LIBSTDCPP && BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 \
|
||||
&& BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS_NPTL)
|
||||
&& BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS)
|
||||
|
||||
comment "azmq needs exception_ptr"
|
||||
depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
|
||||
|
@ -1,4 +1,3 @@
|
||||
# Locally calculated
|
||||
# https://github.com/zeromq/azmq/archive/v1.0.2.tar.gz
|
||||
sha256 25fa8b07756cffae95e25a55c7ea42efe02e8cd797552201aa771dd69cfc8fbf azmq-1.0.2.tar.gz
|
||||
sha256 c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566 LICENSE-BOOST_1_0
|
||||
sha256 80cfb951c5614b8c2e55a59ea2e5723a18ebed08da80e5420e525d6bf273771a azmq-1.0.3.tar.gz
|
||||
sha256 c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566 LICENSE-BOOST_1_0
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
AZMQ_VERSION = 1.0.2
|
||||
AZMQ_VERSION = 1.0.3
|
||||
AZMQ_SITE = $(call github,zeromq,azmq,v$(AZMQ_VERSION))
|
||||
AZMQ_DEPENDENCIES = boost zeromq
|
||||
AZMQ_LICENSE = BSL-1.0
|
||||
@ -15,4 +15,6 @@ AZMQ_LICENSE_FILES = LICENSE-BOOST_1_0
|
||||
AZMQ_INSTALL_STAGING = YES
|
||||
AZMQ_INSTALL_TARGET = NO
|
||||
|
||||
AZMQ_CONF_OPTS = -DAZMQ_NO_TESTS=ON
|
||||
|
||||
$(eval $(cmake-package))
|
||||
|
Loading…
Reference in New Issue
Block a user