package/valgrind: bump version to 3.20.0

- remove 0003-coregrind-fix-compilation-for-uclibc.patch
  (from upstream [1]) and drop AUTORECONF

For details see [2].

[1] https://sourceware.org/git/?p=valgrind.git;a=commit;h=9c9fd9ae24b45f915f0759d32f662835c26d37c3
[2] https://www.valgrind.org/docs/manual/dist.news.html

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Peter Seiderer 2023-03-29 22:56:59 +02:00 committed by Yann E. MORIN
parent 9507e5a4b4
commit 2d7cfd49ba
3 changed files with 3 additions and 70 deletions

View File

@ -1,65 +0,0 @@
From 9c9fd9ae24b45f915f0759d32f662835c26d37c3 Mon Sep 17 00:00:00 2001
From: Dario Binacchi <dario.binacchi@amarulasolutions.com>
Date: Fri, 8 Apr 2022 12:36:33 +0200
Subject: [PATCH] coregrind: fix compilation for uclibc
It fixes a known iusse whose details are described at [1] and more
generally it guarantees that Valgrind is properly compiled for ulibc.
[1] https://www.mail-archive.com/valgrind-users@lists.sourceforge.net/msg05295.html
Suggested-by Michael Trimarchi <michael@amarulasolutions.com>
Co-developed-by: Michael Trimarchi <michael@amarulasolutions.com>
Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
---
configure.ac | 2 ++
coregrind/m_debuginfo/minilzo-inl.c | 4 ++++
coregrind/vg_preloaded.c | 4 ++++
3 files changed, 10 insertions(+)
diff --git a/configure.ac b/configure.ac
index 6f51dfd9f8fb..c627a9c17a4a 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1204,6 +1204,8 @@ AC_SUBST(DEFAULT_SUPP)
AC_CHECK_HEADER([features.h])
if test x$ac_cv_header_features_h = xyes; then
+ AC_DEFINE([HAVE_HEADER_FEATURES_H], 1,
+ [Define to 1 if you have the `features.h' header.])
rm -f conftest.$ac_ext
cat <<_ACEOF >conftest.$ac_ext
#include <features.h>
diff --git a/coregrind/m_debuginfo/minilzo-inl.c b/coregrind/m_debuginfo/minilzo-inl.c
index 153d008fd44f..b45ec92eaa85 100644
--- a/coregrind/m_debuginfo/minilzo-inl.c
+++ b/coregrind/m_debuginfo/minilzo-inl.c
@@ -1875,6 +1875,10 @@ extern "C" {
#endif
+#ifdef HAVE_HEADER_FEATURES_H
+#include <features.h>
+#endif
+
#undef LZO_HAVE_CONFIG_H
#include "minilzo.h"
diff --git a/coregrind/vg_preloaded.c b/coregrind/vg_preloaded.c
index 5e2098390847..3809811aede7 100644
--- a/coregrind/vg_preloaded.c
+++ b/coregrind/vg_preloaded.c
@@ -45,6 +45,10 @@
#include "pub_core_debuginfo.h" // Needed for pub_core_redir.h
#include "pub_core_redir.h" // For VG_NOTIFY_ON_LOAD
+#ifdef HAVE_HEADER_FEATURES_H
+#include <features.h>
+#endif
+
#if defined(VGO_linux) || defined(VGO_solaris) || defined(VGO_freebsd)
/* ---------------------------------------------------------------------
--
2.32.0

View File

@ -1,7 +1,7 @@
# From https://valgrind.org/downloads/current.html
md5 4687a4990585a038c52f842448ef4e63 valgrind-3.19.0.tar.bz2
md5 e3ca8e03c6c527e80e7da5135a1b6beb valgrind-3.20.0.tar.bz2
# locally computed
sha256 dd5e34486f1a483ff7be7300cc16b4d6b24690987877c3278d797534d6738f02 valgrind-3.19.0.tar.bz2
sha256 8536c031dbe078d342f121fa881a9ecd205cb5a78e639005ad570011bdb9f3c6 valgrind-3.20.0.tar.bz2
# License files
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING

View File

@ -4,7 +4,7 @@
#
################################################################################
VALGRIND_VERSION = 3.19.0
VALGRIND_VERSION = 3.20.0
VALGRIND_SITE = https://sourceware.org/pub/valgrind
VALGRIND_SOURCE = valgrind-$(VALGRIND_VERSION).tar.bz2
VALGRIND_LICENSE = GPL-2.0, GFDL-1.2
@ -14,8 +14,6 @@ VALGRIND_CONF_OPTS = \
--disable-ubsan \
--without-mpicc
VALGRIND_INSTALL_STAGING = YES
# 0003-coregrind-fix-compilation-for-uclibc.patch
VALGRIND_AUTORECONF=YES
# Valgrind must be compiled with no stack protection, so forcefully
# pass -fno-stack-protector to override what Buildroot may have in