heimdal: backport upstream commit to fix parallel build

Thanks to Vicente for an initial patch, and to Gustavo for pointing
out the relevant upstream fix.

Fixes:

  http://autobuild.buildroot.net/results/3a4/3a42c5b294a9a8602844ed1127ec5eadb60a6bed/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Petazzoni 2015-07-14 13:35:43 +02:00
parent b0e5bef3e3
commit 2b34208115
2 changed files with 37 additions and 0 deletions

View File

@ -0,0 +1,35 @@
From 18fe7d300f133c2b9eb93bb4bd81e4644979a74b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jakub=20=C4=8Cajka?= <jcajka@redhat.com>
Date: Tue, 1 Jul 2014 13:13:43 -0600
Subject: [PATCH] kadm5: fix race in Makefile with kadm5_err.h
When running make with -j4, occasionally kadm5 fails due to a missing
header file kadm5_err.h. Fix the race condition.
Reported at https://bugzilla.redhat.com/1115164
Reviewed-by: Ken Dreyer <ktdreyer@ktdreyer.com>
Backported from upstream commit
6affa4cceceaa1369dd895f8acdd7a883ee65674.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
lib/kadm5/Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/kadm5/Makefile.am b/lib/kadm5/Makefile.am
index f8be3b1..1b399b1 100644
--- a/lib/kadm5/Makefile.am
+++ b/lib/kadm5/Makefile.am
@@ -155,6 +155,7 @@ iprop-commands.c iprop-commands.h: iprop-commands.in
$(SLC) $(srcdir)/iprop-commands.in
$(libkadm5srv_la_OBJECTS): kadm5_err.h
+$(libkadm5clnt_la_OBJECTS): kadm5_err.h
$(iprop_log_OBJECTS): iprop-commands.h
client_glue.lo server_glue.lo: $(srcdir)/common_glue.c
--
2.4.5

View File

@ -26,6 +26,8 @@ HOST_HEIMDAL_CONF_OPTS = \
HOST_HEIMDAL_CONF_ENV = MAKEINFO=true
HEIMDAL_LICENSE = BSD-3c
HEIMDAL_LICENSE_FILES = LICENSE
# 0002-kadm5-fix-race-in-Makefile-with-kadm5_err.h.patch
HEIMDAL_AUTORECONF = YES
# We need asn1_compile in the PATH for samba4
define HOST_HEIMDAL_MAKE_SYMLINK