libroxml: fix avr32 build failure
The -Wno-unused-result option is not understood by the version of gcc used by the avr32 toolchain. Remove the option from the compilation flags. Fixes build failures such as the following. http://autobuild.buildroot.net/results/e22/e22d94fca3eabb4e54d82af04319f17ad8e10c20/ The single existing patch for libroxml has been renamed to include a numerical component for application order sorting. The existing patch has also been updated to apply without fuzz. Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
2b468f1bd9
commit
2b2c657957
@ -11,7 +11,7 @@ Index: a/Makefile
|
||||
===================================================================
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -41,7 +41,7 @@
|
||||
@@ -46,7 +46,7 @@
|
||||
|
||||
# options
|
||||
override CPPFLAGS += -Iinc/
|
21
package/libroxml/libroxml-0002-wno-unused-result.patch
Normal file
21
package/libroxml/libroxml-0002-wno-unused-result.patch
Normal file
@ -0,0 +1,21 @@
|
||||
The -Wno-unused-result option is not understood by the version of gcc used by the
|
||||
avr32 toolchain. Remove the option from the compilation flags.
|
||||
|
||||
Fixes build failures such as the following.
|
||||
|
||||
http://autobuild.buildroot.net/results/e22/e22d94fca3eabb4e54d82af04319f17ad8e10c20/
|
||||
|
||||
Signed-off-by: Simon Dawson <spdawson@gmail.com>
|
||||
|
||||
diff -Nurp a/Makefile b/Makefile
|
||||
--- a/Makefile 2013-11-21 17:13:17.679388374 +0000
|
||||
+++ b/Makefile 2013-11-21 17:13:35.219299157 +0000
|
||||
@@ -46,7 +46,7 @@ DEFINES = -DIGNORE_EMPTY_TEXT_NODES
|
||||
|
||||
# options
|
||||
override CPPFLAGS += -Iinc/
|
||||
-override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Wno-unused-result -Iinc/ $(DEFINES)
|
||||
+override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused-parameter -Iinc/ $(DEFINES)
|
||||
override LDFLAGS +=
|
||||
|
||||
ifeq ("$(OS)", "Darwin")
|
Loading…
Reference in New Issue
Block a user