bison: bump to version 2.4.3

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Gustavo Zacarias 2010-12-17 13:21:56 -03:00 committed by Peter Korsgaard
parent 15bcaba70a
commit 2a92cee21a
3 changed files with 26 additions and 3 deletions

View File

@ -1,8 +1,12 @@
config BR2_PACKAGE_BISON
bool "bison"
depends on BR2_USE_WCHAR
help
General-purpose parser generator that converts a
grammar description for an LALR context-free grammar into a C
program to parse that grammar.
http://www.gnu.org/software/bison/
comment "bison requires a toolchain with WCHAR support"
depends on !BR2_USE_WCHAR

View File

@ -0,0 +1,19 @@
uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
and is not needed too per standard. gnulib attempts to use it but we have to account
for it because in this case uclibc does not behave like glibc.
-Khem
http://bugs.gentoo.org/336484
--- m4-1.4.14/lib/spawn.in.h
+++ m4-1.4.14/lib/spawn.in.h
@@ -31,7 +31,7 @@
/* Get definitions of 'struct sched_param' and 'sigset_t'.
But avoid namespace pollution on glibc systems. */
-#ifndef __GLIBC__
+#if !defined __GLIBC__ || defined __UCLIBC__
# include <sched.h>
# include <signal.h>
#endif

View File

@ -3,9 +3,9 @@
# bison
#
#############################################################
BISON_VERSION:=2.3
BISON_SOURCE:=bison-$(BISON_VERSION).tar.bz2
BISON_SITE:=$(BR2_GNU_MIRROR)/bison
BISON_VERSION = 2.4.3
BISON_SITE = $(BR2_GNU_MIRROR)/bison
define BISON_DISABLE_EXAMPLES
echo 'all install:' > $(@D)/examples/Makefile