package/libglib2: bump to version 2.70.4
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
d96b9ed073
commit
2a8ceb5cb3
@ -35,7 +35,7 @@ index 4bbf4c2..ac59f4e 100644
|
||||
@@ -1,4 +1,4 @@
|
||||
-project('glib', 'c', 'cpp',
|
||||
+project('glib', 'c',
|
||||
version : '2.70.0',
|
||||
version : '2.70.4',
|
||||
# NOTE: We keep this pinned at 0.49 because that's what Debian 10 ships
|
||||
meson_version : '>= 0.49.2',
|
||||
@@ -10,7 +10,6 @@ project('glib', 'c', 'cpp',
|
||||
@ -46,7 +46,7 @@ index 4bbf4c2..ac59f4e 100644
|
||||
|
||||
cc_can_run = not meson.is_cross_build() or meson.has_exe_wrapper()
|
||||
|
||||
@@ -1679,20 +1678,6 @@ if g_have_iso_c_varargs
|
||||
@@ -1696,20 +1695,6 @@ if g_have_iso_c_varargs
|
||||
#endif''')
|
||||
endif
|
||||
|
||||
@ -67,7 +67,7 @@ index 4bbf4c2..ac59f4e 100644
|
||||
g_have_gnuc_varargs = cc.compiles('''
|
||||
void some_func (void) {
|
||||
int a(int p1, int p2, int p3);
|
||||
@@ -2330,7 +2315,6 @@ subdir('gobject')
|
||||
@@ -2339,7 +2324,6 @@ subdir('gobject')
|
||||
subdir('gthread')
|
||||
subdir('gmodule')
|
||||
subdir('gio')
|
||||
|
@ -16,7 +16,7 @@ diff --git a/meson.build b/meson.build
|
||||
index 3c615b7..7cae4e8 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -431,6 +431,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
||||
@@ -435,6 +435,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
||||
# building with -Wbad-function-cast.
|
||||
'-Wno-bad-function-cast',
|
||||
'-Wno-cast-function-type',
|
||||
|
@ -23,7 +23,7 @@ diff --git a/gio/meson.build b/gio/meson.build
|
||||
index 29473d26b..112d4ada9 100644
|
||||
--- a/gio/meson.build
|
||||
+++ b/gio/meson.build
|
||||
@@ -831,6 +831,7 @@ pkg.generate(libgio,
|
||||
@@ -841,6 +841,7 @@ pkg.generate(libgio,
|
||||
variables : ['datadir=' + join_paths('${prefix}', get_option('datadir')),
|
||||
'schemasdir=' + join_paths('${datadir}', schemas_subdir),
|
||||
'bindir=' + join_paths('${prefix}', get_option('bindir')),
|
||||
@ -35,7 +35,7 @@ diff --git a/glib/meson.build b/glib/meson.build
|
||||
index f78f32969..6c5486699 100644
|
||||
--- a/glib/meson.build
|
||||
+++ b/glib/meson.build
|
||||
@@ -377,6 +377,7 @@ pkg.generate(libglib,
|
||||
@@ -384,6 +384,7 @@ pkg.generate(libglib,
|
||||
subdirs : ['glib-2.0'],
|
||||
extra_cflags : ['-I${libdir}/glib-2.0/include'] + win32_cflags,
|
||||
variables : ['bindir=' + join_paths('${prefix}', get_option('bindir')),
|
||||
|
@ -1,4 +1,4 @@
|
||||
# https://download.gnome.org/sources/glib/2.70/glib-2.70.0.sha256sum
|
||||
sha256 200d7df811c5ba634afbf109f14bb40ba7fde670e89389885da14e27c0840742 glib-2.70.0.tar.xz
|
||||
# https://download.gnome.org/sources/glib/2.70/glib-2.70.4.sha256sum
|
||||
sha256 ab3d176f3115dcc4e5d02db795984e04e4f4b48d836252e23e8c468e9d423c33 glib-2.70.4.tar.xz
|
||||
# License files, locally calculated
|
||||
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING
|
||||
|
@ -5,7 +5,7 @@
|
||||
################################################################################
|
||||
|
||||
LIBGLIB2_VERSION_MAJOR = 2.70
|
||||
LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).0
|
||||
LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).4
|
||||
LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.xz
|
||||
LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
|
||||
LIBGLIB2_LICENSE = LGPL-2.1+
|
||||
|
Loading…
Reference in New Issue
Block a user