boot/arm-trusted-firmware: add config option to use latest lts-v2.8.13
Patch 0001-feat-build-add-support-for-new-binutils-versions.patch as found in v2.8 patch dir has already been applied in lts-v2.8.13 Patch 0002-build-tools-avoid-unnecessary-link.patch from v2.8 has been included as 0001-build-tools-avoid-unnecessary-link.patch for lts-v2.8.13 Signed-off-by: Marleen Vos <marleen.vos@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
c6ab9328e1
commit
2a310666e0
@ -16,6 +16,11 @@ choice
|
|||||||
config BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_VERSION
|
config BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_VERSION
|
||||||
bool "v2.10"
|
bool "v2.10"
|
||||||
|
|
||||||
|
config BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_LTS_2_8_VERSION
|
||||||
|
bool "latest lts-v2.8.x"
|
||||||
|
help
|
||||||
|
Select the latest LTS v2.8.x version available
|
||||||
|
|
||||||
config BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_VERSION
|
config BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_VERSION
|
||||||
bool "Custom version"
|
bool "Custom version"
|
||||||
help
|
help
|
||||||
@ -43,6 +48,7 @@ config BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_VERSION_VALUE
|
|||||||
config BR2_TARGET_ARM_TRUSTED_FIRMWARE_VERSION
|
config BR2_TARGET_ARM_TRUSTED_FIRMWARE_VERSION
|
||||||
string
|
string
|
||||||
default "v2.10" if BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_VERSION
|
default "v2.10" if BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_VERSION
|
||||||
|
default "lts-v2.8.13" if BR2_TARGET_ARM_TRUSTED_FIRMWARE_LATEST_LTS_2_8_VERSION
|
||||||
default "custom" if BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL
|
default "custom" if BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL
|
||||||
default BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_REPO_VERSION \
|
default BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_REPO_VERSION \
|
||||||
if BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_GIT
|
if BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_GIT
|
||||||
|
@ -1,3 +1,4 @@
|
|||||||
# Locally calculated
|
# Locally calculated
|
||||||
sha256 2e18b881ada9198173238cca80086c787b1fa3f698944bde1743142823fc511c arm-trusted-firmware-v2.10.tar.gz
|
sha256 2e18b881ada9198173238cca80086c787b1fa3f698944bde1743142823fc511c arm-trusted-firmware-v2.10.tar.gz
|
||||||
|
sha256 e55ae7105c996b60f748b2eb6adeaf5ac8946425e1d4294ecc1c56aebf435274 arm-trusted-firmware-lts-v2.8.13.tar.gz
|
||||||
sha256 130d0c6e5159fa454b1e969fd281fa1d388819aefb203f65dd282544b5ab7ba9 docs/license.rst
|
sha256 130d0c6e5159fa454b1e969fd281fa1d388819aefb203f65dd282544b5ab7ba9 docs/license.rst
|
||||||
|
@ -0,0 +1,77 @@
|
|||||||
|
From aa57ce632c629fe72ff417e261e0f5bfd8db6bab Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Vincent=20Stehl=C3=A9?= <vincent.stehle@arm.com>
|
||||||
|
Date: Tue, 4 Jul 2023 16:14:02 +0200
|
||||||
|
Subject: [PATCH] build(tools): avoid unnecessary link
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
In their respective makefiles, cert_create, encrypt_fw and fiptool
|
||||||
|
depend on the --openssl phony target as a prerequisite. This forces
|
||||||
|
those tools to be re-linked each time.
|
||||||
|
|
||||||
|
Move the dependencies on the --openssl target from the tools to their
|
||||||
|
makefiles all targets, to avoid unnecessary linking while preserving the
|
||||||
|
OpenSSL version printing done in the --openssl targets when in debug.
|
||||||
|
|
||||||
|
Fixes: cf2dd17ddda2 ("refactor(security): add OpenSSL 1.x compatibility")
|
||||||
|
Signed-off-by: Vincent Stehlé <vincent.stehle@arm.com>
|
||||||
|
Change-Id: I98a3ab30f36dffc253cecaaf3a57d2712522135d
|
||||||
|
Upstream: https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/commit/?id=aa57ce632c629fe72ff417e261e0f5bfd8db6bab
|
||||||
|
---
|
||||||
|
tools/cert_create/Makefile | 4 ++--
|
||||||
|
tools/encrypt_fw/Makefile | 4 ++--
|
||||||
|
tools/fiptool/Makefile | 4 ++--
|
||||||
|
3 files changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tools/cert_create/Makefile b/tools/cert_create/Makefile
|
||||||
|
index 042e844626..b911d19d2b 100644
|
||||||
|
--- a/tools/cert_create/Makefile
|
||||||
|
+++ b/tools/cert_create/Makefile
|
||||||
|
@@ -85,9 +85,9 @@ HOSTCC ?= gcc
|
||||||
|
|
||||||
|
.PHONY: all clean realclean --openssl
|
||||||
|
|
||||||
|
-all: ${BINARY}
|
||||||
|
+all: --openssl ${BINARY}
|
||||||
|
|
||||||
|
-${BINARY}: --openssl ${OBJECTS} Makefile
|
||||||
|
+${BINARY}: ${OBJECTS} Makefile
|
||||||
|
@echo " HOSTLD $@"
|
||||||
|
@echo 'const char build_msg[] = "Built : "__TIME__", "__DATE__; \
|
||||||
|
const char platform_msg[] = "${PLAT_MSG}";' | \
|
||||||
|
diff --git a/tools/encrypt_fw/Makefile b/tools/encrypt_fw/Makefile
|
||||||
|
index 2939b142be..924e5febab 100644
|
||||||
|
--- a/tools/encrypt_fw/Makefile
|
||||||
|
+++ b/tools/encrypt_fw/Makefile
|
||||||
|
@@ -65,9 +65,9 @@ HOSTCC ?= gcc
|
||||||
|
|
||||||
|
.PHONY: all clean realclean --openssl
|
||||||
|
|
||||||
|
-all: ${BINARY}
|
||||||
|
+all: --openssl ${BINARY}
|
||||||
|
|
||||||
|
-${BINARY}: --openssl ${OBJECTS} Makefile
|
||||||
|
+${BINARY}: ${OBJECTS} Makefile
|
||||||
|
@echo " HOSTLD $@"
|
||||||
|
@echo 'const char build_msg[] = "Built : "__TIME__", "__DATE__;' | \
|
||||||
|
${HOSTCC} -c ${HOSTCCFLAGS} -xc - -o src/build_msg.o
|
||||||
|
diff --git a/tools/fiptool/Makefile b/tools/fiptool/Makefile
|
||||||
|
index 2ebee33931..4bdebd9235 100644
|
||||||
|
--- a/tools/fiptool/Makefile
|
||||||
|
+++ b/tools/fiptool/Makefile
|
||||||
|
@@ -68,9 +68,9 @@ DEPS := $(patsubst %.o,%.d,$(OBJECTS))
|
||||||
|
|
||||||
|
.PHONY: all clean distclean --openssl
|
||||||
|
|
||||||
|
-all: ${PROJECT}
|
||||||
|
+all: --openssl ${PROJECT}
|
||||||
|
|
||||||
|
-${PROJECT}: --openssl ${OBJECTS} Makefile
|
||||||
|
+${PROJECT}: ${OBJECTS} Makefile
|
||||||
|
@echo " HOSTLD $@"
|
||||||
|
${Q}${HOSTCC} ${OBJECTS} -o $@ ${LDLIBS}
|
||||||
|
@${ECHO_BLANK_LINE}
|
||||||
|
--
|
||||||
|
2.25.1
|
||||||
|
|
Loading…
Reference in New Issue
Block a user