package/flac: bump to version 1.4.0

This release fixes a lot of bugs found by fuzzing, and fuzzing coverage
has improved much. Also, compression should be better but a little
slower. Speedups for 64-bit ARM have been implemented. Encoding and
decoding 32 bps PCM is now possible.

- Drop sha1 (not provided anymore)
- Drop patch (already in version) and so autoreconf
- Update hash of COPYING.Xiph (year updated with:
  10d7ce268b)

https://github.com/xiph/flac/releases/tag/1.4.0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Fabrice Fontaine 2022-09-11 12:51:08 +02:00 committed by Yann E. MORIN
parent 2de6538320
commit 29948fec11
3 changed files with 3 additions and 89 deletions

View File

@ -1,81 +0,0 @@
From 4c62082f64132bfcbcb6569aa914c5ec283303f9 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Mon, 21 Feb 2022 18:21:11 +0100
Subject: [PATCH] Fix uclibc build
Commit 4fbb6d4f2ecf2a96c17ea9880108409f852c08a9 reverted commit
44036c9a9b45d03373fe90e9c112852bfc054c51 and so broke again the build on
uclibc
So put back the sys/auxv.h check as well as a getauxval check in a way
that doesn't break iOS
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/xiph/flac/pull/292]
---
configure.ac | 5 ++++-
src/libFLAC/cpu.c | 9 ++++-----
2 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/configure.ac b/configure.ac
index 4d7dc2e4..6f32fa45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,7 +69,7 @@ AC_C_INLINE
AC_C_VARARRAYS
AC_C_TYPEOF
-AC_CHECK_HEADERS([stdint.h inttypes.h byteswap.h sys/param.h sys/ioctl.h termios.h x86intrin.h cpuid.h])
+AC_CHECK_HEADERS([stdint.h inttypes.h byteswap.h sys/auxv.h sys/param.h sys/ioctl.h termios.h x86intrin.h cpuid.h])
XIPH_C_BSWAP32
XIPH_C_BSWAP16
@@ -101,6 +101,9 @@ fi
# For the XMMS plugin.
AC_CHECK_TYPES(socklen_t, [], [])
+dnl check for getauxval in standard library
+AC_CHECK_FUNCS(getauxval)
+
dnl check for getopt in standard library
dnl AC_CHECK_FUNCS(getopt_long , , [LIBOBJS="$LIBOBJS getopt.o getopt1.o"] )
AC_CHECK_FUNCS(getopt_long, [], [])
diff --git a/src/libFLAC/cpu.c b/src/libFLAC/cpu.c
index 8b92f4c7..64c6acad 100644
--- a/src/libFLAC/cpu.c
+++ b/src/libFLAC/cpu.c
@@ -53,11 +53,9 @@
#define dfprintf(file, format, ...)
#endif
-#if defined FLAC__CPU_PPC
-#if defined(__linux__) || (defined(__FreeBSD__) && (__FreeBSD__ >= 12))
+#if defined(HAVE_SYS_AUXV_H)
#include <sys/auxv.h>
#endif
-#endif
#if (defined FLAC__CPU_IA32 || defined FLAC__CPU_X86_64) && (defined FLAC__HAS_NASM || FLAC__HAS_X86INTRIN) && !defined FLAC__NO_ASM
@@ -247,7 +245,7 @@ ppc_cpu_info (FLAC__CPUInfo *info)
#define PPC_FEATURE2_ARCH_2_07 0x80000000
#endif
-#ifdef __linux__
+#if defined (__linux__) && defined(HAVE_GETAUXVAL)
if (getauxval(AT_HWCAP2) & PPC_FEATURE2_ARCH_3_00) {
info->ppc.arch_3_00 = true;
} else if (getauxval(AT_HWCAP2) & PPC_FEATURE2_ARCH_2_07) {
@@ -267,7 +265,8 @@ ppc_cpu_info (FLAC__CPUInfo *info)
info->ppc.arch_2_07 = false;
info->ppc.arch_3_00 = false;
#else
-#error Unsupported platform! Please add support for reading ppc hwcaps.
+ info->ppc.arch_2_07 = false;
+ info->ppc.arch_3_00 = false;
#endif
#else
--
2.34.1

View File

@ -1,8 +1,6 @@
# From https://ftp.osuosl.org/pub/xiph/releases/flac/SHA1SUMS
sha1 99c28482a8b2d81deaf740639e4cb55658427420 flac-1.3.4.tar.xz
# From http://downloads.xiph.org/releases/flac/SHA256SUMS.txt
sha256 8ff0607e75a322dd7cd6ec48f4f225471404ae2730d0ea945127b1355155e737 flac-1.3.4.tar.xz
sha256 af41c0733c93c237c3e52f64dd87e3b0d9af38259f1c7d11e8cbf583c48c2506 flac-1.4.0.tar.xz
# Locally computed
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING.GPL
sha256 5df07007198989c622f5d41de8d703e7bef3d0e79d62e24332ee739a452af62a COPYING.LGPL
sha256 fa27cb11f13f97b0c5f3ff363b1e2610c6efe87ed175779cb2a78e44eb19d34c COPYING.Xiph
sha256 6e58d3036f05e2a0d58af854c12a505ddbe75011d71a598a2170987f3b15408d COPYING.Xiph

View File

@ -4,7 +4,7 @@
#
################################################################################
FLAC_VERSION = 1.3.4
FLAC_VERSION = 1.4.0
FLAC_SITE = http://downloads.xiph.org/releases/flac
FLAC_SOURCE = flac-$(FLAC_VERSION).tar.xz
FLAC_INSTALL_STAGING = YES
@ -13,9 +13,6 @@ FLAC_LICENSE = Xiph BSD-like (libFLAC), GPL-2.0+ (tools), LGPL-2.1+ (other libra
FLAC_LICENSE_FILES = COPYING.Xiph COPYING.GPL COPYING.LGPL
FLAC_CPE_ID_VENDOR = flac_project
# patch touching configure.ac
FLAC_AUTORECONF = YES
FLAC_CONF_OPTS = \
$(if $(BR2_POWERPC_CPU_HAS_ALTIVEC),--enable-altivec,--disable-altivec) \
$(if $(BR2_INSTALL_LIBSTDCPP),--enable-cpplibs,--disable-cpplibs) \