unionfs: bump to version 1.0

Switch to github homepage and site.
Drop patch, it's not required any more.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Gustavo Zacarias 2015-10-19 18:38:35 -03:00 committed by Thomas Petazzoni
parent 7ef6efe314
commit 29551707f8
4 changed files with 5 additions and 25 deletions

View File

@ -1,19 +0,0 @@
By default, CMake assumes a project uses the C and C++ languages, so
it checks for both the C and the C++ compiler to exist.
However, unionfs-fuse is written purely in C, so checking for a C++
compiler is useless, and even prevents unionfs-fuse from building
properly on targets for which no C++ compiler is available.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-project(unionfs-fuse)
+project(unionfs-fuse C)
cmake_minimum_required(VERSION 2.0)
INCLUDE (CheckIncludeFiles)

View File

@ -7,7 +7,7 @@ config BR2_PACKAGE_UNIONFS
help
A userspace unionfs implementation.
http://podgorny.cz/moin/UnionFsFuse
https://github.com/rpodgorny/unionfs-fuse
comment "unionfs needs a toolchain w/ threads, dynamic library"
depends on BR2_USE_MMU

View File

@ -1,2 +1,2 @@
# locally computed hash
sha256 8d5c9dcb51ecb9a9b03890e16d17e37d602b0c1f23ed6a9ddec2b0f719c9f662 unionfs-fuse-0.26.tar.xz
# Locally computed
sha256 2ee80bd0634a61adb2159212e155d607a0a82ad659214ae6edb3530396cccc09 unionfs-1.0.tar.gz

View File

@ -4,9 +4,8 @@
#
################################################################################
UNIONFS_VERSION = 0.26
UNIONFS_SITE = http://podgorny.cz/unionfs-fuse/releases
UNIONFS_SOURCE = unionfs-fuse-$(UNIONFS_VERSION).tar.xz
UNIONFS_VERSION = 1.0
UNIONFS_SITE = $(call github,rpodgorny,unionfs-fuse,v$(UNIONFS_VERSION))
UNIONFS_DEPENDENCIES = libfuse host-pkgconf
UNIONFS_LICENSE = BSD-3c
UNIONFS_LICENSE_FILES = LICENSE