package/alsa-lib: topology modules need dynamic library support
With this new option we can remove a patch from alsa-utils which fixed its static build. A static build of topology modules is not supported by upstream however: "Note that it does not make sense to build static topology modules. They are not usable." https://github.com/alsa-project/alsa-utils/issues/152#issuecomment-1144485929 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
7935e427bc
commit
28497102e1
@ -80,4 +80,9 @@ config BR2_PACKAGE_ALSA_LIB_OLD_SYMBOLS
|
||||
bool "old-symbols"
|
||||
default y
|
||||
|
||||
config BR2_PACKAGE_ALSA_LIB_TOPOLOGY
|
||||
bool "topology"
|
||||
default y
|
||||
depends on !BR2_STATIC_LIBS
|
||||
|
||||
endif
|
||||
|
@ -58,6 +58,9 @@ endif
|
||||
ifneq ($(BR2_PACKAGE_ALSA_LIB_OLD_SYMBOLS),y)
|
||||
ALSA_LIB_CONF_OPTS += --disable-old-symbols
|
||||
endif
|
||||
ifneq ($(BR2_PACKAGE_ALSA_LIB_TOPOLOGY),y)
|
||||
ALSA_LIB_CONF_OPTS += --disable-topology
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_ALSA_LIB_PYTHON),y)
|
||||
ALSA_LIB_CONF_OPTS += \
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 0e74339bf0751932abf6aa49bf07aa1c035f9ec6 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sun, 14 Aug 2022 20:31:30 +0200
|
||||
Subject: [PATCH] configure.ac: fix build without dlfcn.h
|
||||
|
||||
Fix the following static build failure (i.e. without dlfcn.h) raised
|
||||
since version 1.2.7 and
|
||||
https://github.com/alsa-project/alsa-utils/commit/44d3e8aa44fc12f95bfeef0e3a1051e8f77047b5:
|
||||
|
||||
pre-processor.c:28:10: fatal error: dlfcn.h: No such file or directory
|
||||
28 | #include <dlfcn.h>
|
||||
| ^~~~~~~~~
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/1173a1ee28a58ce565a3274f35e868c35bb2e04e
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: https://github.com/alsa-project/alsa-utils/pull/165]
|
||||
---
|
||||
configure.ac | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 20cbb68..6833800 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -27,6 +27,9 @@ AC_CHECK_FUNC([snd_ctl_elem_add_enumerated],
|
||||
, [AC_ERROR([No user enum control support in alsa-lib])])
|
||||
fi
|
||||
|
||||
+
|
||||
+AC_CHECK_HEADERS([dlfcn.h])
|
||||
+
|
||||
dnl Check components
|
||||
AC_CHECK_HEADERS([alsa/pcm.h], [have_pcm="yes"], [have_pcm="no"],
|
||||
[#include <alsa/asoundlib.h>])
|
||||
@@ -74,7 +77,7 @@ AM_CONDITIONAL(HAVE_MIXER, test "$have_mixer" = "yes")
|
||||
AM_CONDITIONAL(HAVE_RAWMIDI, test "$have_rawmidi" = "yes")
|
||||
AM_CONDITIONAL(HAVE_SEQ, test "$have_seq" = "yes")
|
||||
AM_CONDITIONAL(HAVE_UCM, test "$have_ucm" = "yes")
|
||||
-AM_CONDITIONAL(HAVE_TOPOLOGY, test "$have_topology" = "yes")
|
||||
+AM_CONDITIONAL(HAVE_TOPOLOGY, test "$have_topology" = "yes" -a "$ac_cv_header_dlfcn_h" = "yes")
|
||||
AM_CONDITIONAL(HAVE_SAMPLERATE, test "$have_samplerate" = "yes")
|
||||
AM_CONDITIONAL(HAVE_FFADO, test "$have_ffado" = "yes")
|
||||
|
||||
--
|
||||
2.35.1
|
||||
|
@ -15,9 +15,6 @@ ALSA_UTILS_DEPENDENCIES = host-pkgconf alsa-lib \
|
||||
$(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate) \
|
||||
$(TARGET_NLS_DEPENDENCIES)
|
||||
|
||||
# We're patching configure.ac
|
||||
ALSA_UTILS_AUTORECONF = YES
|
||||
|
||||
ifeq ($(BR2_PACKAGE_ALSA_UTILS_ALSACTL),y)
|
||||
ALSA_UTILS_SELINUX_MODULES += alsa
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user