Update toolchain

This commit is contained in:
Eric Andersen 2002-08-10 10:21:47 +00:00
parent e03b6ce52a
commit 27f3bc3198
2 changed files with 142 additions and 3 deletions

View File

@ -387,9 +387,6 @@ $(GCC_DIR)/.ldso_hacks: $(GCC_DIR)/.patched
$(GCC_DIR)/libstdc++-v3/src/Makefile.am $(GCC_DIR)/libstdc++-v3/src/Makefile.in;
perl -i -p -e "s,3\.0\.0,9.9.0,g;" $(GCC_DIR)/libstdc++-v3/acinclude.m4 \
$(GCC_DIR)/libstdc++-v3/aclocal.m4 $(GCC_DIR)/libstdc++-v3/configure;
# Disable logf() -- we just use log() in uClibc
-perl -i -p -e "s,_GLIBCPP_HAVE_LOGF,0,g;" $(GCC_DIR)/libstdc++-v3/include/c_std/std_cmath.h \
$(GCC_DIR)/libstdc++-v3/include/c_shadow/bits/std_cmath.h
# For now, we don't support locale-ified ctype, so bypass that problem here
cp $(GCC_DIR)/libstdc++-v3/config/os/generic/bits/ctype_base.h \
$(GCC_DIR)/libstdc++-v3/config/os/gnu-linux/bits/

View File

@ -0,0 +1,142 @@
--- gcc-3.1/libstdc++-v3/configure Tue May 7 23:27:59 2002
+++ gcc-3.1-patched/libstdc++-v3/configure Thu Aug 8 11:01:35 2002
@@ -5034,10 +5034,6 @@
EOF
cat >> confdefs.h <<\EOF
-#define HAVE_FREXPF 1
-EOF
-
- cat >> confdefs.h <<\EOF
#define HAVE_HYPOTF 1
EOF
@@ -7873,128 +7869,6 @@
cat >> confdefs.h <<\EOF
#define HAVE_MMAP 1
EOF
-
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ACOSF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ASINF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ATAN2F 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ATANF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_CEILF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_COPYSIGN 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_COPYSIGNF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_COSF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_COSHF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_EXPF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_FABSF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_FINITE 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_FINITEF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_FLOORF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_FMODF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_FREXPF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ISINF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ISINFF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ISNAN 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_ISNANF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_LDEXPF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_LOG10F 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_LOGF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_MODFF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_POWF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_SINF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_SINHF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_SQRTF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_TANF 1
-EOF
-
- cat >> confdefs.h <<\EOF
-#define HAVE_TANHF 1
-EOF
-
;;
esac