package/xml-security-c: bump to version 2.0.4

Version 2.0.4 of the Apache XML Security for C++ has been released,
correcting support for OpenSSL earlier than 1.1.

Version 2.0.3 of the Apache XML Security for C++ has been released,
adding support for OpenSSL 3.0.0.

Drop patch (already in version) and so autoreconf

https://santuario.apache.org/cindex.html

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2022-01-23 22:27:57 +01:00 committed by Thomas Petazzoni
parent 2c7ad667ec
commit 27d08083ed
3 changed files with 3 additions and 56 deletions

View File

@ -1,50 +0,0 @@
From 9d14fad412a497fe83cfc6ab594ddc612512f02a Mon Sep 17 00:00:00 2001
From: Matt Weber <matthew.weber@rockwellcollins.com>
Date: Thu, 4 Jun 2020 20:34:11 -0500
Subject: [PATCH] autoconf variable cache option for getcwd test
The cached variable allows cross compiled builds to successfully set the
desired default for this value without invoking a test.
Fixes:
https://issues.apache.org/jira/browse/SANTUARIO-549
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
---
configure.ac | 20 ++++++++++++--------
1 file changed, 12 insertions(+), 8 deletions(-)
diff --git a/configure.ac b/configure.ac
index b43d7a5..c3d4489 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,14 +74,18 @@ AC_CHECK_FUNCS([strcasecmp])
# Check whether getcwd can dynamically allocate memory.
AC_MSG_CHECKING([whether getcwd(NULL, 0) works])
-AC_RUN_IFELSE([AC_LANG_PROGRAM([#include <stdlib.h>
- #include <unistd.h>],
-[char *cwd = getcwd(NULL, 0);
-return (cwd != NULL) ? EXIT_SUCCESS : EXIT_FAILURE;])],
- [AC_MSG_RESULT(yes)
- AC_DEFINE([XSEC_HAVE_GETCWD_DYN], [1],
- [Define to 1 if getcwd(NULL, 0) works])],
- [AC_MSG_RESULT(no)])
+AC_CACHE_VAL([xml_cv_func_getcwd_null],
+[AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdlib.h>
+ #include <unistd.h>
+ char *cwd = getcwd(NULL, 0);
+ return (cwd != NULL) ? EXIT_SUCCESS : EXIT_FAILURE;]])],
+ [xml_cv_func_getcwd_null=yes],
+ [xml_cv_func_getcwd_null=no])])
+AC_MSG_RESULT([$xml_cv_func_getcwd_null])
+if test $xml_cv_func_getcwd_null = yes; then
+AC_DEFINE([XSEC_HAVE_GETCWD_DYN], [1],
+ [Define to 1 if getcwd(NULL, 0) works])
+fi
AC_LANG(C++)
--
2.17.1

View File

@ -1,3 +1,3 @@
# From http://www.apache.org/dist/santuario/c-library/xml-security-c-2.0.2.tar.gz.sha256
sha256 c303a2b08cb9ca0f5594adcbb83829b1e793175d7114a82f7d78def8bb2e30df xml-security-c-2.0.2.tar.gz
# From http://www.apache.org/dist/santuario/c-library/xml-security-c-2.0.4.tar.gz.sha256
sha256 a78da6720f6c2ba14100d2426131e0d33eac5a2dba5cc11bdd04974b7eb89003 xml-security-c-2.0.4.tar.gz
sha256 c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4 LICENSE.txt

View File

@ -4,7 +4,7 @@
#
################################################################################
XML_SECURITY_C_VERSION = 2.0.2
XML_SECURITY_C_VERSION = 2.0.4
XML_SECURITY_C_SITE = http://archive.apache.org/dist/santuario/c-library
XML_SECURITY_C_LICENSE = Apache-2.0
XML_SECURITY_C_LICENSE_FILES = LICENSE.txt
@ -15,7 +15,4 @@ XML_SECURITY_C_CONF_ENV = \
xml_cv_func_getcwd_null=yes \
CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
# Patched configure.ac
XML_SECURITY_C_AUTORECONF = YES
$(eval $(autotools-package))