python-ipython: new package
Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
1030ea5a5b
commit
2671e7eee3
@ -476,6 +476,7 @@ menu "external python modules"
|
||||
source "package/python-flup/Config.in"
|
||||
source "package/python-id3/Config.in"
|
||||
source "package/python-ipy/Config.in"
|
||||
source "package/python-ipython/Config.in"
|
||||
source "package/python-json-schema-validator/Config.in"
|
||||
source "package/python-keyring/Config.in"
|
||||
source "package/python-libconfig/Config.in"
|
||||
|
10
package/python-ipython/Config.in
Normal file
10
package/python-ipython/Config.in
Normal file
@ -0,0 +1,10 @@
|
||||
config BR2_PACKAGE_PYTHON_IPYTHON
|
||||
bool "python-ipython"
|
||||
depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
|
||||
help
|
||||
IPython is a command shell for interactive computing in multiple
|
||||
programming languages, originally developed for the Python
|
||||
programming language, that offers enhanced introspection, rich
|
||||
media, additional shell syntax, tab completion, and rich history.
|
||||
|
||||
http://ipython.org/
|
@ -0,0 +1,15 @@
|
||||
Set correct Python executable path
|
||||
|
||||
Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com>
|
||||
|
||||
--- python-ipython-2.1.0/setupbase.py 2014-05-21 15:19:12.000000000 -0400
|
||||
+++ python-ipython-2.1.0-new/setupbase.py 2014-07-23 23:34:32.892030423 -0400
|
||||
@@ -394,7 +394,7 @@ class build_scripts_entrypt(build_script
|
||||
|
||||
mod, func = entrypt.split(':')
|
||||
with open(outfile, 'w') as f:
|
||||
- f.write(script_src.format(executable=sys.executable,
|
||||
+ f.write(script_src.format(executable='/usr/bin/env python',
|
||||
mod=mod, func=func))
|
||||
|
||||
return outfiles, outfiles
|
14
package/python-ipython/python-ipython.mk
Normal file
14
package/python-ipython/python-ipython.mk
Normal file
@ -0,0 +1,14 @@
|
||||
################################################################################
|
||||
#
|
||||
# python-ipython
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PYTHON_IPYTHON_VERSION = 2.1.0
|
||||
PYTHON_IPYTHON_SOURCE = ipython-$(PYTHON_IPYTHON_VERSION).tar.gz
|
||||
PYTHON_IPYTHON_SITE = https://pypi.python.org/packages/source/i/ipython/
|
||||
PYTHON_IPYTHON_LICENSE = BSD-3c
|
||||
PYTHON_IPYTHON_LICENSE_FILES = COPYING.rst
|
||||
PYTHON_IPYTHON_SETUP_TYPE = distutils
|
||||
|
||||
$(eval $(python-package))
|
Loading…
Reference in New Issue
Block a user