luajit: fix a runtime error
this patch fixes : luajit: error while loading shared libraries: libluajit-5.1.so.2: cannot open shared object file: No such file or directory Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
7f015d051a
commit
23f7d8ece7
22
package/luajit/luajit-06-install-so.patch
Normal file
22
package/luajit/luajit-06-install-so.patch
Normal file
@ -0,0 +1,22 @@
|
||||
fix the following runtime error :
|
||||
luajit: error while loading shared libraries: libluajit-5.1.so.2: cannot open shared object file: No such file or directory
|
||||
|
||||
by creating two symbolic links:
|
||||
libluajit-5.1.so -> libluajit-5.1.so.2.0.3
|
||||
libluajit-5.1.so.2 -> libluajit-5.1.so.2.0.3
|
||||
|
||||
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
|
||||
|
||||
Index: b/Makefile
|
||||
===================================================================
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -56,7 +56,7 @@
|
||||
INSTALL_STATIC= $(INSTALL_LIB)/$(INSTALL_ANAME)
|
||||
INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
|
||||
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
-INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
+INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT).$(MAJVER)
|
||||
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
||||
INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
|
||||
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
|
Loading…
Reference in New Issue
Block a user