package/file: bump version to 5.45

Patch is included upstream.
See here for Changes in 5.45:
https://mailman.astron.com/pipermail/file/2023-July/001205.html
See here for Changes in 5.44:
https://mailman.astron.com/pipermail/file/2022-December/001042.html

The hash of src/vasprintf.c, which is used as one of the license
files, has been updated due to source code changes that do not affect
the licensing terms.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Waldemar Brodkorb 2023-08-21 11:17:49 +02:00 committed by Thomas Petazzoni
parent 57ff5f7d2a
commit 2298de6853
4 changed files with 4 additions and 44 deletions

View File

@ -449,7 +449,6 @@ package/ffmpeg/0003-libavutil-Fix-mips-build.patch Upstream
package/ffmpeg/0004-configure-add-extralibs-to-extralibs_xxx.patch Upstream
package/ficl/0001-fix-Makefile.patch Upstream
package/ficl/0002-Makefile.linux-pass-LDFLAGS.patch Upstream
package/file/0001-src-file.c-fix-build-without-wide-support.patch Upstream
package/flatbuffers/0001-include-flatbuffers-base.h-fix-build-on-musl.patch Upstream
package/flex/0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch Upstream
package/flex/0002-build-make-it-possible-to-disable-the-build-of-the-f.patch Upstream

View File

@ -1,39 +0,0 @@
From f2ab09d0e1388657f6b7e62bacc383ebea91f5b9 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Wed, 26 Oct 2022 00:23:32 +0200
Subject: [PATCH] src/file.c: fix build without wide support
Fix the following build failure without wide support (e.g. on uclibc)
raised since version 5.43 and
https://github.com/file/file/commit/c80065fe6900be5e794941e29b32440e9969b1c3:
file.c: In function 'fname_print':
file.c:605:10: error: macro "putc" requires 2 arguments, but only 1 given
605 | putc(c);
| ^
Fixes:
- http://autobuild.buildroot.org/results/7ff1dd9f79408d2e6286c005302b6f3c505ab259
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://bugs.astron.com/view.php?id=398]
---
src/file.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/file.c b/src/file.c
index f5f46524..1c23defc 100644
--- a/src/file.c
+++ b/src/file.c
@@ -615,7 +615,7 @@ fname_print(const char *inname)
for (i = 0; i < n; i++) {
unsigned char c = CAST(unsigned char, inname[i]);
if (isprint(c)) {
- putc(c);
+ putc(c, stdout);
continue;
}
file_octal(c);
--
2.35.1

View File

@ -1,7 +1,7 @@
# Locally calculated after verifying signature
# ftp://ftp.astron.com/pub/file/file-5.43.tar.gz.asc
# ftp://ftp.astron.com/pub/file/file-5.45.tar.gz.asc
# using key BE04995BA8F90ED0C0C176C471112AB16CB33B3A
sha256 8c8015e91ae0e8d0321d94c78239892ef9dbc70c4ade0008c0e95894abfb1991 file-5.43.tar.gz
sha256 fc97f51029bb0e2c9f4e3bffefdaf678f0e039ee872b9de5c002a6d09c784d82 file-5.45.tar.gz
sha256 0bfa856a9930bddadbef95d1be1cf4e163c0be618e76ea3275caaf255283e274 COPYING
sha256 4ccb60d623884ef637af4a5bc16b2cb350163e2135e967655837336019a64462 src/mygetopt.h
sha256 cc3d8704489d08eaefcaee8c639cc6436c6f0f6b2b03986d3ba7521a1a1d2fc9 src/vasprintf.c
sha256 2e14b6fa9a74f952ebfde3c96527158df281c953cfaf35609eb854d4da30131c src/vasprintf.c

View File

@ -4,7 +4,7 @@
#
################################################################################
FILE_VERSION = 5.43
FILE_VERSION = 5.45
FILE_SITE = ftp://ftp.astron.com/pub/file
FILE_LICENSE = BSD-2-Clause, BSD-4-Clause (one file), BSD-3-Clause (one file)
FILE_LICENSE_FILES = COPYING src/mygetopt.h src/vasprintf.c